Microsoft Excel 2013
Part 3: Advanced Excel
Spring 2015, Version 1.0

Table of Contents

Introduction ....................................................................................................................................2
Sorting Data....................................................................................................................................2
  Sorting Data by a Single Column .............................................................................................2
  Sorting Data by Multiple Columns .............................................................................................2
Filtering Data .................................................................................................................................3
  Enabling AutoFilter .....................................................................................................................4
  Applying Filters ............................................................................................................................4
  Clearing Filters .............................................................................................................................6
  Disabling AutoFilter ...................................................................................................................7
Entering Data Using AutoFill .......................................................................................................7
Working with Charts .....................................................................................................................8
  Creating Charts ............................................................................................................................9
  Selecting Chart Elements ...........................................................................................................11
  Changing the Chart Type ............................................................................................................11
  Changing the Chart Data ............................................................................................................12
  Changing the Chart Layout ........................................................................................................13
  Formatting Charts ......................................................................................................................15
  Moving Charts ............................................................................................................................17
  Deleting Charts ...........................................................................................................................17
Using Formulas and Functions ....................................................................................................18
  Using Operators in Formulas ......................................................................................................18
  Using Cell References in Formulas ............................................................................................18
  Entering Formulas ......................................................................................................................19
  Displaying Formulas ..................................................................................................................20
  Using Functions in Formulas ......................................................................................................20
    Using the AutoSum Button ........................................................................................................21
    Inserting Functions ...................................................................................................................21
    Using Formula AutoComplete ...............................................................................................23
Password-protecting Workbooks ...............................................................................................24

For additional handouts, visit http://www.calstatela.edu/handouts.
For video tutorials, visit http://www.youtube.com/mycsula.
Introduction

Microsoft Excel 2013 is a spreadsheet program that is used to manage, analyze, and present data. It includes many powerful tools that can be used to organize and manipulate large amounts of data, perform complex calculations, create professional-looking charts, enhance the appearance of worksheets, and more. This handout covers sorting and filtering data, filling cell, creating and modifying charts, using formulas and functions, and protecting workbooks.

Sorting Data

Sorting makes it easier to read or analyze the data in a worksheet. When you sort data, you rearrange the rows based on the contents of a particular column or a set of columns. Rows with duplicate data in the sort column remain in their original order. Rows with blank cells in the sort column are placed last in the sorted list.

You can sort data alphabetically, numerically, or by date in ascending or descending order. *Ascending order* arranges text from A to Z, numbers from smallest to largest, and dates from oldest to newest. *Descending order* arranges text from Z to A, numbers from largest to smallest, and dates from newest to oldest.

**Sorting Data by a Single Column**

You can sort the data in a worksheet by a single column. For example, you may want to sort a list of employees by last name. Data in adjacent columns will be sorted based on the column that you sort by.

To sort data by a single column:
1. Select a cell in the column that you want to sort by.
2. On the **Data** tab, in the **Sort & Filter** group, do one of the following:
   - To sort in ascending order, click the **Sort Ascending** button.
   - To sort in descending order, click the **Sort Descending** button.

   **NOTE:** The names of the sort buttons change to reflect the type of data in the column. If the column contains text, the buttons are named **Sort A to Z** and **Sort Z to A**; for numbers, the buttons are named **Sort Smallest to Largest** and **Sort Largest to Smallest**; and for dates, the buttons are named **Sort Oldest to Newest** and **Sort Newest to Oldest**.

**Sorting Data by Multiple Columns**

You can sort the data in a worksheet by several columns by adding levels of sorting criteria. For example, you can sort a list of employees first by department (to group all the employees in the same department together), and then by last name (to list the names in alphabetical order within each department). You can sort by up to 64 columns.

To sort data by multiple columns:
1. Select a cell in one of the columns that you want to sort by.
2. On the **Data** tab, in the **Sort & Filter** group, click the **Sort** button (see Figure 1). The **Sort** dialog box opens (see Figure 2).

   **NOTE:** Each sort level is represented by a single row in the **Sort** dialog box.
3. If the data has a header row, make sure that the **My data has headers** check box is selected.

   **NOTE:** When the **My data has headers** check box is selected, the first row of data is excluded from the sort and the column headers appear in the **Sort by** list.

4. Under **Column**, click the arrow and select the first column that you want to sort by.
5. Under **Sort On**, click the arrow and select **Values**.
6. Under **Order**, click the arrow and select the desired sort order (e.g., **A to Z**).

   **NOTE:** The options that appear in the **Order** list change to reflect the data to be sorted.

7. To add another column to sort by, click the **Add Level** button, and then repeat steps 4 through 6.

   **NOTE:** You can delete a sort level by selecting it, and then clicking the **Delete Level** button. You can copy a sort level by selecting it, and then clicking the **Copy Level** button. You can change a sort level’s position in the order by selecting it, and then clicking the **Move Up** button or **Move Down** button. Columns higher in the list are sorted before columns lower in the list.

8. When finished, click the **OK** button.

---

**Filtering Data**

Filtering allows you to view or analyze a subset of the data in a large worksheet. When you filter data, Excel displays only those rows that meet the criteria you specify. The rows that do not meet the criteria are hidden, not deleted. You can filter by one or more columns. Each filter limits the data to which you can apply the next filter, helping you narrow down the results. For best results, do not mix data types (such as text and numbers) in the same column because only one type of filter command is available for each column. Excel includes an **AutoFilter** feature that can be used to quickly filter data.
Enabling AutoFilter

In order to use the AutoFilter feature, you must first enable it. When AutoFilter is enabled, Filter arrows appear to the right of the column headings. Before enabling AutoFilter, make sure that the top row of each column has a heading that describes the contents of the column.

To enable AutoFilter:
1. Select a cell within the range that you want to filter.
2. On the Data tab, in the Sort & Filter group, click the Filter button (see Figure 3). Filter arrows appear next to each column heading (see Figure 4).

![Figure 3 – Sort & Filter Group on the Data Tab]

Applying Filters

Clicking the Filter arrow of a column displays the Sort and Filter menu which includes sorting and filtering commands as well as a list of the unique values in that column. You can filter data by selecting values from the list, by searching for values, or by specifying conditions.

To filter data by selecting values:
1. Click the Filter arrow of the column that you want to filter. The Sort and Filter menu appears, displaying a list of the unique values in that column (see Figure 5).
2. Deselect the (Select All) check box at the top of the list, and then select the check box next to the values by which you want to filter (see Figure 6).
3. Click the OK button. Excel displays only those rows that contain the selected values.

![Figure 5 – Sort and Filter Menu]

![Figure 6 – Sort and Filter Menu After Selecting Values]
NOTE: When a column is filtered, the Filter arrow that appears to the right of the column heading includes a filter icon (see Figure 7).

![Figure 7 – Filter Arrow of a Filtered Column](image)

To filter data by specifying conditions:
1. Click the Filter arrow of the column that you want to filter. The Sort and Filter menu appears.
2. Point to Number Filters, Text Filters, or Date Filters, and then click Custom Filter on the submenu (see Figure 8).

NOTE: The special filters (Number Filters, Text Filters, or Date Filters) that appear on the Sort and Filter menu depend on the type of data in the column (numbers, text, or dates). Most of the special filters open the Custom AutoFilter dialog box, allowing you to specify conditions.

![Figure 8 – Sort and Filter Menu with Number Filters Submenu](image)

3. In the Custom AutoFilter dialog box, enter one or two filtering conditions by selecting a comparison operator (such as equals) from the box on the left and entering a value in the box on the right (see Figure 9).

NOTE: When filtering by two conditions, select the And option if both conditions must be met, or the Or option if either condition can be met.
4. Click the OK button. Excel displays only those rows that meet the specified conditions.
Clearing Filters
After applying filters, you may want to remove them from the worksheet to redisplay the hidden data. You can clear filters one at a time or clear all the filters in a worksheet at once.

To clear a filter from one column:

1. Click the Filter arrow next to the column heading to display the Sort and Filter menu, and then click Clear Filter From “Column” or select the (Select All) check box (see Figure 10).

   **NOTE:** The Clear Filter menu item changes to reflect the heading of the filtered column.

To clear all filters at once:

1. On the Data tab, in the Sort & Filter group, click the Clear button.
**Disabling AutoFilter**
When you finish using AutoFilter, you can disable it. Disabling AutoFilter clears all filters and removes the Filter arrows from the worksheet.

To disable AutoFilter:
1. On the **Data** tab, in the **Sort & Filter** group, click the **Filter** button.

**Entering Data Using AutoFill**
The AutoFill feature automatically fills in data based on the data in adjacent cells. You can use it to enter data in a series (such as months, days of the week, and quarters), or copy values or formulas to adjacent cells.

To enter data using AutoFill:
1. Select the cell that contains the first value of a series you want to extend or the data you want to copy.
2. Point to the **Fill** handle (the green square) in the lower-right corner of the selected cell (see Figure 11). The mouse pointer changes to a black plus sign +.

![Figure 11 – Fill Handle](image)

3. Drag the **Fill** handle over the cells that you want to fill. As you drag, a ScreenTip appears, showing the data that will be entered in each cell.
4. Release the mouse button. Excel fills the cells based on the contents of the first cell, and the **AutoFill Options** button appears in the lower-right corner of the last cell (see Figure 12).

![Figure 12 – AutoFill Options Button](image)

**NOTE:** You can change how the selection is filled by clicking the **AutoFill Options** button and selecting the desired option from the menu (see Figure 13). The options that are available on the **AutoFill Options** menu depend on the type of content in the cells and on the format of the data.
Working with Charts

A *chart* is a graphical representation of numerical data. You can use charts to make it easier to spot trends, highlight important changes, or compare individual figures. A chart is composed of many elements (see Figure 14 and Table 1). Some of these elements are displayed by default; others can be added as needed. You can also remove chart elements that you do not want to display. Not all elements appear in every chart type.

**NOTE:** When you point to a chart element, a ScreenTip displays the name of that element.

![Figure 14 – Chart Elements](image)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart area</td>
<td>Consists of the chart border, the background, and all the fonts.</td>
</tr>
<tr>
<td>Plot area</td>
<td>Consists of the data series and gridlines.</td>
</tr>
<tr>
<td>Chart title</td>
<td>Text that describes the chart.</td>
</tr>
<tr>
<td>Axes</td>
<td>The horizontal axis (x-axis) contains the categories being plotted. The vertical axis (y-axis) contains the values being plotted.</td>
</tr>
<tr>
<td>Axis titles</td>
<td>The horizontal axis title describes the chart categories. The vertical axis title describes the chart values.</td>
</tr>
<tr>
<td>Gridlines</td>
<td>Horizontal or vertical lines in the plot area that make the data easier to read.</td>
</tr>
<tr>
<td>Data points</td>
<td>Individual values that are plotted in the chart. Data points are represented by bars, lines, slices, dots, or other markers.</td>
</tr>
<tr>
<td>Data labels</td>
<td>Text that displays the exact value represented by each data point.</td>
</tr>
<tr>
<td>Data series</td>
<td>A collection of related data points. Each data series in a chart has a unique color or pattern.</td>
</tr>
<tr>
<td>Legend</td>
<td>A key that identifies the colors or patterns associated with each data series.</td>
</tr>
</tbody>
</table>
When a chart is selected, the Chart Tools contextual tabs (Design and Format) become available on the Ribbon (see Figure 15 and Figure 16). You can use the commands on these tabs to change the design, layout, and appearance of the chart.

![Figure 15 – Chart Tools Design Tab](image)

![Figure 16 – Chart Tools Format Tab](image)

When a chart is selected, three buttons appear in the upper-right corner of the chart (see Figure 17). These buttons provide quick access to the most common and useful chart customization features.

- The Chart Elements button allows you to add, remove, or change chart elements.
- The Chart Styles button allows you to change the style or color of the chart.
- The Chart Filters button allows you to show or hide data in the chart.

![Figure 17 – Selected Chart with Chart Buttons](image)

Creating Charts
Excel provides a variety of chart types that you can choose from when creating a chart (see Table 2). Each chart type has a number of subtypes and is best suited for conveying a different type of information. If you are not sure which type of chart is appropriate for your data, you can use one of the charts recommended by Excel.
<table>
<thead>
<tr>
<th>Chart</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Column charts are used to show how data changes over time or to compare values across categories.</td>
</tr>
<tr>
<td>Line</td>
<td>Line charts are used to show trends over time.</td>
</tr>
<tr>
<td>Pie or Doughnut</td>
<td>Pie charts display the contribution of each value to the total. They can contain only one data series. Like pie charts, doughnut charts show the relationship of parts to a whole. However, they can contain more than one data series.</td>
</tr>
<tr>
<td>Bar</td>
<td>Bar charts are similar to column charts, except they display information in horizontal rather than vertical bars.</td>
</tr>
<tr>
<td>Area</td>
<td>Area charts are similar to line charts, except the area below the lines is filled with color.</td>
</tr>
<tr>
<td>Scatter (X, Y) or Bubble</td>
<td>Scatter charts are typically used to display and compare numeric values such as scientific, statistical, and engineering data. Bubble charts are similar to Scatter charts, except they compare sets of three values instead of two, with the third values determining the sizes of the bubbles.</td>
</tr>
<tr>
<td>Stock, Surface, or Radar</td>
<td>Stock charts are most often used to show the fluctuation of stock prices. However, they may also be used for scientific data. Surface charts are used to find optimal combinations between two sets of data. Radar charts are used to compare the aggregate values of several data series.</td>
</tr>
<tr>
<td>Combo</td>
<td>Combo charts combine two or more chart types to make the data easier to understand, especially when the data is widely varied.</td>
</tr>
</tbody>
</table>

To create a chart:
1. Select the cells that contain the data you want to include in the chart.
2. On the **Insert** tab, in the **Charts** group, click the chart type that you want to use, and then click the desired chart subtype (see Figure 18 and Table 2). The chart appears in the worksheet.

To create a recommended chart:
1. Select the cells that contain the data you want to include in the chart.
2. On the **Insert** tab, in the **Charts** group, click the **Recommended Charts** button.
3. In the **Insert Chart** dialog box, on the **Recommended Charts** tab, select one of the recommended charts in the left pane, and then click the **OK** button (see Figure 19).
Selecting Chart Elements

In order to modify a chart element, you must first select it. You can select only one chart element (or one group of chart elements) at a time.

To select a chart element with the mouse:
1. Click the chart element that you want to select. Selection handles appear around the selected element.

   **NOTE:** Grouped elements (such as data series and data labels) contain individual elements that can be selected after you select the group. For example, to select a single data point in a data series, click the data point one time to select the whole data series, and then click that data point again to select just the point.

To select a chart element from a list:
1. Click anywhere in the chart.
2. Under **Chart Tools**, on the **Format** tab, in the **Current Selection** group, click the arrow on the **Chart Elements** box and select the desired chart element from the list (see Figure 20).

   **NOTE:** The **Chart Elements** box displays the name of the selected chart element.

Changing the Chart Type

You can change the chart type of an existing chart without having to re-create it from scratch.
To change the chart type:
1. Select the chart that you want to change.
2. Under Chart Tools, on the Design tab, in the Type group, click the Change Chart Type button.
3. In the Change Chart Type dialog box, select the desired chart type in the left pane, select the desired chart subtype in the right pane, and then click the OK button (see Figure 21).

![Figure 21 – Change Chart Type Dialog Box](image)

### Changing the Chart Data

A chart is linked to the worksheet data that was used to create the chart (also known as the source data). If you change the data within the original range, the chart is automatically updated to reflect those changes. You can add or remove data from a chart by changing the data range included in the chart. You can also hide a particular series or category by applying a chart filter.

To change the source data:
1. Select the chart that you want to change. The chart’s source data is highlighted in the worksheet (see Figure 22).

![Figure 22 – Source Data](image)

2. Under Chart Tools, on the Design tab, in the Data group, click the Select Data button. The Select Data Source dialog box opens (see Figure 23).
3. In the worksheet, select the new data range.
4. In the Select Data Source dialog box, click the OK button. The chart is updated to reflect the new data.
To filter a chart:
1. Select the chart that you want to filter.
2. Click the Chart Filters button next to the chart, deselect the check boxes next to the series or categories that you want to hide, and then click the Apply button (see Figure 24).

NOTE: You can remove a chart filter by selecting the chart, clicking the Chart Filters button, selecting the Select All check box, and then clicking the Apply button.

Changing the Chart Layout
The overall arrangement of a chart’s elements is its layout. Each chart type comes with a variety of predefined layouts that you can use to quickly change a chart’s layout. If none of the predefined layouts gives you the combination and positioning of chart elements that you want, you can manually change a chart’s layout by adding or removing specific chart elements and rearranging where they are positioned.
To apply a predefined chart layout:
1. Select the chart that you want to change.
2. Under Chart Tools, on the Design tab, in the Chart Layouts group, click the Quick Layout button, and then click the desired layout in the gallery (see Figure 25).

NOTE: Pointing to an option in the Quick Layout gallery provides a preview of that layout on the selected chart. The layout is not applied until you click it.

To manually change the layout of chart elements:
1. Select the chart that you want to change.
2. Do one of the following:
   - Under Chart Tools, on the Design tab, in the Chart Layouts group, click the Add Chart Element button, point to the chart element that you want to change, and then click the desired option on the submenu (see Figure 26).
   - Click the Chart Elements button next to the chart, and then select an element’s check box to add it to the chart or deselect it to remove it. For additional options (such as the element’s location in the chart), point to the element, click the arrow, and then click the desired option on the submenu (see Figure 27).
**Formatting Charts**

The overall appearance of a chart’s elements is its *style*. You can quickly change a chart’s appearance by applying one of Excel’s predefined styles or changing the color scheme. In addition, you can manually format individual chart elements.

To apply a predefined chart style:

1. Select the chart that you want to format.
2. Do one of the following:
   - Under **Chart Tools**, on the **Design** tab, in the **Chart Styles** group, and then click the desired style in the **Quick Styles** gallery. To see all available styles, click the **More** button in the lower-right corner of the **Quick Styles** gallery (see Figure 28).

   ![Figure 28 – Chart Styles Group on the Design Tab](image)

   - Click the **Chart Styles** button next to the chart, and then click the desired style on the **Style** tab of the **Chart Styles** gallery (see Figure 29).

   ![Figure 29 – Style Tab of the Chart Styles Gallery](image)
To change the color scheme of a chart:
1. Select the chart that you want to format.
2. Do one of the following:
   - Under Chart Tools, on the Design tab, in the Chart Styles group, click the Change Colors button, and then click the desired color scheme (see Figure 30).
   - Click the Chart Styles button next to the chart, and then click the desired color scheme on the Color tab of the Chart Styles gallery (see Figure 31).

   ![Figure 30 – Change Colors Menu](image)
   ![Figure 31 – Color Tab of the Chart Styles Gallery](image)

To manually format chart elements:
1. Double-click the chart element that you want to format. The Format pane opens on the right side of the program window (see Figure 32).
   
   **NOTE:** Each chart element has a unique Format pane that contains controls specific to that element.

2. In the Format pane, click the desired button (Fill & Line, Effects, or Size & Properties), click the white triangle next to the desired category to expand it, and then select the desired options.
3. To close the Format pane, click the Close button in the upper-right corner of the pane.

   ![Figure 32 – Format Pane](image)
Moving Charts
The default location for a chart is the same worksheet as the data from which it is derived. You can move the chart to another location in the same sheet, to another sheet as an embedded object, or to its own chart sheet. A chart sheet is a special type of worksheet in Excel used to display only charts. Chart sheets are inserted to the left of the worksheet that contains the data represented by the chart.

To move a chart to another location in the same worksheet:
1. Select the chart that you want to move.
2. Drag the chart to the desired location.

To move a chart to a chart sheet or another worksheet:
1. Select the chart that you want to move.
2. Under Chart Tools, on the Design tab, in the Location group, click the Move Chart button.
3. In the Move Chart dialog box, do one of the following (see Figure 33):
   • To move the chart to its own chart sheet, select the New sheet option, and then type a name for the new chart sheet in the New sheet box.
   • To move the chart to another worksheet, select the Object in option, and then select the desired worksheet from the Object in list.
4. Click the OK button.

Deleting Charts
If you no longer need a chart, you can delete it from the workbook.

To delete a chart:
1. Select the chart that you want to delete, and then press the Delete key.

To delete a chart sheet:
1. Right-click its sheet tab, and then click Delete on the shortcut menu.
2. A dialog box opens asking you to confirm. Click the Delete button (see Figure 34).

Figure 33 – Move Chart Dialog Box

Figure 34 – Microsoft Excel Dialog Box
Using Formulas and Functions

Formulas are used to perform calculations in a worksheet. All formulas must begin with an equal sign (=). Formulas can consist of the following elements:

- Constant values (such as 5 or 100).
- Cell references (such as A1 or A1:A3).
- Operators (such as + for addition or * for multiplication).
- Functions (such as SUM or AVERAGE).

Using Operators in Formulas

Operators are symbols that represent specific mathematical operations. Excel formulas support a variety of operators (see Table 3). Arithmetic operators perform basic mathematical operations (such as addition or subtraction) and return numeric results. Comparison operators compare two values and return TRUE or FALSE.

Table 3 – Arithmetic and Comparison Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
<td>=1+1</td>
<td>2</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>=1-1</td>
<td>0</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>=2*2</td>
<td>4</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
<td>=4/2</td>
<td>2</td>
</tr>
<tr>
<td>%</td>
<td>Percentage</td>
<td>=20%</td>
<td>0.2</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td>=2^3</td>
<td>8</td>
</tr>
<tr>
<td>=</td>
<td>Equal to</td>
<td>=1=2</td>
<td>FALSE</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>=1&gt;2</td>
<td>FALSE</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>=1&lt;2</td>
<td>TRUE</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>=1&gt;=1</td>
<td>TRUE</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>=1&lt;=1</td>
<td>TRUE</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td>=1&lt;&gt;1</td>
<td>FALSE</td>
</tr>
</tbody>
</table>

When a formula contains more than one operator, Excel performs calculations from left to right, based on the standard mathematical order of operations. You can change this order by using parentheses; calculations within parentheses are performed first. The basic order of operations is as follows:

1. Percentage
2. Exponentiation
3. Multiplication and division
4. Addition and subtraction
5. Comparison

Using Cell References in Formulas

Most formulas are created using cell references. A cell reference identifies a cell or a range of cells in a worksheet. There are three types of cell references in Excel: relative, absolute, and mixed (see Table 4). These references behave differently when a formula is copied to other cells.
You create an absolute reference by adding a dollar sign ($) before the column letter and row number (e.g., $A$1). If the dollar sign ($) precedes only the column letter (e.g., $A1$), the column is absolute and the row is relative. If the dollar sign ($) precedes only the row number (e.g., $A$1), the column is relative and the row is absolute.

**Table 4 – Types of Cell References**

<table>
<thead>
<tr>
<th>Reference Type</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative</td>
<td>Refers to cells by their position in relation to the cell that contains the formula (such as “the cell two rows above this cell”). When you copy a formula containing relative references, the references adjust to the new location.</td>
<td>A1</td>
</tr>
<tr>
<td>Absolute</td>
<td>Refers to cells by their fixed position in the worksheet (such as “the cell located at the intersection of column A and row 1”). Absolute references always refer to the same cell, regardless of where the formula is copied.</td>
<td>$A$1</td>
</tr>
<tr>
<td>Mixed</td>
<td>Contain both relative and absolute references (such as “the cell located in column A and two rows above this cell”). When you copy a formula containing mixed references, the relative references adjust, but the absolute references do not.</td>
<td>$A$1 or $A$1</td>
</tr>
</tbody>
</table>

**Entering Formulas**

You can create a simple formula by entering constant values or using cell references. The advantage of using cell references in a formula is that the formula automatically recalculates whenever the value in any cell referenced in the formula changes.

To enter a formula:
1. Select the cell in which you want to enter the formula.
2. Type an equal sign (=).
3. Enter the first value or cell reference.
4. Enter the desired operator.
5. Enter the next value or cell reference.
6. Repeat steps 4 and 5 as needed to complete the formula (see Figure 35).

7. When finished, press the **Enter** key. The result of the formula appears in the cell (see Figure 36).
Displaying Formulas

Cells containing formulas display the results of the formula, not the formula itself. You can see the underlying formulas by selecting individual cells and looking at the Formula bar. Another way to see formulas in a worksheet is to make them all visible.

To display all formulas:

1. On the **Formulas** tab, in the **Formula Auditing** group, click the **Show Formulas** button (see Figure 37). The width of each column increases to accommodate the formulas.

   **NOTE:** To hide the formulas and redisplay the calculated results, click the **Show Formulas** button again.

Using Functions in Formulas

*Functions* are predefined formulas that can be used to perform complex calculations. Excel includes hundreds of functions that you can use alone or in combination with other formulas or functions (see Table 5).

### Table 5 – Commonly Used Excel Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM</td>
<td>Adds the values in the selected range.</td>
<td>=SUM(A1:A5)</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>Averages the values in the selected range.</td>
<td>=AVERAGE(A1:A5)</td>
</tr>
<tr>
<td>COUNT</td>
<td>Returns the number of cells containing numbers.</td>
<td>=COUNT(A1:A5)</td>
</tr>
<tr>
<td>MAX</td>
<td>Returns the largest value in the selected range.</td>
<td>=MAX(A1:A5)</td>
</tr>
<tr>
<td>MIN</td>
<td>Returns the smallest value in the selected range.</td>
<td>=MIN(A1:A5)</td>
</tr>
</tbody>
</table>

Each function has its own *syntax* which specifies how it must be written. The general syntax of a function is an equal sign (=), followed by the function name, an opening parenthesis, the function arguments, and a closing parenthesis. *Function names* (such as SUM and AVERAGE) describe the operation the function performs. *Arguments* specify the values or cell references the function uses when it performs its operations. Some functions have no arguments or the argument is optional.
There are a few rules to keep in mind when using functions:

- Arguments must be entered in the order required by the function.
- Arguments must be separated by commas.
- Optional arguments must be placed after the required ones.
- Parentheses are needed with every function, including functions that have no arguments.

**Using the AutoSum Button**

The *AutoSum* button provides quick access to the most commonly used functions (SUM, AVERAGE, COUNT, MAX, and MIN). It appears on both the *Home* tab and the *Formulas* tab of the *Ribbon*. The default action of the AutoSum button is the SUM function; you can access the other functions by clicking the arrow on the button (see Figure 38).

![Figure 38 – AutoSum Menu](image)

To sum numbers using the AutoSum button:

1. Select a cell next to the numbers that you want to sum.
2. On the *Home* tab, in the *Editing* group, click the *AutoSum* button (see Figure 39). Excel automatically enters a formula that uses the SUM function and suggests a range to sum (see Figure 40).
3. Do one of the following:
   - If the suggested range is correct, press the *Enter* key to display the result.
   - If the suggested range is incorrect, select the correct range, and then press the *Enter* key to display the result.

![Figure 39 – Editing Group on the Home Tab](image)  
![Figure 40 – Cell with SUM Function](image)

**Inserting Functions**

Functions are organized into categories (Financial, Logical, Text, Date & Time, Lookup & Reference, Math & Trig, etc.) based on their purpose (see Figure 41). Each of the categories has a button in the *Function Library* group on the *Formulas* tab of the *Ribbon*. You can insert a function into a formula by selecting it from one of the function categories. If you are not sure which category to choose, you can use the *Insert Function* dialog box to browse through the entire list of functions and select the one you need.
To insert a function:

1. Select the cell in which you want to enter the formula.
2. On the **Formulas** tab, in the **Function Library** group, click the **Insert Function** button \( fx \). Or, click the **Insert Function** button on the **Formula** bar (see Figure 42).

3. In the **Insert Function** dialog box, search for a function or select a category, select the desired function, and then click the **OK** button (see Figure 43).

   **NOTE:** When you select a function in the **Select a function** box, the function’s syntax and description appear below the box.

4. In the **Function Arguments** dialog box, enter the function’s arguments, and then click the **OK** button to display the result (see Figure 44).

   **NOTE:** If you need help with entering arguments, click the **Help on this function** link in the lower-left corner of the **Function Arguments** dialog box.
Using Formula AutoComplete
If you are already familiar with the function you want to use, you can enter it directly into a cell by using the *Formula AutoComplete* feature.

To insert a function using Formula AutoComplete:
1. Select the cell in which you want to enter the formula.
2. Type an equal sign (=).
3. Begin typing the name of the desired function (e.g., =SU). Excel displays an alphabetical list of all the functions that begin with those letters (see Figure 45).

   **NOTE:** Clicking a function in the *Formula AutoComplete* list displays a *ScreenTip* with a description of what that function does.

4. Double-click the function that you want to use. Excel enters the function name in the cell, followed by an opening parenthesis (see Figure 46).

   **NOTE:** After the function is added, a *ScreenTip* appears, displaying the function’s syntax. The current argument is in bold. Optional arguments appear in square brackets.
5. Enter the first argument for the function (see Figure 47).
6. If there is another argument, type a comma, and then enter the next argument. Repeat this step for each argument.
7. When you have finished entering all the arguments, type a closing parenthesis, and then press the Enter key to display the result.

![Figure 46 – Cell with Function and Opening Parenthesis](Image)

![Figure 47 – Cell with Function, Opening Parenthesis, and Argument](Image)

**Password-protecting Workbooks**

In Excel, you can protect a workbook with a password, allowing only authorized users to open the file. This can be used to protect files stored on computers or external storage devices, as well as data being transferred via networks.

To password-protect a workbook:
1. Open the workbook that you want to protect.
2. Click the File tab, and then click Info. The Info page of the Backstage view opens.
3. In the center pane, click the Protect Workbook button, and then click Encrypt with Password (see Figure 48).

![Figure 48 – Protect Workbook Menu](Image)
4. In the Encrypt Document dialog box, type a password in the Password box, and then click the OK button (see Figure 49).

**NOTE:** Passwords are case-sensitive. Lost or forgotten passwords cannot be recovered.

Figure 49 – Encrypt Document Dialog Box

5. In the Confirm Password dialog box, retype the password in the Reenter password box, and then click the OK button (see Figure 50).

Figure 50 – Confirm Password Dialog Box

6. Save the workbook.

**NOTE:** If you want to remove the password from the workbook, click the File tab to display the Info page, click the Protect Workbook button, and then click Encrypt with Password. In the Encrypt Document dialog box, delete the password from the Password box, and then click the OK button.