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Introduction

SPSS stands for Statistical Package for the Social Sciences. This program can be used to analyze
data collected from surveys, tests, observations, etc. It can perform a variety of data analyses and
presentation functions, including statistical analysis and graphical presentation of data. Among
its features are modules for statistical data analysis. These include 1) descriptive statistics, such
as frequencies, central tendency, plots, charts, and lists; and 2) sophisticated inferential and
multivariate statistical procedures, such as analysis of variance (ANOVA), factor analysis,
cluster analysis, and categorical data analysis. IBM SPSS Statistics 18 is particularly well-suited
for survey research, though by no means is it limited to just this topic of exploration.

This handout (Chi-Square and ANOVA) introduces basic skills for performing hypothesis tests
utilizing Chi-Square test for Goodness-of-Fit and generalized pooled t tests, such as ANOVA.
The step-by-step instructions will guide the user in performing “tests of significance” using
SPSS Statistics and help the user understand how to interpret the output for research questions.

Downloading the Data Files

This handout includes sample data files that can be used for hands-on practice. The data files are
stored in a self-extracting archive. The archive must be downloaded and executed in order to
extract the data files.
e The data files used with this handout are available for download at
http://www.calstatela.edu/its/training/datafiles/spss18p4.exe.
e Instructions on how to download and extract the data files are available at
http://www.calstatela.edu/its/docs/download.php.

Chi-Square

The Chi-Square (x2) test is a statistical tool used to examine differences between nominal or
categorical variables. The Chi-Square test is used in two similar but distinct circumstances:
e To estimate how closely an observed distribution matches an expected distribution — also
known as the Goodness-of-Fit test.
e To determine whether two random variables are independent.

Chi-Square Test for Goodness-of-Fit

This procedure can be used to perform a hypothesis test about the distribution of a qualitative
(categorical) variable or a discrete quantitative variable having only finite possible values. It
analyzes whether the observed frequency distribution of a categorical or nominal variable is
consistent with the expected frequency distribution.

With Fixed Expected Values

Research Question # 1
Can the hospital schedule discharge support staff evenly throughout the week?

A large hospital schedules discharge support staff assuming that patients leave the hospital at a
fairly constant rate throughout the week. However, because of increasing complaints of staff
shortages, the hospital administration wants to determine whether the number of discharges
varies by the day of the week.
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Ho: Patients leave the hospital at a constant rate (there is no difference between the discharge
rates for each day of the week).

To perform the analysis:
1. Start IBM SPSS Statistics 18.

2. Click the Open button ~ on the Data Editor toolbar. The Open Data dialog box
opens.

3. Navigate to the data files folder, select the Chi-hospital.sav file, and then click the Open
button.

Before the Chi-Square test is run, the observed values need to be declared.
To declare the observed values:
1. Click the Data menu and select Weight Cases. The Weight Cases dialog box opens (see
Figure 1).

#if Weight Cases [X]

© Do not weight cases
@ Wigight cases by

m Freguency Yariable:
« | .ﬁ Average Daily Dizcharg. ..

&2 Davy of the Wiek [dow]
ﬁ Average Daily Admissi...

Current Status: Wieight cazes by discharg

(Con) (s (meset) (concet) (e

Figure 1 — Weight Cases Dialog Box

N

Select the Weight cases by option.

3. Select the Average Daily Discharges [discharge] variable from the list box on the left,
and then click the transfer arrow button to transfer it to the Frequency Variable box.

4. Click the OK button.

To perform the analysis:
1. Click the Analyze menu, point to Nonparametric Tests, point to Legacy Dialogs, and
select Chi-square. The Chi-square Test dialog box opens (see Figure 2).
2. Select the Day of the Week [dow] variable and transfer it to the Test Variable List box.
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Figure 2 — Chi-square Test Dialog Box

3. Click the OK button. The Output Viewer window opens (see Figure 3).

Frequencies The observed frequency

for each row is the
actual number of

Dyt the Yeoe patients discharged per
Observed N& Expected N | Residual day.
Sunday 44 g4.1 -40.1
The expected value for
Manday 74 54.1 b1 each row is equal to the
Tuesday a0 a4 .1 5.9 sum of the observed

frequencies divided by

Wednesday 94 g4.1 94 k
the number of rows in

Thursday 29 241 449 the table.

Friday 110 g4.1 259

Saturday ad a4 1 1* The Residual is equal to
the observed frequency

Total 584 minus the expected

value.

Figure 3 — Chi-Square Frequencies Output Table

Diay of the
Week
Chi-Sguare 20 3pGa
df B
Asymp. Sia. .0oo

Figure 4 — Chi-Square Test Statistics Output Table
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Reporting the analysis results:
Ho: Rejected in favor of Hj.
H;: Patients do not leave the hospital at a constant rate.

Explanation: Figure 4 indicates that the calculated y° statistic, for six degrees of freedom, is
29.389. Additionally, it indicates that the significance value (0.000) is less than the usual
threshold value of 0.05. This suggests that the null hypothesis, Hy (patients leave the hospital at a
constant rate), can be rejected in favor of the alternate hypothesis, H; (patients leave the hospital
at different rates during the week).

With Fixed Expected Values and within a Contiguous Subset of Values

By default, the Chi-Square test procedure builds frequencies and calculates an expected value
based on all valid values of the test variable in the data file. However, it may be desirable to
restrict the range of the test to a contiguous subset of the available values, such as weekdays only
(Monday through Friday).

Research Question # 2
The hospital requests a follow-up analysis: can staff be scheduled assuming that patients
discharged on weekdays only (Monday through Friday) leave at a constant daily rate?

Ho: Patients discharged on weekdays only (Monday through Friday) leave at a constant daily
rate.

To run the analysis:
1. Click the Analyze menu, point to Nonparametric Tests, point to Legacy Dialogs, and
select Chi-square. The Chi-square Test dialog box opens.
2. Select the Use specified range option in the Expected Range section (see Figure 2).
3. Type 2 in the Lower box and 6 in the Upper box.
4. Click the OK button. The Output Viewer window opens (see Figure 5 and Figure 6).
Notice that the test range is restricted to Monday through Friday.

Figure 5 — Chi-Square (Subset) Frequencies Output Table

Reporting the analysis results:

NOTE: The expected values are equal to the sum of the observed values divided by the number of

rows, while the observed values are the actual number of patients discharged.

Day of the Week D%}I}nfit{he
eg
Category Chsemved M | Expected M | Residual -

Chi-sguare 58229
1 mMonday Ta 922 -14.2 o s
2 Tuesday 40 922 -2.2 )

Asymp. Sig. 213
3 Wednesday 94 922 1.8

Figure 6 — Test Statistics Output

4 Thursday 24 4212 -3.2 Table
g Friday 110 Q2.2 17.8
Total 461

Ho: Do not reject. Patients discharged on weekdays only (Monday through Friday) leave at a
constant daily rate.
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Explanation: Figure 5 indicates that on average, about 92 patients were discharged from the
hospital each weekday. The rate for Mondays was below average and the rate for Fridays was
greater than average. Figure 6 indicates that the calculated value of the Chi-Square statistic was
5.822 at four degrees of freedom. Because the significance level (0.213) is greater than the
rejection threshold of 0.05, Hy (patients were discharged at a constant rate on weekdays) could
not be rejected.

Using the Chi-Square test procedure, it was determined that the rate at which patients were
discharged from the hospital was not constant over the course of an average week. This was
primarily due to a greater number of discharges on Fridays and fewer discharges on Sundays.
When the range of the test was restricted to weekdays, the discharge rates appeared to be more
uniform. Staff shortages could be corrected by adopting separate weekday and weekend staff
schedules.

With Customized Expected Values

Research Question # 3
Does first-class mailing provide quicker response time than bulk mail?

A manufacturer tries first-class postage for direct mailings, hoping for faster responses than with
bulk mail. Order takers record how many weeks each order takes after mailing.

Ho: First-class and bulk mailings do not result in different customer response times.

Before the Chi-Square test is run, the cases must be weighted. Because this example compares
two different methods, one method must be selected to provide the expected values for the test
and the other will provide the observed values.

To weight the cases:
1. Open the Chi-mail.sav file.
2. Click the Data menu and select Weight Cases. The Weight Cases dialog box opens.
3. Select the Weight cases by option.
4. Select the First Class Mail [fcmail] variable and transfer it to the Frequency Variable
box.
5. Click the OK button.

To run the analysis:
1. Click the Analyze menu, point to Nonparametric Tests, point to Legacy Dialogs, and
select Chi-square. The Chi-square Test dialog box opens.
2. Select the Week of Response [week] variable and transfer it to the Test Variable List
box.
Select the Values option in the Expected Values section.
Type 6 in the VValues box, and then click the Add button.
Repeat step 4, adding the values 15.1, 18, 12, 11.5,9.8, 7, 6.1, 5.5, 3.9, 2.1, and 2 (in that
order).
6. Click the OK button. The Output Viewer window opens.

o s w

NOTE: The expected frequencies in this example are the response percentages that the firm has
historically obtained with bulk mail.

IBM SPSS Statistics 18, Part 4 6



Observed N | Expected M | Residual
1 10 6.0 4.0
2 22 151 6.9
3 14 18.0 -4.0
4 10 12.0 -2.0
a] g 11.48 -2.4
] g 9.8 -1.8
7 ¥ i.a 0
g 10 6.1 3.9
] 4 5.4 -1.5
10 2 349 -1.9
11 2 21 -1
12 1 20 -1.0
Total 95

Figure 7 — First-Class/Bulk Mail Week of Response

Weelk of

Response
Chi-sguare 12,2494
df 11
Asymp. Sig. 345

Figure 8 — Week of Response Test Statistics

Reporting the analysis results:
Ho: Do not reject. There was no statistical difference between customer response times using
first-class mailing and customer response times using bulk mailing.

Explanation: The manufacturer hoped that first-class mail would result in quicker customer
response. As indicated in Figure 7, the first two weeks indicated different response times of four
and seven percentage points, respectively. The question was whether the overall differences
between the two distributions were statistically significant.

The Chi-Square statistic was calculated to be 12.249 at eleven degrees of freedom (see Figure 8).
The significance value (p) associated with the data was 0.345, which was greater than the
threshold value of 0.05. Hence, Hy was not rejected because there was no significant difference
between first-class and bulk mailings. The first-class mail promotion did not result in response
times that were statistically different from standard bulk mail. Therefore, bulk postage was more
economical for direct mailings.

One-Way Analysis of Variance

One-way analysis of variance (One-Way ANOVA) procedures produce an analysis for a
quantitative dependent variable affected by a single factor (independent variable). Analysis of
variance is used to test the hypothesis that several means are equal. This technique is an
extension of the two-sample t test. It can be thought of as a generalization of the pooled t test.
Instead of two populations (as in the case of a t test), there are more than two populations or
treatments.

Research Question # 4
Which of the alloys tested would be appropriate for creating an underwater sensor array?
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To create an underwater sensor array, four different alloys are tested for corrosion resistance.
Five plates of the same size of each alloy are placed underwater for 60 days. After 60 days, the
number of corrosion pits on each plate is measured.

Ho: The four alloys exhibit the same kind of behavior and are not different from one another.

To run One-Way ANOVA:
1. Open the Alloy.sav file.

NOTE: Each case within the One-Way ANOVA data file represents one of the 20 metal plates
(five plates of four different alloys) and is characterized by two variables. One variable assigns a
numeric value to the alloy. The other variable is used to quantify the number of pits on the plate
after being underwater for 60 days (see Figure 9).

alloy pits
1 1.00 15.00
2 1.00 17.00
3 1.00 11.00
4 1.00 18.00
5 1.00 24.00
5] 2.00 62.00
7 2.00 G1.00
] 2.00 58.00
g 2.00 65.00
10 2.00 54.00

Figure 9 — Alloy Data File

2. In Data View, click the Analyze menu, point to Compare Means, and select One-Way
ANOVA. The One-Way ANOVA dialog box opens (see Figure 10).

§if One-Way ANOVA

Dependent List:
& pits
Post Hoc...

Options. ..

Contrasts. .

1.

Factor:
| & aioy [alloy] |

(Cox) (pome) (o) (concet) (Cooe)

Figure 10 — One-Way ANOVA Dialog Box

3. Select the pits variable from the list box on the left and transfer it to the Dependent L.ist
box.

4. Select the Alloy [alloy] variable from the list box on the left and transfer it to the Factor
box.

5. Click the Options button. The One-Way ANOVA: Options dialog box opens (see
Figure 11).
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i One-Way ANOVA: Options ]

Statistics
-J’ Descriptive

Browen-Farsythe

[T] wiglch

Miszing YWalues

[ Fixedd and random etfects

J' Homogeneity of variance test

(B Exciude cazes analysiz by analysis

&) Exclude cazes listwize

[Cl:untinue][ Cancel ][ Help ]

Figure 11 — One-Way ANOVA: Options Dialog Box

6. Select the Descriptive, Homogeneity of variance test, and Means plot check boxes.
7. Click the Continue button.
8. Click the OK button. The Output Viewer window opens.

Figure 14 — ANOVA Output

Reporting the analysis results:

Ho: Reject in favor of H;.

95% Confidence Interval for
Mean
I Mean Std. Deviation | Std. Error | Lower Bound | Upper Bound | Minimum | Maximum
1.00 A 17.0000 474347 212132 11.1103 22.88497 11.00 24.00
2.00 A AO.EOO0 5.17BET 23187 541721 AF.02749 f4.00 fE.00
3.00 ] 34.6000 492950 220454 2847492 40,7208 28.00 40.00
4.00 A 19.4000 320936 1.43627 154151 2338449 15.00 24.00
Total 20 32.9000 18.29840 409165 24 3361 41 46349 11.00 fE.00
Figure 12 — ANOVA Descriptive Output
Levene
Statistic dfl o2 Sig.
535 3 16 BB5
Figure 13 — Output for Test of Homogeneity of Variances
Surn of
Sqguares df Mean Sguare F Sig.
Between Groups 6026.200 3 2008.733 95763 oo
Within Groups 335,600 16 200874
Total £361.800 149

H;i: The four alloys do not exhibit the same kind of behavior. They are statistically different from
one another.

Explanation: Figure 12 lists the means, standard deviations, and individual sample sizes of each
alloy. Figure 13 provides the degrees of freedom and the significance level of the population; df1
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is one less than the number of sample alloys (4-1=3), and df2 is the difference between the total
sample size and the number of sample alloys (20-4=16). Figure 14 lists the sum of the squares of
the differences between means of different alloy populations and their mean square errors. In
Figure 14, the Between Groups variation 6026.200 is due to interaction in samples between
groups. If sample means are close to each other, this value is small. The Within Groups variation
335.600 is due to differences within individual samples. The Mean Square values are calculated
by dividing each Sum of Squares value by its respective degree of freedom (df). The table also
lists the F statistic 95.768, which is calculated by dividing the Between Groups Mean Square by
the Within Groups Mean Square. The significance level of 0.000 is less than the threshold value
of 0.05 and indicates that the null hypothesis can be rejected, leading to the conclusion that the
alloys are not all the same.

Post Hoc Tests

In ANOVA, if the null hypothesis is rejected, then it is concluded that there are differences
between the means (p, Ho,..., Ha). It is useful to know specifically where these differences exist.
Post hoc testing identifies these differences. Multiple comparison procedures look at all possible
pairs of means and determine if each individual pairing is the same or statistically different. In an
ANOVA with a treatments, there will be a*(a-1)/2 possible unique pairings, which could mean a
large number of comparisons.

Research Question # 5
Is the mean difference between alloy sets statistically significant?

The previous null hypothesis was rejected, leading to the conclusion that all the alloys do not
exhibit the same behavior. The next part of the analysis is to determine if the mean difference
between individual alloy sets is statistically significant.

Ho: Mo = H1...= Ua
Hi: o # e ... # Ha

To run post hoc tests:
1. In Data View, click the Analyze menu, point to Compare Means, and select One-Way
ANOVA. The One-Way ANOVA dialog box opens (see Figure 15).

i3 One-Way ANOVA X

Dependent List:
.
Factor:
had | & atoy [alioy) |
|_oxJ| peste J[ meset || cancer || rew |

Figure 15 — One-Way ANOVA Dialog Box

2. Click the Post Hoc button. The One-Way ANOVA: Post Hoc Multiple Comparisons
dialog box opens (see Figure 16).
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3. Select the LSD check hox, click the Continue button, and then click the OK button. The

Output Viewer window opens.

NOTE: LSD stands for Least Significant Differences, which compares the means one by one.

£if One-Way ANOYA: Post Hoc Multiple Comparisons

Equal Yatiances &ssumed

[T] 5K || waller-Duncan
[ Tukey

[ Tukey's-b [ Durinett

& Duncan

[7] Hochberg's GT2 Test

|| Gabriel Q

Equal Yariances Mot Azsumed

| Tamhane's T2 || Dunnett's T3 || Games-Howel

Signiticance level:

[Continue][ Cancel ][ Help ]

3

|| Dunnett's C

Figure 16 — One-Way ANOVA: Post Hoc Multiple Comparisons Dialog Box

i Alloy (0 Alloy 95% Confidence Interval
Mean
Difference (-

Ji Std. Error Sig. Lower Bound | Upper Bound

1.00 2.00 -43.60000° 2.896585 oo -49.7404 -37.4596
3.00 -17.60000° 2.896585 oo -23.7404 -11.4596

4.00 -2.40000 2.896485 420 -8.5404 3.7404

2.00 1.00 43.60000° 2.896485 .non a7.4596 497404
3.00 26.00000° 2.896485 .non 19.8596 321404

4.00 41.20000° 2.896455 .0on 35,0596 473404

3.00 1.00 17.60000° 2.896455 .0on 11.4596 237404
2.00 -26.00000° 2.896455 .0on -32.1404 -19.8596

4.00 15.20000" 2 BY9EAS non 9.0596 21 .3404

4.00 1.00 240000 2.B9E55 420 -3.7404 8.5404
2.00 -41 20000° 2.B9E55 oo -47.3404 -35.0596

3.00 -15.20000° 2.B9E55 oo -21.3404 -9.05496

* The mean difference is significant atthe 0.04 level.

Figure 17 — Multiple Comparisons Output
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Figure 18 — Means Plot

Reporting the analysis results:
Ho: Reject in favor of H;.
Hi: At least one of the means is different.

Explanation: Figure 17 shows the results of comparing pairs of means between different alloy
sets. Each row indicates the difference between the two corresponding treatments. Alloys 7 and 4
have a mean difference of 2.4 (a relatively small value). Also, the significance level of 0.420
indicates that the null hypothesis cannot be rejected for the comparison of alloys 7 and 4.

There is no statistically significant difference between them. Alloy pairs 7/ and 2, 7 and 3, 2 and
3, 2and 4, and 3 and 4 have large mean differences with significance values of 0.000. In these
cases, the null hypothesis can be rejected, leading to the conclusion that they are statistically
different. Also, the means plot (see Figure 18) shows that both alloys / and 4 have average mean
values of pits very close to each other. Because alloys / and 4 have the lowest mean number of
corrosion pits, they are the best candidates for the array. Depending on the relative costs of the
two alloys, the one that is more cost effective can be selected to construct the array.

Two-Way Analysis of Variance

Two-way analysis of variance (Two-Way ANOVA) is an extension to the one-way analysis of
variance. The difference is that instead of running the test by using a single independent variable,
two or more independent variables can be used to run the test in two-way analysis of variance.
There are several advantages in using several variables over using a one variable design. Some of
the advantages are a two-variable design ANOVA is more efficient and it helps increase
statistical power of the result.

Research Question # 6
Will typing ability and test method affect student test scores?

To answer the question, an essay final is given to the class. Two test methods are used — half the
students are assigned to write the final with a blue-book and the other half with notebook
computers. In addition, the students are partitioned into three groups, namely: no typing ability,
some typing ability, and highly skilled at typing. After evaluating the final, the mean score of
each group is examined.
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Ho: Typing ability and test method do not affect student test scores.

H;i: Typing ability and test method do affect student test scores.

To run Two-Way ANOVA:
1. Open the Two-Way-ANOVA.sav file (see Figure 19).

ABILITY
1 none
2 none
3 none
4 some
=3 some
G some
i lots
3 lots
9 lots
10 none
1Al none
12 none
13 some
14 somme
15 somme
16 lots
17 lots
18 lots

METHOD
blue-book
blue-book
blue-book
blue-book
blue-book
blue-book
blue-book
blue-book
blue-book
camputer
computer
computer
computer
computer
computer
computer
computer

computer

SCORE
23
32
25
29
30
34
I
36
33
32
26
26
34
41
35
23
26
32

Figure 19 — Two-Way ANOVA Data File

2. In Data View, click the Analyze menu, point to General Linear Model, and select

Univariate (see Figure 20). The Univariate dialog box opens (see Figure 21).

3. Select the SCORE variable from the list box on the left and transfer it to the Dependent

Variable box.

4. Select the ABILITY and METHOD variables from the list box on the left and transfer
them to the Fixed Factor(s) box.

Analyze  Graphs  Uilties  Add-ons Windows  Help

Reports

Descriptive Statistics

Tahles

Compare Means

General Linear Model

Generalized Linear Models:

Mized Models

Correlste

Regression

Loglinear

Clazsify

Dimension Reduction

Scale

Monparametric Tests

Forecasting

Survival

Multiple Responze
Missing Yalue Analysis...

Multiple Imputation

Quiality Contral

ROC Curve...

Amos 7.

> v v T T T T T ETTETTTET T T OT

i 5 M B

@ Univariate. ..
@ Muttivariste. ..
E Repeated Measures..

“ariance Components...

Figure 20 — Analyze Menu When Selecting Univariate

£i8 Univariate

Dependent “ariable:

»

| score

Fixed Factor(s):

&g MEILITY
&4 METHOD

Random Factor(z):.

Covariate(s):

LS Wieight:

(o) (s (eset) (coneet) (e

Figure 21 — Univariate Dialog Box

5. Click the Options button. The Univariate: Options dialog box opens (see Figure 22).

6. Select the Descriptive statistics check box, and then click the Continue button.

IBM SPSS Statistics 18, Part 4
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£if Univariate: Options @

Estimated Marginal Means

Factor(s) and Factor Interactions: Dizplay Means for:

[(OWERALL)
ABILITY
METHOD
ABILITYMETHOD

Display

|| Homogenedty tests

¥ Descriptive statistics

|| Estimates of effect size ___ Spread vs. level plat
[T] opserved power [ Residual piot
__ Parameter estimates __ Lack aof fit

[T contrast cosfficient matrix [T] General estimsbls furction

Significance level: Confidence intervals are 95.0 %

[Continue][ Cancel ][ Help ]

Figure 22 — Univariate: Options Dialog Box

7. Click the OK button. The Output Viewer window opens (see Figure 23 and Figure 24).

Dependent Variable:5CORE

ABILITY  METHOD Mean Std. Deviation M
lats blue-baoak 33.33 2817 3
computer 27.00 4583 3
Total 3017 4792 6
nane hiue-hook 26.67 4736 K]
carmputer 2800 3464 3
Tatal 27.33 3777 6
some  blue-hook 31.00 2. 646 3
3667 3.786 3
Tatal 33.83 4.262 G
Toatal blue-baak 30.33 4183 g
computer 3056 8747 9
Taotal 30.44 4878 18
Figure 23 — ANOVA Descriptive Output Table
Dependent Wariahle:SCORE
Source Type 1l Sum
of Sguares df Mean Sgquare F Sig.
Corrected Model 238.4444 5 47 G849 3.447 03r
Intercept 16683.556 1 16683.556 | 1206.040 .ooa
ABILITY 127.444 2 G3.722 4 606 033
METHOD 232 1 222 16 801
ABILITY * METHOD 110.778 2 55.3849 4.004 047
Errar 166.000 12 13.833
Tatal 17088.000 18
Corrected Total 404.444 17

Figure 24 — Output Table for Tests of Between-Subjects Effects
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Reporting the analysis results:

Ho: Reject in favor of Hy for Ability and the interaction between Ability and Method
(Ability*Method).

Hi: Typing ability and test method affect student test scores.

Explanation: Figure 23 lists the means and standard deviations from three abilities in two
methods. Students who have some typing ability and use the computer method achieve the
highest mean score (mean=36.67). As indicated in Figure 24, because the significance value of
Method (0.901) is more than the threshold value (0.05), it can be concluded that the Method
factor alone does not affect test scores. The significance values of 4bility (0.033) and the
interaction between the two factors 4bility*Method (0.047) are less than the threshold value
(0.05), leading to the conclusion that Ability and the combination of Ability and Method
(Ability*Method) do affect student test scores.

Importing/Exporting Data

SPSS Statistics can be used to analyze data in a Microsoft Excel spreadsheet. SPSS Statistics
provides the ability to import an Excel spreadsheet directly into the Data Editor window and
automatically create variables based on the column headings in the spreadsheet. Data can also b
exported from SPSS Statistics into Microsoft Excel and PowerPoint.

To import an Excel spreadsheet into SPSS Statistics:

e

1. Click the Open button — on the Data Editor toolbar. The Open Data dialog box opens

(see Figure 25).
2. Click the Files of type arrow and select Excel (*.xls, *.xlsx, *.xIsm) from the list.
3. Select the Demo.xls file, and then click the Open button. The Opening Excel Data
Source dialog box opens (see Figure 26).

£ Open Data E| £if Opening Excel Data Source g|
Look in: |u:I Partd - | Eﬂ EJ EE EE C:\Documents and Settings\Desktop\Part&\Demo. xls
] Demo.xls [ iRead variable names from the first row of data
Worksheet: | demo [A1:AB6401] -]

Range: | |

Maximum width for string columns:

(Lox ) (cancel]_rep |

File name: |Dem|:r.xls | Open
L] Figure 26 — Opening Excel Data Source
Files of type: |Exoe| (*xls, * xlsx, *xlsm) e | Dialog Box
Ei Minimize =tring widths based on observed values

Figure 25 — Open Data Dialog Box

4. Click the OK button. SPSS Statistics will process and read the Excel file and convert all
first row column headings into variables using the best approximation for the variable
attributes (see Figure 27 and Figure 28).

NOTE: If the Excel file contains multiple worksheets, select the desired worksheet by clicking
the Worksheet arrow (see Figure 26). In addition, if only a specific range of cells in the
worksheet is to be imported, the range must be specified in the Range box.
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Figure 27 — Excel File

i3t *Untitled2 [DataSet1] - PASW Statistics Data Editor

.'/l-:!_:-a W9 -™- =% |7 Demoxls [Compatibility Mode] - Microsaft Excel - = X
R =
- Home Insert Page Layout Formulas Data Review View Developer Acrobat @) - O X
== ¥ |||courier -8 =| 5 General @ A‘ S Insert - PE % [?a
P‘—:lu.g (B r o-|A v||=E==E- 8% | o % Delete ~ .EI-SML e
aste o || =i 5 | . ort & Find &
- |E D A I|%"}‘_‘| |<a8 %8| - || B Format - || 2~ Filter~ select~
Clipboard ™ Font ] Alignment I Number = Cells Editing
| Al - fe | Ace
A E C D E F G H I i) K
1 AGE.'HARITAI ADDRESS  IHCOME — INCCAT CAR  CARCAT ED EHPLOY RETIRE EMPCAT
2 39 1 12 72.00 3.00 37.00 3.00 1 23 0 3
3 56 a 29 153.00 4.00 76.00 3.00 1 35 0 3
4 28 1 | 28.00 2.00 13.90 1.00 3 4 0 1
5 24 1 4 26.00 2.00 13.00 1.00 4 0 0 1
4 25 1 2 23.00 1.00 11.30 1.00 2 5 0 2
7 45 a | 76.00 4.00 37.30 3.00 3 13 0 2
8 44 1 17 144 .00 4.00 72.10 3.00 2 23 0 3
9 46 1 20 75.00 4.00 37.10 3.00 1 29 0 3
10 41 1] 10 26.00 2.00 13.00 1.00 1 8 1] 2
11 29 1] 4 19.00 1.00 9.60 1.00 2 10 1] 2
12 24 1] 1] a9.00 4.00 44 .40 3.00 3 12 1] 2
13 Eg 1] 17 72.00 .00 36.10 3.00 3 2 1] 1
14 28 1] ] 5. 00 3.00 28.20 2.00 4 1 0 1
W4k H| demo %]
Ready ﬂ

Fie Edit Miew Data Transform Analyze Graphs Utiites Add-ons Window Help

SHOM -~ BhA B 55 W a4

[1:aee |55 |Visible: 28 of 28 Varisbles

AGE MARITAL ADDRESS INCOME INCCAT CAR
1 55 1 12 72.00 3.00 37.00F)
2 56 0 29 153.00 4.00 76.00
3 28 1 9 28.00 2.00 13.90
4 24 1 4 26.00 2.00 13.00
5 25 1 2 23.00 1.00 11.30
6 45 0 76.00 4.00 37.30
T 44 1 17 144.00 4.00 7210, |4
8 46 1 20 75.00 400 3710
9 41 0 10 26.00 2.00 13.00
10 29 0 4 19.00 1.00 9.60
11 34 0 §9.00 4.00 44.40
12 55 0 7 72.00 3.00 36.10
13 28 0 55.00 3.00 28.20
14 21 1 20.00 1.00 9.60/+]
[ ——— [
—
Data View Variable View
I |PASW Statistics Processorisready | | | | |

Figure 28 — Excel File Imported into SPSS Statistics

The reverse situation may also arise, where data in an SPSS Statistics file must be analyzed using

Excel. This can be accomplished by exporting the contents of the Data Editor window into an

Excel spreadsheet.

To export SPSS Statistics data into an Excel spreadsheet:

1. Inthe Data Editor window, click the File menu and select Save As. The Save Data As

dialog box opens (see Figure 29).

2. Click the Save as type arrow and select Excel 97 through 2003 (*.xls) or Excel

2007(*.xlIsx) from the list.

NOTE: Selecting the Write variable names to spreadsheet check box will cause SPSS Statistics

to write the variable names as column headings in the spreadsheet.
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NOTE: If only certain variables from the Data Editor window are desired in the spreadsheet,
users can click the Variables button and select/deselect variables in the Save Data As: Variables

dialog box (see Figure 30).
&ii Save Data As g| i3k Save Data As: Variables
ook |lﬂ Part4 b4 | Eﬂ D S Only selected variables will be saved to specified data file.
Keep | Mame Label Crroler
¥ acE 1 B
[+ MERITAL 2
Il ADDRESS 3
[+ IMNCOME 4
W nccat 5
Il CAR g
] ] M caprcat 7
Keeping 28 of 28 variables. [ . ] m ED 3
—— e v -
Save astype: |Excel 2007 (*.xlex] -pwg
| = == | Selected: 28 of 25 variables
I Write variable names to spreadsheet . :
[ Save value labels where defined instead of data values [ - ] [ ] [ ]
m Cortinue Cancel Help
Figure 29 — Save Data As Dialog Box Figure 30 — Save Data As: Variables Dialog Box

Click the Look in arrow and select a location to save the file.

Type a name for the Excel file in the File name box.

Click the Save button. The Output Viewer window opens with a report summarizing the
details and results of the export operation (see Figure 31).

o~ w

Data written to C:\Documents and Settings\Desktop\Part4\Export.xlsx.
28 variables and 6400 cases written to range: SPSS.

Variable: AGE Type: Number Width: 11 Dec: 0
Variable: MARITAL Type: Number Width: 11 Dec: 0
Variable: ADDRESS Type: Number Width: 11 Dec: 0
Variable: INCOME Type: Number Width: 11 Dec: 2
Variable: INCCAT Type: Number Width: 11 Dec: 2
Variable: CAR Type: Number Width: 11 Dec: 2
Variable: CARCAT Type: Number Width: 11 Dec: 2
Variable: ED Type: Number Width: 11 Dec: 0

Figure 31 — SPSS Statistics Export Output Report

To export an SPSS Statistics Output chart into a PowerPoint slide:
1. Inthe Output Viewer window, click to select the table. A box appears around the table
and a red arrow = to the left of it.
Click the File menu and select Export. The Export Output dialog box opens (see Figure
32).
Click the Type arrow and select PowerPoint (*.ppt) from the list.
Click the Browse button. The Save File dialog box opens (see Figure 33).
Click the Look in arrow and select a location to save the file.
Type a name for the PowerPoint file in the File name box.
Click the Save button.
Click the OK button.

no

e A o
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i3 Export Output E3]
rObjects to Export
@a © Selected
rDocument
Type: Options:
|P0W3fm (*.ppt) ¥ | |Layers in Pivot Tables Honor Print Layer setting (set in Tabl... |
. . . . Wide Pivot Tables Wrap table to fit within page margins
*. A PowerPoint prezentation containing both pivot -
A tables and graphics wil be created. The Include Footnotes and Caption Yes
graphics will be embedded in Tagged Image File  |Uze Viewer outline entries as slide tit...|No
(TIF} format in the document. Text tems other . R R . .
than pivot tables will not be exported. Views of Models Heonor print =etting (st in Model Vie... =
Nonn senitn [y
File Name:
C:ADocuments and Settings\Desktop\Part4\Output. ppt | @mwse ]
rGraphics
- No options available |
(Lo J[ paste J[ Reset J( cancel |[ Hep |

Figure 32 — Export Output Dialog Box

i Save File X
Lookin: | ) Part4 ~| @ f3EE s

File name: |0u1pu1 | [ Save ]
Save as type: |PuwerPDint {*.ppt) - | it

Figure 33 — Save File Dialog Box

Using Scripting for Redundant Statistical Analyses

Every statistical analysis used by SPSS Statistics is executed through a special programming

language. The specific code used for each analysis can be captured, stored as a script file, and
edited if necessary. A series of scripts in a script file can be run either individually or all at the
same time. Scripting automates a series of statistical analyses that are performed on a data file

that changes data, but always contains the same variables. Scripts are captured and edited in the
SPSS Statistics Syntax Editor window.
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The following example illustrates the usefulness of capturing, storing, and running scripts. The
data for the example is taken from a classroom setting for a class that lasts one week. At the end
of each week, data is compiled for each student. The variables in the set include the subject
name, gender, pretest scores, posttest scores, grade point average, computer ownership, and
method of administering examinations for that individual. Each week, a report is generated that
answers a series of questions about the class from the previous week. The questions answered
and the statistical analyses used are the same every week, as described in Table 1.

Table 1 — Scripted Questions and Statistical Techniques

Question Statistical Technique(s) to Answer Question
Does the data set include equal numbers of e Split the file

each gender and each test method? e Crosstabs

Is there a difference between the male and e Select all cases

female pretest scores? e Independent-Samples T Test

Is there a difference between the male and e Independent-Samples T Test
female posttest scores?

Is there a difference between the overall e Paired-Samples T Test

pretest and posttest scores?

Do gender, computer ownership, and test e Three-Way ANOVA

method affect test scores?

Do gender, computer ownership, and test e Split the file

method affect test scores differently e Two-Way ANOVA

depending on gender?

Is there a linear relationship between the e Scatter plot graph with file split
pretest and posttest scores for each gender?

Can pretest scores predict posttest scores for e Simple regression with file split
each gender?

Is there an overall linear relationship between e Select all cases

pretest and posttest scores? e Scatter plot graph

Can pretest scores predict posttest scores? e Simple regression

To construct a script file that will automatically run the analyses:

1.
2.
3.

o

Open the ClassData.sav file.

Click the Edit menu and select Options. The Options dialog box opens (see Figure 34).
Click the Viewer tab, select the Display commands in the log check box, click the
Apply button, and then click the OK button.

NOTE: The script file is built by performing each statistical analysis in the desired order. All
analyses must be performed manually one time while the file is being built. In the current
example, the file will first be split, and then a crosstab table will be constructed.

Click the Data menu and select Split File. The Split File dialog box opens.

Select the Compare groups option, and then transfer the gender variable to the Groups
Based on box.

Click the Paste button to add the command to the script file. The Split File dialog box
closes and the PASW Statistics Syntax Editor window opens with the pasted command
displayed (see Figure 35).
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7. Inthe PASW Statistics Data Editor window, click the Analyze menu, point to
Descriptive Statistics, and select Crosstabs. The Crosstabs dialog box opens.

i Options E
chats | Pivot Tobles Flelocsions  Sogts | Mulle mpudatons | Sk Eotor
Genersl Viewer D, Gikrenay Outind Loty
Inibal Output State- Title:
Heey Fort: Sizer ey B
|I'E '!LB"‘ SansSerit - 35 .wmm
og -
W [ esrans
ILF_IL| ® Shown
|I[H O icen Page Tile
g [t Fart Size :
Lh! N Sanssert = aos=) (o [ (] W
iy
il
Test Cutput
|L.é: Fort Size
L Cr— = hes v (B [ ] W)
L
L1
| Display commands in the log
oK || cancel r'ﬁ__

Figure 34 — Options Dialog Box

= "Syntax1 - PASW Statistics Syntax Editor

EBX

File Edt View Data Transform Analyze Graphs  UMities  Add-ons  Run  Tools  Window  Help

SH6 M e~ R8P0 |

‘0‘ !, “ active: [DetaSetz = |

DATASET ACTIVATE
SORT CASES
SPLITFILE

DATASET ACTIVATE DataZet2.
SORT CASES BY gender,
P SPLIT FILE LAYERED BY gender |

[T

[ |Pasiy Statistics Processor isready| | [n4col2a| UM

Figure 35 — PASW Statistics Syntax Editor Window

8. Transfer the gender variable to the Row(s) box and the method variable to the

Column(s) box.

9. Click the Paste button. The Crosstabs dialog box closes and the command is pasted in
the PASW Statistics Syntax Editor window (see Figure 36). The first question in Table

1 has been entered into the script file.

NOTE: Scripts for each of the remaining analytical techniques can be entered into the script file
by using the Paste button in each dialog box after the parameters are set.

= "Syntax1 - PASW Statistics Syntax Ediior

EBX

File Ecit “isw Data Transform Analyze Graphs  Uities Add-ons  Run  Tools  Window  Help

SHEH -~ JELE R PO G

‘0‘ !, “ Active

DATASET ACTIWATE
SORT CASES

SPLIT FILE
CROSSTABS

DATASET ACTIVATE DataSet2.
SORT CASES BY gender.
SPLIT FILE LAYERED BY gender,

CROSSTABS
/TABELES=gender BY method
JFORMAT=AVALUE TABLES

g JCELLE=COUNT
10 JCOUNT ROUND CELL.
1k

1
2
3
4
5
B
7
B

| |PASWSta1\s1\csProcessorisready\ | lIn 11 Col 0] |NUM|

E= Save Syntax As le

Look in: |@ Desktop

j My Computer
\3 My Metwork Places

File name: |weskiyAnalysis sps

| ([(save )
<] (Lcancel ]

|Local Encoding -]

Save as type: |Syntax (*.zps)

Encoding:

Figure 36 — PASW Statistics Syntax Editor Window

Figure 37 — Save Syntax As Dialog Box

10. To save the script file, click the File menu in the PASW Statistic Syntax Editor window
and select Save As. The Save Syntax As dialog box opens (see Figure 37).
11. Select a location to save the file, enter a file name, and then click the Save button.

SPSS Statistics provides several options when running a script file. SPSS Statistics script files
have the .sps file extension. The Run menu of the PASW Statistic Syntax Editor window contains
commands for A//, Selection, and To End (see Figure 39).
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To run an existing script file:
1. Inthe Data Editor window, click the File menu, point to Open, and select Syntax (see

Figure 38). The Open Syntax dialog box opens.

2. Locate and select the WeeklyAnalysis.sps syntax file, and then click the Open button.
The PASW Statistics Syntax Editor window opens with the script displayed.

3. Inthe PASW Statistics Syntax Editor, click the Run menu and select All (see Figure
39). Every command in the script file is executed and the results are displayed in the
Output Viewer window.

NOTE: If the Display commands in the log check box in the Viewer tab of the Options dialog
box remains selected, individual script commands will appear with the output in the Output
Viewer window.

(8 Read Text Data...

File  Edit “iew Data Transform  Analyze Graphs  Uilities
Ty P
Cpen b
Cpen Database P

Figure 38 — File Menu When Selecting Syntax

Run  Toolz  Window  Help I

L29 Al
P Selection sk

=+| To End
Steg Through »
Active Dataset 4

Figure 39 — Run (Syntax) Menu
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