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Introduction 
Adobe Photoshop CS4, an industry standard, pushes the boundaries of digital imaging and 
editing. While widely used by professional photographers as well as web and graphic designers, 
Photoshop can also provide a creative outlet for amateurs, enthusiasts, and artists alike. 
 
This handout covers how to use the Vanishing Point filter to maintain the fidelity of image 
perspective. Furthermore, advanced resizing and cropping lessons introduce the Content-Aware 
Scale feature as well as new cropping techniques. 

Downloading the Data Files 
This handout includes sample data files that can be used for hands-on practice. The data files are 
stored in a self-extracting archive. The archive must be downloaded and executed in order to 
extract the data files. 

 The data files used with this handout are available for download at 
http://www.calstatela.edu/its/training/datafiles/photoshopcs4advp3.exe. 

 Instructions on how to download and extract the data files are available at 
http://www.calstatela.edu/its/docs/download.php. 

Working with Vanishing Point 
The term vanishing point refers to a point on an image where parallel lines appear to converge 
(see Figure 1). The following image illustrates a one point perspective, meaning there is one 
vanishing point (see Figure 1). Vanishing points affect the perspective of an image; users must 
keep that in mind in order to maintain the fidelity of the image when editing. The following 
exercises will help users become familiar with Photoshop’s Vanishing Point filter for editing 
images as well as getting creative with it. 

 
Figure 1 – Vanishing Point 

Using the Vanishing Point Filter to Add Content 
To manipulate an image but make it look realistic, users have to take into account the perspective 
of the image. In the following exercise, users will learn how to create a plane of reference and 
add objects to fit the existing perspective of an image. 
 

http://www.calstatela.edu/its/training/datafiles/photoshopcs4advp3.exe�
http://www.calstatela.edu/its/docs/download.php�


Adobe Photoshop CS4: Advanced, Part 3 3 

To add objects to an image with perspective: 
1. Start Adobe Photoshop CS4. 
2. Locate and open the vanishing_point.psd file. 
3. In the Layers panel, select the Graffiti 1 layer, and then turn on its layer visibility by 

clicking in the column to the left of the layer (see Figure 2). 

 
Figure 2 – Graffiti 1 Layer 

4. In the Tools panel, select the Rectangular Marquee tool . 
5. In the Document window, drag the mouse pointer to make a rectangular selection around 

the graffiti object (see Figure 3). 

 
Figure 3 – Graffiti Object Selected 

6. Click the Edit menu and select Cut. 
7. Click the Filter menu and select Vanishing Point (see Figure 4). The Vanishing Point 

dialog box opens (see Figure 5). 

 
Figure 4 – Vanishing Point Command on the Filter Menu 
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8. Select the Create Plane tool  located on the left side of the dialog box (see Figure 5). 

 
Figure 5 – Vanishing Point Dialog Box 

9. Click the upper left corner of the side of the truck, and then create a rectangular grid by 
clicking each subsequent corner (see Figure 5). 
NOTE: A blue grid indicates correct perspective. If a yellow or red grid appears, select the Edit 

Plane tool  and move the corners of the grid until it turns blue. 

10. Press Ctrl+V to paste the graffiti object. 
11. Use the Transform tool  to rotate and/or resize the graffiti object (see Figure 5). 

NOTE: Hold down the Shift key to keep the same aspect ratio. 

Figure 6). 
12. Drag the graffiti object to the area of the truck where the vanishing point plane was 

created (see 

NOTE

 

: Use the Transform tool  to resize further. 

Figure 6 – Adding Objects with Correct Perspective 

13. When finished, click the OK button to return to the canvas (see Figure 5). 
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Figure 7 – Before and After Using the Vanishing Point Filter 

Editing Images with Correct Perspective 
When editing an image with perspective, users should do it in the Vanishing Point dialog box in 
order to maintain that same perspective without compromise. In the following exercise, users 
will practice using the Stamp tool located within the Vanishing Point dialog box to remove items 
from an image. 
 
To edit an image using the Vanishing Point filter: 

1. Locate and open the editing_vanishing_point.psd file. 
2. Click the Filter menu and select Vanishing Point. The Vanishing Point dialog box 

opens. 
3. If necessary, use the Edit Plane tool  to adjust the already created plane. 

4. To remove the brush from the scene, select the Stamp tool . 
5. Hold down the Alt key and click on an empty area of the deck near the brush, and then 

release the Alt key. 
6. Hover the mouse pointer over the brush to see a live preview of the sampled area (see 

Figure 8). 

 
Figure 8 – Stamp Tool Live Preview 

: If the sampled area is too large or too small, decrease or increase the Diameter 

 of the Stamp tool located at the top of the Vanishing Point dialog box, and then 
sample the area again. 

NOTE

7. Align the sample over the desired area, then using the lines of the deck as reference, click 
on the area that needs to be replaced. 



Adobe Photoshop CS4: Advanced, Part 3 6 

8. Repeat steps 5 through 7 over the entirety of the brush. 
NOTE: Sampling often will allow users to achieve the most accurate and realistic results. 

9. When finished, click the OK button to return to the canvas. 

 
Figure 9 – Before and After Editing an Image with the Vanishing Point Filter 

Resizing with Content-Aware Scale 
The Content-Aware Scale feature, new to Photoshop CS4, allows users to resize only a part of an 
image without adjusting the rest of it. This can especially come in handy when trying to fit an 
image to standard photographic dimensions (e.g., 4x6 inches or 8x10 inches). 
 
To resize an image using content-aware scaling: 

1. Locate and open the content-aware_scale.psd file. 
2. In the Tools panel, select the Lasso tool . 
3. With the Mantis layer selected in the Layers panel, drag the mouse pointer make a 

selection around the praying mantis and its shadow (see Figure 10). 

 
Figure 10 – Selecting Using the Lasso Tool 

4. Click the Select menu and select Save Selection. The Save Selection dialog box opens 
(see Figure 11). 

5. Click the OK button. 
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Figure 11 – Save Selection Dialog Box 

6. Click the Select menu and select Deselect. 
7. Click the Edit menu and select Content-Aware Scale (see Figure 12). 

 
Figure 12 – Content-Aware Scale Command on the Edit Menu 

8. On the Options bar, click the Protect arrow and select Alpha 1 from the list (see Figure 
13). 

 
Figure 13 – Protect List on the Options Bar 

9. Drag a side or corner handle on the border of the bounding box to resize the image. 

10. When finished, click the Commit button  on the Options bar. 
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Figure 14 – Before and After Resizing an Image with Content-Aware Scale 

Advanced Cropping 
The following lessons will show users how to crop an image to a specific size and how to 
maintain the same aspect ratio as the original image when cropping. Both techniques can be used 
to fit or maintain standard photographic dimensions or any desired size, depending on the intent 
of the project at hand. 

Cropping to a Specific Size 
When the Crop tool is selected, the Options bar will change, showing additional cropping 
options. 
 
To crop an image to a specific size: 

1. Locate and open the cropping_4by6.psd file. 
2. In the Tools panel, select the Crop tool . 
3. On the Options bar, type 6 in the Width box and 4 in the Height box (see Figure 15). 

 
Figure 15 – Setting the Width to Height Cropping Ratio 

4. Leave the Resolution box empty; however, make sure the unit is set to pixels/inch (see 
Figure 15). 

5. On the canvas, drag the mouse pointer to create a cropping border (see Figure 16). 
NOTE

Figure 16
: Once the mouse button is released, users can adjust the cropping border by dragging the 

corner handles (see ). The area within the border will remain 6 inches by 4 inches no 
matter how big or small it is. However, the resolution will change accordingly. 

 
Figure 16 – Adjusting the Cropping Border 
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6. To complete the crop, press the Enter key. Or, click the Commit button  on the 
Options bar. 

Maintaining the Same Width to Height Ratio When Cropping 
The following steps will show users how to crop an image while maintaining the same aspect 
ratio as the original image, no matter what the size. 
 
To maintain the same aspect ratio as the original image: 

1. Locate and open the aspect_ratio_cropping.psd file. 
2. Click the Select menu and select All (see Figure 17). 

 
Figure 17 – All and Transform Selection Commands on the Select Menu 

3. Click the Select menu and select Transform Selection (see Figure 17). 
4. Hold down the Shift key and drag a corner handle of the bounding box to resize the 

selection (see Figure 18). 

 
Figure 18 – Transforming and Dragging the Selection 

5. Drag the selection to the desired area to be cropped (see Figure 18). 

6. When finished, press the Enter key. Or, click the Commit button  on the Options 
bar.  
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7. Click the Image menu and select Crop. 
8. Click the Select menu and select Deselect. 

Increasing Depth of Field 
Close up photography can create dramatic imagery; however, using a macro lens will produce an 
image with a shallow depth of field, meaning only parts of the image will be in focus while the 
rest might be blurry. The following lesson will use the Auto-Blend Layers feature in Photoshop 
CS4 to increase the depth of field and create an image where everything is in focus. 
 
To increase the depth of field in an image: 

1. Locate and open the dof1.psd, dof2.psd, dof3.psd, and dof4.psd files. 

2. On the Application bar, click the Arrange Documents button  and select 4 Up 

 (see Figure 19). 

  
Figure 19 – Arrange Documents 4 Up 

3. To get all four images into one document, click the File menu, point to Scripts, and 
select Load Files into Stack (see Figure 20). The Load Layers dialog box opens (see 
Figure 21). 

 
Figure 20 – Load Files into Stack Command on the File Menu 

4. Click the Add Open Files button (see Figure 21). 
5. Select the Attempt to Automatically Align Source Images check box (see Figure 21). 
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Figure 21 – Load Layers Dialog Box 

6. Click the OK button (see Figure 21). Photoshop creates a new document titled Untitled1 
with all four images perfectly aligned. 

7. Close the dof1.psd, dof2.psd, dof3.psd, and dof4.psd files. 
8. With only the Untitled1 document open, select all layers in the Layers panel, (see Figure 

22). 

 
Figure 22 – All Layers Selected in the Layers Panel 

9. Click the Edit menu and select Auto-Blend Layers (see Figure 23). The Auto-Blend 
Layers dialog box opens (see Figure 24). 

 
Figure 23 – Auto-Blend Layers Command on the Edit Menu 
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10. Under Blend Method, select the Stack Images option (see Figure 24). 
11. Select the Seamless Tones and Colors check box (see Figure 24). 

 
Figure 24 – Auto-Blend Layers Dialog Box 

12. When finished, click the OK button (see Figure 24). 
NOTE: Before printing, users should click the Layer menu and select Flatten Image. 

Fixing Skies from Gray to Dynamic 
When shooting landscapes, photographers will use a neutral density filter in order to get a well 
exposed foreground as well as background (e.g., sky). Without it, the sky can look gray, or if the 
sky is well exposed, the foreground will turn out too dark. The neutral density filter is dark at the 
top and graduates down to transparent at the bottom so that the entire image is well exposed. 
Photoshop can replicate this graduated effect. 
 
To clear up gray skies: 

1. Click the File menu and select Open As (see Figure 25). The Open As dialog box opens. 

 
Figure 25 – Open As Command on the File Menu 

2. Locate and select the neutral_density_filter.tif file, and then click the Open As arrow 
and select Camera Raw from the list (see Figure 26). 

 
Figure 26 – Camera Raw Selected from the Open As List 



Adobe Photoshop CS4: Advanced, Part 3 13 

3. Click the Open button (see Figure 26). The Camera Raw 5.0 dialog box opens. 
4. In the Basic panel, click the White Balance arrow and select Auto from the list (see 

Figure 27). 

 
Figure 27 – Basic Panel 

5. Drag the Exposure slider to +1.00 (see Figure 27). 

6. Select the Graduated Filter tool  on the Camera Raw toolbar (see Figure 28). 

 
Figure 28 – Camera Raw 5.0 Toolbar 

7. While holding down the Shift key, click at the top of the image and drag the mouse 
pointer straight down to the horizon line (see Figure 29). 

 
Figure 29 – Graduated Filter Line 

8. In the Graduated Filter panel, drag the Exposure slider to -0.75 (see Figure 30). 
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Figure 30 – Graduated Filter Panel 

9. Drag the Brightness slider to -0.10 (see Figure 30). 
10. Click the color swatch next to Color to open the Color Picker dialog box, and then use 

the dropper to select a rich, blue tone (see Figure 31). 

 
Figure 31 – Color Picker Dialog Box 

11. When finished, click the OK button (see Figure 31). 
12. In the Camera Raw 5.0 dialog box, do one of the following: 

 To open the image in Photoshop, click the Open Image button. 
 To apply the changes without opening the image, click the Done button. 

Creating High Dynamic Range (HDR) Images 
In image processing, computer graphics, and photography, high dynamic range (HDR) imaging 
is a set of techniques that allows a greater dynamic range of luminance between the lightest and 
darkest areas of an image than standard digital imaging techniques or photographic methods. 
This wider dynamic range allows HDR images to more accurately represent the wide range of 
intensity levels found in real scenes, ranging from direct sunlight to faint starlight. 
 
NOTE

 

: Users will need at least three identically composed images with varying degrees of exposure (e.g., 
normal exposure, one stop underexposed, and one stop overexposed) in order to use the Merge to HDR 
feature in Photoshop. 
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To create an HDR image: 
1. Locate and open the 1.psd, 2.psd, 3.psd, and 4.psd files. 
2. Click the File menu, point to Automate, and select Merge to HDR. 
3. In the Merge to HDR dialog box, click the Add Open Files button (see Figure 32). 

NOTE: If the files are not open already, click the Browse button instead to locate and add the 
necessary files for merging to HDR (see Figure 32). 

 
Figure 32 – Merge to HDR Dialog Box 

4. Click the OK button (see Figure 32). A second Merge to HDR dialog box opens. 
5. Click the OK button. A third Merge to HDR dialog box opens (see Figure 33). 
6. Click the OK button to create the merged image (see Figure 33). 

 
Figure 33 – Second Merge to HDR Dialog Box 
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7. In Photoshop, click the Image menu, point to Mode, and select 8 Bits/Channel (see 
Figure 34). 

 
Figure 34 – 8 Bits/Channel Command on the Image Menu 

8. In the HDR Conversion dialog box, click the Method arrow and select Local 
Adaptation (see Figure 35). 

 
Figure 35 – HDR Conversion Dialog Box 

9. Expand the Toning Curve and Histogram section by clicking the arrow  next to it 
(see Figure 35). 

10. To balance out the tones in the image, drag the point located in the upper right corner of 
the chart to the left, towards the edge of the gray histogram (see Figure 35). If necessary, 
drag the shadow point located in the lower left corner of the chart to the right, towards the 
other edge of the gray histogram (see Figure 35). 

11. When finished, click the OK button (see Figure 35). 
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