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Introduction 
Websites can be created by using one of many programming languages (e.g., HTML, JSP, PHP, 
ASP, ASP.NET, or Perl). Among those languages, HTML is the most basic text-based language 
that has been used in web design since 1989. HTML consists of two parts: 1) content that will be 
displayed in a web browser, and 2) markup or tags, which are encoded information that are 
generally hidden from web page viewers. This three-part handout will help users create a basic 
website using fundamental HTML knowledge that they can build on with more advanced 
techniques. This final part builds upon the website that was created in the first and second 
handouts. It covers creating an image gallery and image thumbnails, including the final process 
of uploading the website to the Internet. 

Downloading the Data Files 
This handout includes sample data files that can be used for hands-on practice. The data files are 
stored in a self-extracting archive. The archive must be downloaded and executed in order to 
extract the data files. 

 The data files used with this handout are available for download at 
http://www.calstatela.edu/its/training/datafiles/html5p3.exe. 

 Instructions on how to download and extract the data files are available at 
http://www.calstatela.edu/its/docs/download.php. 

Creating an Image Gallery 
An image gallery is an effective way to share photographs and images with friends, families, co-
workers, etc. In an image gallery, thumbnails are used to represent the full size images which 
will be displayed when the thumbnails are clicked. Thumbnails are used to reduce the load time 
of a web page. 

Creating a New Page for the Image Gallery 
In this lesson, a new page is created using the template file that was created in the HTML5 and 
CSS3 Part 2 handout. This new page will serve as an image gallery page. 
 
To create a new page from the template file: 

1. Launch Notepad++. In the ITS Training Program computer labs, click the Start button, 
point to All Programs, point to Notepad++, and select Notepad++. 

2. Click the File menu and select Open. The Open dialog box opens. 
3. Navigate to the data files folder, select the template.html file, and then click the Open 

button. 
4. Click the File menu and select Save As. The Save As dialog box opens. 
5. In the File name box, type pictures.html. 

NOTE: Make sure to save the file in the same directory that contains the index.html file. 

6. Click the Save button. 
7. To add a header to the new page, add the word Pictures between the opening <span 

class="header"> tag and the closing </span> tag. 

http://www.calstatela.edu/its/training/datafiles/html5p3.exe
http://www.calstatela.edu/its/docs/download.php
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Creating the Image Gallery Table 
Tables are ideal for organizing content symmetrically and consistently. This works not only for 
text, but images as well. 
 
To create the image gallery table: 

1. Add a new line after the closing </div> tag of the <div class="trim"> tag, and then type 
the following code to create a table with two rows and three cells in each row. 

<table> 
<tr> 

<td></td> 
<td></td> 
<td></td> 

</tr> 
<tr> 

<td></td> 
<td></td> 
<td></td> 

</tr> 
</table> 
NOTE: <table> creates a new table. <tr> creates a new row. <td> creates a new cell. 

2. To apply styles to the table, add a new line before the closing </style> tag, and then type 
the following CSS rule. 
table{ 

background-color:lightgrey; 
width:95%; 
margin-left:auto; 
margin-right:auto; 
text-align:center; 

} 

Creating Thumbnails for the Full Size Images 
In order to reduce both web page size and load time, all pictures on a page should be compressed 
as much as possible and, in some cases, replaced with their thumbnail counterparts. In this 
lesson, Adobe Photoshop is used to create thumbnails of the full size images. Photoshop is a 
powerful picture and image editor software that allows you to customize images to fit the needs 
of your website. 
 
To create thumbnails using Photoshop: 

1. Launch Photoshop. In the ITS Training Program computer labs, click the Start button, 
point to All Programs, point to Adobe Design Premium CS5, and select Adobe 
Photoshop CS5. 
NOTE: Other alternative image editors which can be used to create image thumbnails are Gimp 
and Paint.net. 

2. Click the File menu and select Open. The Open dialog box opens. 
3. Navigate to the images folder located inside the data files folder, select the 1.jpg file, and 

then click the Open button. 
4. Click the Image menu and select Image Size. The Image Size dialog box opens. 
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5. To maintain the ratio of width to height, make sure that the Constrain Proportions 
check box is selected. 

6. Under Pixel Dimensions, type 150 in the Width box. The value in the Height box 
automatically changes in proportion to the width. 

7. Click the OK button. 
8. To save the thumbnail with a different file name, click the File menu and select Save As. 

The Save As dialog box opens. 
9. In the File name box, type tn_ before the name of the original file (e.g., if the full size 

image is named 1.jpg, the thumbnail of the same image should be saved as tn_1.jpg). 
10. Click the Save button. The JPEG Options dialog box opens. 
11. Click the OK button. 
12. Repeat steps 2 through 11 to create thumbnails for the remaining numbered images 

(2.jpg, 3.jpg, 4.jpg, 5.jpg, and 6.jpg). 

Inserting the Thumbnails into the Table Cells 
In this lesson, the thumbnails are inserted into each table cell so that they can then be linked to 
the full size images. 
 
To insert the thumbnails into the table cells: 

1. In Notepad++, place the cursor between the first opening <td> tag and its corresponding 
closing </td> tag, and type <img src="images/tn_1.jpg" />. This inserts the thumbnail 
of the first image into the first table cell. 

2. Repeat step 1 to insert the remaining thumbnails (tn_2.jpg, tn_3.jpg, tn_4.jpg, tn_5.jpg, 
and tn_6.jpg) into the remaining table cells (see Figure 1). 

 
Figure 1 – HTML Code of Table with Thumbnails 

Linking the Thumbnails to the Full Size Images 
In this lesson, the thumbnails are linked to their corresponding full size images. When a viewer 
clicks on a thumbnail, the full size image will open in a new browser window. 
 
To link the thumbnails to the full size images: 

1. To link the first thumbnail, add <a href="images/1.jpg" target="_blank"> before 
<img src="images/tn_1.jpg" />, and then add the closing </a> tag after <img 
src="images/tn_1.jpg" />. 

2. Repeat step 1 to link the remaining thumbnails to their corresponding full size images 
(see Figure 2). 
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Figure 2 – HTML Code of Table with Linked Thumbnails 

Uploading to the Internet 
After the website has been created, it needs to be uploaded to a web server so that it can be 
viewed by everyone. Web space is available on the CSULA web server for publishing 
educational, research, and other academic related material. There are also several free web 
hosting services available on the web. 

Uploading the Files to the CSULA Web Server 
In this lesson, the website is uploaded to a temporary directory on the CSULA web server. This 
directory is intended to be used during the HTML5 Part 3 workshop for demonstration purposes 
only. 
 
To upload the files to the CSULA web server using Secure FTP: 

1. Click the Start button, point to All Programs, point to INTERNET apps - Utils, point 
to Secure - SSH FTP, and select Secure File Transfer Client. 

2. Click the Connect button on the Toolbar (see Figure 3). The Connect to Remote Host 
dialog box opens. 

 
Figure 3 – Connect Button on the Toolbar 

3. In the Host Name box, type ftp.calstatela.edu. 
4. In the User Name box, type trainer. 
5. Leave the entry in the Port Number box as 22. 
6. Click the Authentication Method arrow and select Password from the list. 
7. Click the Connect button. The Message from the server dialog box opens. 
8. Click the OK button to agree to Cal State L.A.’s policies and user guidelines regarding 

appropriate use and confidentiality. The Enter Password dialog box opens. 
9. In the Password box, enter the password provided by the trainer during the workshop. 
10. Click the OK button. The left pane of the window displays the files on your local 

computer, and the right pane displays the files on the server. 
11. In the right pane, change the path from /home/trainer to /www/www/tmp/workshop, 

and then press the Enter key (see Figure 4). 
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Figure 4 – Changing the Path 

12. To upload the files, drag them from the local computer (left pane) to the server (right 
pane). 

13. To view the website, open a web browser and go to 
http://www.calstatela.edu/tmp/workshop/. 

Alternate Method for Uploading to the Internet 
There are many companies that offer free web hosting services. In this lesson,  
000webhost.com is used to host the website. Before you can upload the files, you must first 
create an account. 

 
Figure 5 – 000webhost.com Home Page 

To create a free hosting account: 
1. Open Mozilla Firefox or any other web browser and go to http://www.000webhost.com. 
2. On the right side of the home page, click the Sign Up button (see Figure 5). The Order 

Free Web Hosting page displays. 
3. Type the desired subdomain name in the Subdomain field (the second form field). 

NOTE: Subdomains are free, but they are always attached to a main domain (e.g., 
mymail.calstatela.edu). If you want your own domain (e.g., calstatela.edu), you can purchase it 
online for various prices. 

4. Fill out the rest of the form. Make sure to type the CAPTCHA text and select the I agree 
to Terms Of Service check box. 

5. Click the Create My Account button. The List of your domains page displays and an e-
mail is sent to the e-mail address you provided. 

http://www.calstatela.edu/tmp/workshop/
http://www.000webhost.com/
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6. In order to confirm your registration, click the confirmation link in the e-mail sent to you 
by 000webhost.com. After the site builds, an addition e-mail is sent to you with all your 
account information. 

 
To upload the files: 

1. Go to http://members.000webhost.com/login.php and log in with your 000webhost.com 
account. 

2. On the List of your domains page, click the Go to CPanel link. 
3. In the Files group, click File Manager (see Figure 6). The File Manager page displays 

in a new window. 
NOTE: After a period of inactivity, the system will automatically log you out and prompt you for 
a password. To continue, type your 000webhost.com account password in the Password field, 
and then click the Continue button. 

 
Figure 6 – Files Group 

4. Under the Name column, click the public html folder. 
5. Select the check box next to the default.php file, and then click the Delete button. The 

Delete directories and files page displays. 
6. Click the green check mark  to confirm, and then click the blue back arrow  to 

return to the File Manager page. 
7. Click the Upload button. The Upload files and archives page displays. 
8. In the Files section, click the Browse button. The Choose File to Upload dialog box 

opens. 
9. Navigate to the folder that contains the website files, select the index.html file, and then 

click the Open button. The file location is entered into the Browse box and a new 
Browse button appears. 

10. Repeat steps 8 and 9 to add the videos.html and pictures.html files. 
11. Click the green check mark to upload the files, and then click the blue back arrow to 

return to the File Manager page. 
12. Click the New Dir button to create a new folder. The Create new directories page 

displays. 
13. Type images in the first New directory name field. 
14. Click the green check mark to create the folder, and then click the blue back arrow to 

return to the File Manager page. 
15. Under the Name column, click the images folder. 
16. Click the Upload button. The Upload files and archives page displays. 
17. In the Files section, click the Browse button. The Choose File to Upload dialog box 

opens. 
18. Navigate to the images folder of the website, select the 1.jpg file, and then click the 

Open button. The file location is entered into the Browse box and a new Browse button 
appears. 

19. Repeat steps 17 and 18 to add the remaining images (2.jpg, 3.jpg, 4.jpg, 5.jpg, 6.jpg, 
tn_1.jpg, tn_2.jpg, tn_3.jpg, tn_4.jpg, tn_5.jpg, tn_6.jpg, csula_banner.gif, and 
darkTile.gif). 

http://members.000webhost.com/login.php


HTML5 and CSS3 Part 3: Creating an Image Gallery and Uploading to the Internet 8 

20. Click the green check mark to upload the files, and then click the blue back arrow to 
return to the File Manager page. 

21. To view the website, copy your domain located in the upper-right corner of the File 
Manager page, paste it into the web browser’s Address bar, and then press the Enter 
key. The website is now on the web. 
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