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Introduction to Microsoft FrontPage 2003 
FrontPage 2003 is a software application for creating and modifying entire Web sites or single 
Web pages. The program, in its normal view, provides a simple interface for users to create and 
design simple, elegant Web pages. It also offers an HTML interface with color-coded command 
lines and organized formatting for more experienced users. A server is needed to upload the 
finalized Web sites. 

This advanced guide to FrontPage 2003 introduces more advanced functions of the program that 
are built on the elements presented in both the Introductory and Intermediate FrontPage 2003 
handouts. 

Importing a Web 
Existing Web pages and other files (e.g., images, video clips) located on the World Wide Web or 
a hard drive can be imported directly into FrontPage. This is useful in the case the original files 
of a Web are lost, or to modify a Web created by someone else (provided the developer obtains 
permission).  

IMPORT THE FILES FROM A LOCAL NETWORK OR DRIVE 
To import files from a local or network drive: 
1. Select File menu ► Import… command. The Import Web Site Wizard - Welcome dialog 

box opens (see Figure 1). 

 
Figure 1 - Import Web Site Wizard - Welcome Dialog Box 

2. Select the File System option button. 
3. Specify the location in the Web Site Location text box ► Next> button.  The Import Web 

Site Wizard – Choose your destination web location dialog box opens (see Figure 2). 
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Figure 2 - Choose source from a local network 

4. Specify the destination in the Local copy location: text box ► Next> button. 
5. When FrontPage successfully imports and stores the web, the Import Web Site Wizard – 

Congratulations dialog box opens (see Figure 3) ► Finish button. 

 
Figure 3 - Import Web Site Wizard - Congratulations Dialog Box 

IMPORT FILES FROM THE WORLD WIDE WEB (WWW) 
Files can be directly imported from a website on the Internet. Be careful of the legal implications 
of modifying web content owned by someone else.  

To import files from the WWW: 
1. Select File menu ► Import… command. The Import Web Site Wizard - Welcome dialog 

box opens (see Figure 1). 
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2. Select the HTTP option button and specify the URL of the web site in the Web Site 
Location text box ► Next> button.  The Import Web Site Wizard – Choose your 
destination web location dialog box opens (see Figure 2). 

3. Specify the destination in the Local copy location: text box ► Next> button.  The Import 
Web Site Wizard – Set Import Limits dialog box opens (see Figure 4). 

 
Figure 4 - Import Web Site Wizard – Set Import Limits Dialog Box 

4. Specify any import limits by clicking the appropriate check boxes ► Next> button. 
5. When FrontPage successfully imports and stores the web, the Import Web Site Wizard – 

Congratulations dialog box opens (see Figure 3) ► Finish button. 

!NOTE: 
Limitations can be specified on the files to be imported (see Figure 4).  These limits include 
the depth of levels of the web site, the number of kilobytes, or only HTML and image files. 

Inserting Advanced Controls Web Components 

INSERTING A JAVA APPLET 
Java applets are frequently used to add effects and interactivity (e.g., animations, games) to a 
web site. However, depending on the browser settings of the site visitor, the applets may not 
display properly or errors messages may appear. FrontPage provided the capability to design a 
web site for compatibility with specific browsers and technologies. If the type of browser 
specified does not support Java applets, the selection for Java applets will be unavailable in the 
Insert Web Component dialog box.  

To insert a Java applet: 
1. Place the cursor to where the applet is to be inserted. 
2. Select the Insert menu ► Web Component. The Insert Web Component dialog box 

opens (see Figure 5). 
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Figure 5 - Insert Web Component Dialog Box 

3. In the Component type: list box, click “Advanced Controls.” 
4. In the Choose a control: list pane, double-click “Java Applet.” The Java Applet 

Properties dialog box opens (see Figure 6). 
5. Do one or more of the following in the Java Applet Properties dialog box:  

o In the Applet source: text box, type the name of the Java applet source file. Java 
applet source files usually have a “.class” filename extension.  

o In the Applet base URL: text box, type the URL of the folder containing the Java 
applet source file (if it is not in the same directory as the web page).    

o In the Message for browsers without Java support: text box, type HTML or plain 
text to display in place of the Java applet on Web browsers that do not support Java 
applets.  

o In the Applet parameters: section; click the Add… button for each parameter to be 
passed to the Java applet, and then type the parameter name and value (if required).  

o In the Size and Layout sections specify the alignment, horizontal spacing, vertical 
spacing, width and height (in pixels) of the Java applet.  

 
Figure 6 – Java Applet Properties Dialog Box 
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!NOTE: 
Because Java does not provide a mechanism for displaying the valid properties and values for 
a given applet, consult the documentation that comes with the Java applet then specify the 
correct parameter names and legal values for each parameter. 

To set or modify properties of a Java applet: 
• In Page view, right-click the Java applet and select Java Applet Properties… on the 

shortcut menu. The Java Applet Properties dialog box opens.  Modify any of the 
parameters in the dialog box. 

INSERTING A PLUG-IN 
A plug-in is a set of software modules that integrate into Web browsers to offer a range of 
interactive and multimedia capabilities. 

Some plug-ins occupy space on a web page, as in the case of certain MPEG video players. Those 
plug-ins may have a display area as well as video controls for playing, pausing, or rewinding, for 
example.   

Other plug-ins, like some MIDI players, need not occupy any space on a web page. Many web 
pages use these types of plug-in (which begin playing music as soon as a web page loads) with 
no "on" or "off" buttons. 

Many software engineers create their own plug-ins to enable software to run in a Web browser. 
Because software engineers may follow different conventions when designing plug-ins, different 
plug-ins might behave differently among different browser types and versions.  

To add a plug-in: 
1. Select the Insert menu ► Web Component.  The Insert Web Component dialog box 

opens (see Figure 5). 
2. In the left pane, click Advanced Controls.  
3. In the right pane, double click Plug-In.  The Plug-In Properties dialog box opens (see 

Figure 7).  
4. In the Data source: text box, type the URL of the file for the plug-in to load, or click the 

Browse button to locate the file.  
5. Type or modify the following information in the Plug-In Properties dialog box:   

o To specify a message for browsers that do not support plug-ins, type an HTML or 
plain text message in the Message for browsers without plug-in support: text box.  

o Size  - Specify the width and height (in pixels) of the plug-in in the appropriate text 
box.  

o Hide  - To hide the plug-in when the page is viewed in a Web browser, select the 
Hide plug-in check box.  

o Layout - To specify layout attributes; adjust the alignment, border thickness, and 
horizontal and vertical spacing for the plug-in.  

To hide a plug-in when a site visitor views the page in a Web browser:  
1. In Page view, right-click the plug-in and select Plug-In Properties… on the shortcut 

menu. The Plug-In Properties dialog box opens (see Figure 7). 
2. Click the Hide plug-in check box ► OK button.  



To create a message to display in browsers without plug-in support: 
1. In Page view, right-click the plug-in and select Plug-In Properties… on the shortcut 

menu. The Plug-In Properties dialog box opens (see Figure 7). 
2. In the Message for browsers without plug-in support: text box, type the HTML or plain 

text to be displayed in place of the plug-in.  

 
Figure 7 - Plug-In Properties Box 

Working with Graphics and Multimedia 

REDUCING GRAPHICS DOWNLOADING TIME 
Sometimes images can take a long time to download because of the large file size. There are 
several techniques that can be used to reduce the size, speed up the download, and reduce 
waiting time. 

Resizing & Resample the Image 
A picture can be resized by selecting it and dragging one of the sizing handles (black squares 
around image). To keep the picture in proportion, drag one of the corner handles. When the size 
of a picture is decreased, it might appear smaller, but it actually takes the same time to download 
unless it is resampled. Only then will the file size change to match the picture size and reduce the 
download time. 

To resample a picture: 
1. Select the image to resize and if necessary display the Pictures toolbar. 
2. Adjust the image to the desired size by using a sizing handle 
3. Click the Resample button to reduce picture size (see Figure 8).  

Converting a Graphic Image to JPEG 
JPEG (.jpg - Joint Photographics Expert Group) files can display millions of colors. While .gif 
files cannot display as many colors as .jpg files, .gif files have an advantage over .jpg files in that 
one color, such as the background color in a .gif file, can be made transparent, making it blend 
better with the page color scheme. 
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Lowering the Graphic Resolution 
Lowering the resolution of a .jpg file can be done by changing the properties of the graphic. To 
change the graphic properties, save the web page containing the altered image. During this 
process, FrontPage will prompt to save the graphics on that page.  

To change the properties of a .jpg or .gif graphic that has already been saved to the web page: 
1. The image must be changed somehow (such as rotating it or cropping it) and then the 

save button  clicked.  The Save Embedded Files dialog box opens (see Figure 9). 
2. Click the name of the graphic ► Picture File Type… button.  The Picture File Type 

dialog box opens (see Figure 10). 
3. Select the picture file type ► OK button ► OK button. 

Creating a Thumbnail Version 
A thumbnail is a small version of an image on a web page, often containing a hyperlink to a full-
size version of the image. To see the original version of the picture, the site visitor simply clicks 
the thumbnail and the original picture appears. This feature saves both page space and 
downloading time. 

To create a thumbnail: 
1. In Page view, select the picture used to create the thumbnail. 
2. If necessary, display the Pictures toolbar (see Figure 8). 
3. Click the Auto Thumbnail button to create the thumbnail with a link to the full-size 

image. 

!NOTE: 
Auto Thumbnail will be unavailable if the graphic selected is already smaller than a 
thumbnail, if the graphic has hyperlink or hot spots set in it, or if the graphic is an animation.  

 
Figure 8 - Picture Toolbar 

 
Figure 9 - Save Embedded Files Dialog Box 

 
Figure 10 - Picture File Type Dialog Box 
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INSERTING A VIDEO CLIP 
A video within a web page can be used to call attention to a particular page and its contents. 
Video files can be inserted from their storage locations or from the Insert Clip Art task pane. 
Video files can also be downloaded from the World Wide Web. The extension in a video file 
name indicates its multimedia format. Common video formats include .avi, .mpg, .wmv, and 
.mpeg. By default, video effects are set to automatically start when the web page opens. This 
setting can be changed so that the video plays only when a mouse pointer moves over it. Video is 
set to play one time by default but can be set to play continuously, if desired. Settings for video 
are controlled on the Video tab of the Picture Properties dialog box. If a video can play in 
Windows Media Player, it can be added to a web page. However, not all browsers support 
video. 

To insert a video clip: 
1. Position the cursor at the location where the video clip is to be inserted. 
2. Select the Insert menu. ► Picture ►Video….  The Video dialog box opens.  
3. Locate the desired video file ► Open button. 

!NOTE: 
To resize a video clip, click the object to display the sizing handles (squares on object 
border). Then drag the sizing handles as desired. 

4. Return to the Normal page view ► right-click the video object ►Picture Properties… 
The Picture Properties dialog box opens (see Figure 11).  

5. Select the Video tab ► Forever option button ► OK button. Save the web page and 
preview it again. Notice that the video plays continuously 

6. To change when the video plays, select an option in the Start section.  

!NOTE: 
To move a video clip, simply select the object on the page and drag it to the desired location. 

 
Figure 11 - Picture Properties (Video) Dialog Box 
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Applying Dynamic HTML Effects 
Dynamic HTML (DHTML) can be used to animate web page elements such as text, pictures, and 
entire paragraphs. Using DHTML, elements can change their font, position style or size when 
triggered. In FrontPage 2003, there are four triggers that can be used to start an effect. 

Table 1 - DHTML Effect Triggers 
Trigger Name Description 
Click Starts effect when the element is clicked. 
Double click Starts effect when the element is double clicked. 
Mouse over Starts effect when the mouse pointer is moved over the 

element. 
Page load Starts effect when the page is first loaded. 

APPLYING DHTML EFFECTS 
An element in a page can have as many effects applied to it as desired. It can have one or 
multiple effects per trigger. In addition, the Format Painter feature can be used to copy 
DHTML effects from one element to another.  

To apply a Dynamic HTML effect: 
1. Select the element to animate. 
2. Activate the DHTML Effects toolbar (see Figure 12). 
3. Click the On drop-down arrow and select the trigger that will start the dynamic effect. 
4. Click the Apply drop-down arrow and select an effect that can be applied to the selected 

element. 
5. For some effects, further customizing is available by selecting an option from the 

<Choose Settings> list. 
6. Once the desired settings are selected and the effect is applied close the DHTML Effects 

toolbar.  
7. Save the web page and preview it; the dynamic effect will only be seen in the preview tab 

or when viewed with a web browser. 

 
Figure 12 - The DHTML Effects Toolbar 

ADDITIONAL DHTML EFFECTS 
In addition to the options provided on the DHTML Effects toolbar, effects such as page 
transitions, collapsible outlines, and hyperlink rollover are also considered DHTML effects.  

Page Transition 
Page transitions are similar to the transitions in a Microsoft PowerPoint slide show. Effects 
such as “Vertical blinds” or “Checkerboard down” can be used whenever a visitor first views a 
web page or web site, or when a visitor exits a web page or web site  

To apply a page transition: 
1. Select the Format menu, ► Page Transition command.  The Page Transitions dialog 

box opens (see Figure 13).  
2. Click the Event: drop-down arrow and select when the transition effect should start.  
3. In the Duration: box, specifying the duration of the transition effect in seconds. 
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4. Select the desired transition settings from the Transition effect: list box ► OK button.  
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Figure 13 - Page Transition Dialog Box 

Collapsible Outline  
A multi-level list can be expanded or collapsed. This feature enables the visitor to hide or show 
sublevels in a list by selecting the higher level.  

!NOTE: 
Only multi-level lists can be made collapsible 

To make a multi-level list collapsible: 
1. Select the list to made collapsible 
2. Right click the list and select List Properties… from the shortcut menu. The List 

Properties dialog box opens.  Select the tab for the appropriate type of list (see Figure 
14). 

3. Check the Enable Collapsible Outlines box.  
4. If desired, check the Initially Collapsed check box ► OK button. 

 
Figure 14 - List Properties Dialog Box 

Hyperlink Rollover Effects 
Hyperlink rollover effects allow a hyperlink to change properties when the mouse pointer is 
positioned over it.  

Event starting 
the transition 
effect 

Duration of the effect 
(in seconds) 

Transition 
Effect 

Click check box to 
enable Collapsible 
Outlines 



!NOTE: 
Once a hyperlink rollover effect is applied to a web page, it will apply to all hyperlinks in that 
page. 

To apply a hyperlink effect: 
1. Right click anywhere in the page and select Page properties… from the shortcut menu. 

The Page Properties dialog box opens (see Figure 15) ► Advanced tab. 
2. Click the Enable hyperlink rollover effects box ► Rollover style… button. The Font 

dialog box opens (see Figure 16). 
3. Select desired formatting for the hyperlink ► OK button ► OK button. 

 
Figure 15 - Page Properties Dialog Box 

 
Figure 16 - Font Dialog Box 

Customizing the Page Options 

AUTO THUMBNAILS 
A thumbnail is a smaller version of a picture that contains a hyperlink to the full size picture. 
Since it is a smaller file size than the original picture, a thumbnail can be used to speed up the 
download time for a web page. (See Creating a Thumbnail Version).  Before creating a 
thumbnail, it is recommended to set the thumbnail properties. 

!NOTE: 
The properties set will only apply to thumbnails created using Auto Thumbnail after the 
property change – not existing thumbnails. 

To set the properties for a thumbnail: 
1. Select the Tools menu, ► Page Options command, The Page Options dialog box opens 

(see Figure 17). 
2. Select the Auto Thumbnail tab and do one or more of the following:  

o In the Set: list, select the option to use for size specification, and then enter a value in 
the Pixels: spin box.  
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o Click the Border thickness check box to automatically add a border to the thumbnail 
picture (specify the border width in the Pixels: spin box.  

 



o Click the Beveled edge box to make the graphic beveled ► OK button. 

 
Figure 17 - Page Options (AutoThumbnail) Dialog Box 

SETTING DEFAULT FONTS 
FrontPage can set a default display font for a language or character set. When no font is applied 
to text, FrontPage uses this default font to display the text. This setting only affects how pages 
are displayed in Microsoft FrontPage, not how the page is displayed in a Web browser.  

To set the default font: 
1. Select Tools menu ► Page Options….  The Page Options dialog box opens (see Figure 

18) ►Default Fonts tab.  
2. In the Language (character set): list box, select the set for the default display font.  
3. Click the Default proportional font: drop-down arrow and select a proportional font for 

the selected character set.  
4. Click the Default fixed-width font: drop-down arrow and select a fixed-width font for the 

selected character set (the fixed-width font is also used to display text on the HTML tab in 
Page view) ► OK button. 

!NOTE: 
Each language (character set) can have a different set of default fonts applied to it. 
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Figure 18 - Page Options (Default Fonts) Dialog Box 

 
Figure 19 - Page Options (Code Formatting) Dialog 

Box 

SETTING HTML SOURCE 
HTML stands for Hypertext Markup Language. HTML uses special markers called tags that 
indicate how Web browsers should display page elements such as text and graphics.  

There is no need to know HTML to create a web page because FrontPage is a WYSIWYG 
(What You See Is What You Get) design tool that generates the necessary HTML code whenever 
new elements are added in the Normal view. However, the way FrontPage formats HTML tags 
displayed in the HTML pane can be modified. For example, the names of HTML tags can be 
displayed in uppercase and HTML attributes can be displayed in lowercase to differentiate 
between the two. 

By default, FrontPage preserves the formatting of existing HTML, but applies new HTML 
formatting to all contents added to the existing page. HTML formatting is viewed in the HTML 
pane.  

To preserve the formatting of existing HTML and apply new settings to new content: 
1. Select the Tools menu, ► Page Options….  The Page Options dialog box opens (see 

Figure 19) ► Code Formatting tab.  
2. In the Formatting section, select the desired options for HTML formatting (e.g., to have 

all tags in uppercase instead of lowercase, deselect the Tag names are lowercase check 
box).  

3. In the Tags section, there is a list with all the tags that can be automatically generated by 
FrontPage. The property of each can be customized ► OK button. 

!NOTE: 
Each HTML tag has unique attributes. Some of the attributes apply to one tag and will be 
disabled when a different tag is selected.  

To reset HTML format settings to FrontPage defaults: 
1. Select the Tools menu ► Page Options….  The Page Options dialog box opens. ► 

Code Formatting tab (see Figure 19).  
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2. Click the Reset button to restore default settings ► OK button. 

!NOTE: 
The settings chosen will not be displayed in the Code view until the view is switched to the 
Normal view and back. 

SETTING HTML COLOR CODING 
Microsoft FrontPage uses different colors in the Code view to differentiate between text, tags, 
attribute names, attribute values, comments, and scripts. These color codes can be modified and 
will apply to all subsequent new pages that are created.  
 
To modify color coding of HTML: 

1. Select the Tools menu ► Page Options….  The Page Options dialog box opens. ► 
Color Coding tab (see Figure 20).  

2. To modify the color of any HTML element, click the appropriate drop-down arrow and 
select the new color to use. Click the More Colors… button  to select 
additional available colors from the More Colors dialog box (see Figure 21). 

 
Figure 20 - Page Options (Color Coding) Dialog Box 

 
Figure 21 - More Colors Dialog Box 

!NOTE: 
To reset color coding to the original default settings, click the Reset Colors button in the 
Page Options (Color Coding) dialog box. 

SETTING COMPATIBILITY 
Different web browsers may display web pages differently; some features might work well 
within the Microsoft FrontPage but fail to work in a non-Microsoft browser application. If web 
pages are targeted to a specific web browser, certain features might be unavailable.  Setting 
browser compatibility before creating the web disables those features that might not display 
correctly with a browser other than Internet Explorer.  Because of this, only the elements 
common to all browsers can be used in that web. 
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To design a web site for use with specific browsers: 
1. Select the Tools menu, ► Page Options….  The Page Options dialog box opens  ► 

Authoring tab (see Figure 22).  
2. From the Browsers: dropdown list, select the specific target browsers. 
3. Click the Browser versions: drop-down arrow to select the specific version(s). 
4. Click or clear the check boxes to enable or disable specific features ► OK button. 

 
Figure 22 - Page Options (Authoring) Dialog Box 
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