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Introduction 
Adobe Flash CS4 is the industry standard software for creating rich, interactive content ranging 
from simple animations to full-featured web applications. Flash includes many features that 
make it powerful but easy to use. In addition, Flash includes a scripting language that can be 
used to add interactivity and complex functionality to Flash projects. This handout covers how to 
create realistic motion in animations with the use of bones and joints, as well as how to develop 
Flash websites and add ActionScript. 

Downloading the Data Files 
This handout includes sample data files that can be used for hands-on practice. The data files are 
stored in a self-extracting archive. The archive must be downloaded and executed in order to 
extract the data files. 

 The data files used with this handout are available for download at 
http://www.calstatela.edu/its/training/datafiles/flashcs4p4.exe. 

 Instructions on how to download and extract the data files are available at 
http://www.calstatela.edu/its/docs/download.php. 

Articulated Motion 
One of the easiest ways to create animation with Flash CS4 is through the use of motion tweens.  
However, fluid movement, such as the movement of legs when walking, is difficult to achieve 
through tweening alone. The use of articulated joints and inverse kinematics in Flash CS4 allows 
for such animations to be created with ease. 

Defining Bones 
The first step in creating articulated motion is to define the bones of an object. Defining bones 
allows for the formation of moveable joints. Collectively, a set of connected bones and their 
joints is called an armature. 
 
To create a crane: 

1. Click the Start button, point to All Programs, point to Adobe Design Premium CS4, 
and select Adobe Flash CS4 Professional. The program opens and the Welcome Screen 
displays. 

2. Click the File menu and select Open. The Open dialog box opens. 
3. Navigate to the data files folder, select the SScrane.fla file, and then click the Open 

button. 
4. Select the crane_base layer in the Timeline. 
5. Drag the Main Crane movie clip symbol from the Library panel to the lower-left corner 

of the Stage. 
6. Drag the Crane Arm movie clip symbol from the Library panel to the Stage and place it 

so that the left side of the Crane Arm symbol connects to the top of the Main Crane 
symbol. 

7. Drag another instance of the Crane Arm movie clip symbol from the Library panel to 
the Stage and place it so that the left side of the second Crane Arm symbol connects to 
the right side of the first Crane Arm symbol. 

http://www.calstatela.edu/its/training/datafiles/flashcs4p4.exe�
http://www.calstatela.edu/its/docs/download.php�
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8. Drag the Winch movie clip symbol from the Library panel to the Stage and place it so 
that the top of the Winch symbol connects to the right side of the second Crane Arm 
symbol. 

9. Rearrange the symbols on the Stage so that the Winch movie clip symbol makes contact 
with the Rocket graphic symbol (see Figure 1). 

 
Figure 1 – Setting Up the Crane 

To define the bones: 
1. Select the Bone tool  in the Tools panel. 
2. Drag to draw a bone starting from the bottom base of the Main Crane symbol to where it 

makes contact with the adjacent Crane Arm symbol. The Crane Arm symbol is 
automatically selected (see Figure 2). 
NOTE: When defining bones, ensure that the mouse pointer hovers over the end of the last drawn 
bone. The pointer changes into a bone with a plus sign  when it is possible to draw a bone; the 
pointer changes into a circle with a slash next to the bone  when it is not possible to draw a 
bone. This might have to do with the symbol itself or the positioning between symbols. 

 
Figure 2 – Defining a Bone 

3. Continuing from the last bone, drag to draw another bone across the adjacent Crane Arm 
symbol. 

4. Repeat step 3 for the second Crane Arm symbol and the Winch symbol. The bones 
connect to each other and to the Rocket symbol (see Figure 3). 
NOTE: An armature layer is created when using the Bone tool, and the keyframes of the 
crane_base and rocket layers disappear. Additionally, drawing connecting bones between 
objects may slightly reposition the affected symbols in order to create a realistic looking joint 
(with minimal air space in between). 
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Figure 3 – Bones and Joints 

Positioning Bones 
Once bones and joints have been created, inverse kinematics comes into play. When one bone 
moves, the other connected bones move in relation to the bone that initiated the movement.  
Flash approximates the movement as best as it can to create fluid motion of the connected 
symbols. 
 
To reposition all the bones of an armature: 

1. In the Timeline, double-click the newly created armature layer and rename it to 
Crane_Armature. 
NOTE: Armature layer names cannot have spaces. 

2. Select the Selection tool  in the Tools panel. 
3. Select the Crane_Armature layer in the Timeline. The bones reappear over the crane 

movie clip symbols. 
4. Drag the Winch symbol to reposition it on the Stage. The entire armature repositions 

according to the movement of the Winch symbol. 
5. Press Ctrl+Z to undo the changes and revert back to the original image. 

 
To reposition individual bones: 

1. If necessary, select the Selection tool , and then select the Crane_Armature layer in 
the Timeline to display the bones. 

2. Hold down the Shift key and drag the Winch symbol to a new position on the Stage. 
Notice that only the bone over the Winch symbol moves, leaving the others intact. 

Constraining Joints and Translation 
By default, joints have no constraints, which means they can rotate 360 degrees. This may not be 
desired in all situations, so constraining the movement of joints can help with creating a realistic 
joint structure and movement. Constraining the translation of a joint involves the movement of 
the joint on the X-axis and Y-axis, thereby limiting horizontal and vertical movement. 
 
To constrain joints: 

1. If necessary, select the Selection tool , and then select the Crane_Armature layer in 
the Timeline to display the bones. 

2. Select the bone over the first Crane Arm symbol (see Figure 4). 
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Figure 4 – Selecting a Bone 

3. In the Property inspector, under Joint: Rotation, select the Constrain check box (see 
Figure 5). 

 
Figure 5 – Constraining Joint: Rotation 

4. Set the Min value to 0 and the Max value to 90. The joint is constrained to move a 
maximum of 90 degrees (see Figure 6). 

 
Figure 6 – Angle Constraints 

NOTE: When deciding the minimum and maximum joint angles, it helps to envision the joint 
angle right-side up, with negative values deviating to the left of a 90-degree angle and positive 
values deviating to the right. 

 
To constrain translations: 

1. If necessary, select the Selection tool , and then select the Crane_Armature layer in 
the Timeline to display the bones. 

2. Select the bone over the Main Crane symbol. 
3. In the Property inspector, under Joint: Rotation, deselect the Enable check box to 

disable joint rotation. 
4. Under Joint: X Translation, select the Enable check box to enable horizontal 

translation. 
5. Select the Constrain check box (see Figure 7). 

 
Figure 7 – Constraining Joint: X Translation 
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6. Set the Min value to -25 and the Max value to 25. The bone is constrained to move 25 
pixels to the left and 25 pixels to the right (see Figure 8). 

 
Figure 8 – X Translation Movement Range 

Setting Poses 
Setting poses is the equivalent of keyframes, indicating a change when working with an 
armature. Flash interpolates the movement from one armature pose to the next in a fluid motion. 
 
To set poses: 

1. In the Timeline, select frame 24 of the Crane_Armature layer, and then press the F6 
key to insert a new keyframe. 

2. Drag the Winch symbol upward, lifting up the Rocket symbol (see Figure 9). 

 
Figure 9 – Pose at Frame 24 

3. In the Timeline, select frame 48 of the Crane_Armature layer, and then press the F6 
key to insert a new keyframe. 

4. Drag the first Crane Arm symbol, constrained earlier, downward (see Figure 10). 

 
Figure 10 – Pose at Frame 48 (Downward Crane Arm) 

5. While on the same frame, drag the second Crane Arm symbol upward (see Figure 11). 
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Figure 11 – Pose at Frame 48 (Upward Crane Arm) 

6. In the Timeline, select frame 72 of the Crane_Armature layer, and then press the F6 
key to insert a new keyframe. 

7. Drag the Winch symbol towards the landing pad (see Figure 12). 

 
Figure 12 – Pose at Frame 72 

8. Press Ctrl+Enter to preview the animation in a Flash Player window. 

Creating Web Pages with Flash 
Flash CS4 can be used to create web pages. Each frame in the Timeline can be thought of as an 
entire page of a website. 

Creating New Pages 
Pages in Flash can be created by inserting frames and keyframes. The advantage of using Flash 
is that the layout and contents of the previous frame will be carried over to the next frame, 
making it easy to create consistent pages. 
 
To add a basic layout: 

1. Click the File menu and select Open. The Open dialog box opens. 
2. Locate and select the site_station.fla file, and then click the Open button. 
3. In the Timeline, hold down the Ctrl key and select frame 4 of the title, spaceship, 

banner, site, and background layers. 
4. Right-click on any of the selected frames and select Insert Frame to insert new frames. 

Or, press the F5 key. 
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To add buttons to the new page: 
1. In the Timeline, select frame 4 of the home layer. 

NOTE: To display the full layer names, drag the bar separating the layer names and the frames 
portions of the Timeline (see Figure 13). 

 
Figure 13 – Adjusting the Width of the Layer Names 

2. Hold down the Ctrl key and select frame 4 of the about, video, and explore layers. 
3. Right-click on any of the selected frames and select Insert Frame. The buttons appear in 

frame 4 of the selected layers. 

Writing ActionScript 
ActionScript is the scripting language included in Flash CS4. It lets users add complex 
interactivity, playback control, and data display to their application. For example, ActionScript 
can be used to attach behaviors to buttons or to stop an animation. Users can add ActionScript in 
the authoring environment by using the Actions panel, Script window, or an external editor. 

Linking Buttons 
To navigate to different pages of a Flash website, ActionScript can be used to control buttons. 
Clicking a button will jump to a different frame in the Timeline, with each frame representing a 
page of a website. Before adding any code, users need to give each button a unique instance 
name. The instance name enables users to target the button with ActionScript code. 
 
To link the Home button: 

1. Deselect all objects by clicking in the gray area surrounding the Stage. 
2. Select the Home button on the Stage. The home layer is automatically selected in the 

Timeline. 
3. In the Property inspector, type home in the Instance Name box to give an instance 

name to the button (see Figure 14).  

 
Figure 14 – Assigning an Instance Name in the Property Inspector 
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NOTE: An instance name cannot have spaces or special characters, but can contain underscores. 
Also, instance names are case-sensitive. 

4. Minimize the Flash CS4 application window. 
5. Locate and open the Link.txt file. 
6. In the Link.txt file, select the first four lines of the script, and then click the Edit menu 

and select Copy to copy the selection (see Figure 15). 

 
Figure 15 – Link.txt File 

7. Maximize the Flash CS4 application window. 
8. In the Timeline, select frame 1 of the home layer. 
9. Click the Window menu and select Actions (see Figure 16). Or, press the F9 key. The 

Actions panel opens. 

 
Figure 16 – Window Menu When Selecting Actions 

10. Right-click in the Script pane of the Actions panel and select Paste. Or, type the 
following code in the Script pane (see Figure 17). 

home.addEventListener(MouseEvent.CLICK, onHome) 
function onHome(event:MouseEvent){ 

gotoAndStop(1); 
} 
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11. Close the Actions panel. 

 
Figure 17 – Actions Panel (Home) 

 
To link the About button: 

1. Select the About button on the Stage. The about layer is automatically selected in the 
Timeline. 

2. In the Property inspector, type about in the Instance Name box. 
3. Switch to the Link.txt file, copy the second four lines of the script, and then switch back 

to the Flash CS4 application window. 
4. In the Timeline, select frame 1 of the about layer. 
5. Press the F9 key to open the Actions panel. 
6. Right-click in the Script pane of the Actions panel and select Paste. Or, type the 

following code in the Script pane (see Figure 18). 

about.addEventListener(MouseEvent.CLICK, onAbout) 
function onAbout(event:MouseEvent){ 

gotoAndStop(2); 
} 

7. Close the Actions panel. 
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Figure 18 – Actions Panel (About) 

To link the Video button: 
1. Select the Video button on the Stage. The video layer is automatically selected in the 

Timeline. 
2. In the Property inspector, type video in the Instance Name box. 
3. Switch to the Link.txt file, copy the third four lines of the script, and then switch back to 

the Flash CS4 application window. 
4. In the Timeline, select frame 1 of the video layer. 
5. Press the F9 key to open the Actions panel. 
6. Right-click in the Script pane of the Actions panel and select Paste. Or, type the 

following code in the Script pane (see Figure 19). 
video.addEventListener(MouseEvent.CLICK, onVideo) 
function onVideo(event:MouseEvent){ 

gotoAndStop(3); 
} 

7. Close the Actions panel. 
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Figure 19 – Actions Panel (Video) 

To link the Explore button: 
1. Select the Explore button on the Stage. The explore layer is automatically selected in the 

Timeline. 
2. In the Property inspector, type explore in the Instance Name box. 
3. Switch to the Link.txt file, copy the last four lines of the script, and then switch back to 

the Flash CS4 application window. 
4. In the Timeline, select frame 1 of the explore layer. 
5. Press the F9 key to open the Actions panel. 
6. Right-click in the Script pane of the Actions panel and select Paste. Or, type the 

following code in the Script pane (see Figure 20). 
explore.addEventListener(MouseEvent.CLICK, onExplore) 
function onExplore(event:MouseEvent){ 
  gotoAndStop(4); 
} 

7. Close the Actions panel. 
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Figure 20 – Actions Panel (Explore) 

To preview the animation: 
1. Press Ctrl+Enter. The SWF file displays in a Flash Player window. 
2. Click the buttons to see how they work. 

Creating a Flash-based Pannable Window 
With ActionScript, Flash has the ability to pan an image based on mouse movements. As the 
mouse pointer is moved around the screen, the image scrolls based on the direction of the mouse 
movement. The scrolling stops once the image's boundary is reached. 
 
To create a customizable pan window: 

1. Click the File menu and select Open. The Open dialog box opens. 
2. Locate and select the site_station_imagepanning.fla file, and then click the Open 

button. 
3. In the Timeline, select frame 4 of the universe layer located within the Explore folder. 
4. On the Edit bar, click the Zoom control arrow and select 50% to adjust the 

magnification of the Stage (see Figure 21). 

 
Figure 21 – Zoom Control on the Edit Bar 

5. Drag the universe.jpg image from the Library panel to the Stage and position it below 
the title (see Figure 22). 
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Figure 22 – Placing the Universe Image on the Stage 

6. Right-click the universe image on the Stage and select Convert to Symbol. The Convert 
to Symbol dialog box opens. 

7. Type bigPic in the Name box. 
8. Click the Type arrow and select Movie Clip from the list. 
9. Click the OK button. 
10. In the Property inspector, type bigPic in the Instance Name box (see Figure 23). 

NOTE: Instance names are case-sensitive. 

 
Figure 23 – Assigning Instance Name of bigPic 

11. Right-click the image again and select Convert to Symbol. The Convert to Symbol 
dialog box opens. 

12. Type wholeMagicWindow in the Name box. 
13. Click the Type arrow and select Movie Clip from the list. 
14. Click the OK button. 
15. In the Property inspector, type wholeMagicWindow in the Instance Name box (see 

Figure 24). 
NOTE: Instance names are case-sensitive. 

 
Figure 24 – Assigning Instance Name of wholeMagicWindow 
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To create an activator for the image pan window: 
1. Double-click the universe image on the Stage to edit the wholeMagicWindow movie 

clip symbol. 

NOTE: You can also enter edit mode by clicking the Edit Symbols button  on the Edit bar 
and selecting the symbol that needs to be edited.  

2. In the wholeMagicWindow movie clip’s Timeline, create a new layer and rename it to 
activator. 

3. Select frame 1 of the activator layer. 
4. Select the Rectangle Primitive tool  in the Tools panel. 

NOTE: If the Rectangle Primitive tool is not displayed, click and hold the mouse button on the 
Rectangle tool , and then select the Rectangle Primitive tool from the pop-up menu (see 
Figure 25). 

 
Figure 25 – Selecting the Rectangle Primitive Tool 

5. On the Stage, drag the mouse pointer to draw a rectangle. 
6. In the Property inspector, under Fill and Stroke, click the Fill Color control and set the 

Alpha value to 30%. This makes the rectangle almost transparent. 
7. Under Position and Size, change the W (width) value to 550 and the H (height) value to 

375 (see Figure 26). 

 
Figure 26 – Property Inspector (Rectangle Primitive Tool) 

8. Select the Selection tool  in the Tools panel. 
9. Right-click the rectangle on the Stage and select Convert to Symbol. The Convert to 

Symbol dialog box opens. 
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10. Type activator in the Name box. 
11. Click the Type arrow and select Movie Clip from the list. 
12. Click the OK button. 
13. In the Property inspector, type activator in the Instance Name box (see Figure 27). 

NOTE: Instance names are case-sensitive. 

 
Figure 27 – Assigning Instance Name of activator 

 
To insert a script into the activator layer of the customizable pan window: 

1. In the Timeline, create a new layer and rename it to actions. 
2. Minimize the Flash CS4 application window. 
3. Locate and open the Image_Panning.txt file. 
4. In the Image_Panning.txt file, select all the content, and then click the Edit menu and 

select Copy (see Figure 28). 

 
Figure 28 – Image_Panning.txt File 

5. Maximize the Flash CS4 application window. 
6. In the Timeline, select frame 1 of the actions layer. 
7. Press the F9 key to open the Actions panel. 
8. Right-click in the Script pane of the Actions panel and select Paste. 
9. Close the Actions panel. 
10. Press Ctrl+Enter to preview the animation in a Flash Player window. 
11. Click the Explore button and move the mouse pointer over the universe image to see 

how the activator works. 
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To mask the image: 
1. Select the activator layer in the Timeline, copy the rectangle, and then lock the 

activator layer. 
2. Click Scene 1 on the Edit bar to return to the main scene. 
3. In the Timeline, create a new layer above the universe layer and rename it to mask (see 

Figure 29). 

 
Figure 29 – Renaming a Mask Layer 

4. Right-click frame 4 of the mask layer and select Insert Keyframe. 
5. Paste the rectangle, and then adjust its position so that it overlaps the half-transparent 

rectangle on the Stage. 
6. Right-click the mask layer and select Mask. The universe image is masked. 

 
To make the activator transparent: 

1. Unlock the mask layer. 
2. Double-click the rectangle on the mask layer to edit the activator movie clip symbol. 
3. In the Color panel, set the Alpha value to 0%. 
4. Click Scene 1 on the Edit bar to return to the main scene. 
5. Lock the mask layer. The activator becomes transparent and the universe image is clearly 

visible (see Figure 30). 

 
Figure 30 – Explore Page 
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6. Press Ctrl+Enter to preview the animation in a Flash Player window. 
7. Click the Explore button and move the mouse pointer over the universe image to view 

the image panning. 

Creating a Preloader 
Preloaders indicate that Flash content is being loaded and show the progress of the download. 
 
To create a simple preloader scene: 

1. Click the File menu and select Open. The Open dialog box opens. 
2. Locate and select the site_station_preloader.fla file, and then click the Open button. 
3. Click the Window menu, point to Other Panels, and select Scene (see Figure 30). Or, 

press Shift+F2. The Scene panel opens. 

 
Figure 31 – Window Menu When Selecting Scene 

4. In the Scene panel, double-click Scene 1 and type Main to rename the scene. 
5. Click the Add Scene button  to create a new scene. 
6. Double-click the new scene name and type Preloader. 
7. Drag the Preloader scene and place it above the Main scene (see Figure 32). 

 
Figure 32 – Scene Panel 
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To create a preloader: 
1. In the Preloader scene, rename Layer 1 to Spirals. 
2. Drag the Spirals movie clip symbol from the Library panel to the center of the Stage. 
3. Select the Free Transform tool  in the Tools panel and resize the shape as desired. 
4. In the Timeline, create a new layer and rename it to Dynamic Text. 
5. Select the Text tool  in the Tools panel. 
6. In the Property inspector, click the Text type arrow and select Dynamic Text from the 

list (see Figure 33). 
7. Under Character, select the desired Color, Size, and Type, and change the Alpha value 

to 100%. 
8. Click on the Stage and type the text Loading. 
9. In the Property inspector, type loadingPercent in the Instance Name box (see Figure 

33). 
NOTE: Instance names are case-sensitive. 

 
Figure 33 – Assigning Instance Name of loadingPercent 

To insert a script into the Preloader scene: 
1. In the Timeline, create a new layer and rename it to actions. 
2. Minimize the Flash CS4 application window. 
3. Locate and open the Preloader.txt file. 
4. In the Preloader.txt file, select the first two lines of the script (see Figure 34). 

 
Figure 34 – Preloader.txt File 

5. Click the Edit menu and select Copy to copy the first part of the script. 
6. Maximize the Flash CS4 application window. 
7. In the Timeline, select frame 1 of the actions layer. 
8. Press the F9 key to open the Actions panel. 
9. Right-click in the Script pane of the Actions panel and select Paste (see Figure 35). 
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Figure 35 – Pasting Script into the Actions Panel (Frame 1) 

10. Close the Actions panel. 
11. In the Timeline, right-click frame 2 of the actions layer and select Insert Blank 

Keyframe. 
12. Switch to the Preloader.txt file, copy the last five lines of the script, and then switch 

back to the Flash CS4 application window. 
13. In the Timeline, select frame 2 of the actions layer. 
14. Press the F9 key to open the Actions panel. 
15. Right-click in the Script pane of the Actions panel and select Paste (see Figure 36). 

 
Figure 36 – Pasting Script into the Actions Panel (Frame 2) 
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16. Close the Actions panel. 
17. In the Timeline, select frame 2 of the Spirals layer, hold down the Ctrl key, and select 

frame 2 of the Dynamic Text layer. 
18. Right-click on any of the selected frames and select Insert Frame to insert new frames 

into the Spirals and Dynamic Text layers. 
 
To preview the preloader: 

1. In the Scene panel, click Main to go back to the Main scene. 

NOTE: You can also click the Edit Scene button  on the Edit bar and select Main to go back 
to the Main scene. 

2. Press Ctrl+Enter to preview the animation in a Flash Player window. 
3. Press Ctrl+Enter again to view the preloader (see Figure 37). 

 
Figure 37 – Preloader 

NOTE: To preview the animation at different download speeds, click the View menu, point to 
Download Settings, and select the desired speed (see Figure 38). 

 
Figure 38 – View Menu When Adjusting the Download Speed 
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Publishing a Flash Website 
When publishing a website in Flash, an HTML file will be generated referencing the SWF file 
that is outputted by Flash. The HTML and SWF files are the two files needed to display the 
Flash website in a web browser. To view the website, visitors must have the latest version of 
Adobe Flash Player installed on their computer. It is recommended to provide a link on the 
website so users can download the plug-in. 
 
To publish the FLA file in HTML format: 

1. Click the File menu and select Publish Settings. The Publish Settings dialog box opens 
(see Figure 39). 

 
Figure 39 – Publish Settings Dialog Box 

2. On the Formats tab, under Type, click the folder icon  to the right of HTML (.html). 
The Select Publish Destination dialog box opens. 

3. Select the Desktop as the location to save the published file, and then click the Save 
button. 

4. Click the Publish button. 
5. Click the OK button. 

 
To preview the Flash website in a web browser: 

1. Minimize all windows. 
2. Locate the site_station_preloader.html file on the Desktop. 
3. Right-click the file, point to Open With, and select Internet Explorer. Internet 

Explorer opens, displaying the Flash site (see Figure 40). 
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Figure 40 – Flash Website in a Web Browser 
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