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Introduction 
Adobe Flash 8 is the industry's most advanced authoring environment for creating interactive 
and animated Web sites. It gives Web designers an efficient way to send artwork and animation 
over the internet. Flash uses vector graphics, which can be scaled to any size without losing 
clarity/quality. Flash also uses easy scripting for adding interactivity and animation. 
 
One of the most compelling parts of Adobe Flash is the ability to add interaction. By adding 
interacting elements, users are engaged to take control of the animation. The most common and 
basic interactive tools are buttons. In Flash, it is easy to implement buttons with any color or 
shape. In addition, sounds and animations can be added as elements of the button. Buttons can 
also be used as menus by linking them up with certain frames. 

Using Buttons 
Buttons are one of the most powerful ways of adding interaction. When working with buttons it’s 
important to understand the different states of a button. For example most dialog boxes contain 
an OK button. When the OK button is clicked it will look slightly different than when it’s not 
clicked. In Flash, this is called the Up and Down state. Up when the button is not being clicked, 
and Down when it is being clicked. These are two of the four states that is available for buttons 
and they will all be covered in one of the following sections. 

CREATING A BUTTON 
In this section a new kind of symbol will be introduced, the button symbol. Creating a button is 
done by inserting a button symbol into the library. 

To create a button symbol: 
1. Select the File menu ►New…. 
2. Click on the OK button. This will create a new flash file. 
3. Go to Insert ► New Symbol… in the menu. The Create New Symbol dialog box appears 

(see Figure 1). 

 
Figure 1 - Creating a Button Symbol 

4. Type desired name of the new button in the Name: text box. For example [Button 1]. 
5. Select the Button option. 
6. Click OK button. The symbol master will appear. 

 
NOTE: Notice how the Timeline panel will look different from Graphic and Movie Clip 
symbols (see Figure 2). This is because instead of defining frames for the buttons, we must define 
states. Each button has four states: Up, Over, Down, and Hit (see Table 1). 
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Figure 2 - The Button Symbol Timeline 

Table 1 - The four button states 
State Description 
Up Default state. 
Over State when mouse is hovered over button. 
Down State when left mouse button is clicked on button. 
Hit Special state defining what area of the button that is intended 

to be clickable. The hit state doesn’t need to be defined unless 
a hit-area outside the shape is desired. 

 
To define the up state: 

1. From the Tools panel, select the Rectangle Tool . 
2. Draw a rectangle somewhere in the Up frame (see Figure 3). 

 
Figure 3 - The Up State of the Button 

To define the over state: 
1. Right-click on the Over frame in the Timeline panel. Select Insert Keyframe. The 

rectangle will be highlighted (see Figure 4). 

 
Figure 4 - Highlighted Button 

2. From the Tools panel, select the Paint Bucket Tool .  
3. In the Properties panel, change the color of the Paint Bucket Tool to a light green color 

(see Figure 5). This will change the color of the rectangle (see Figure 6).  
 

 
Figure 5 - Changing the color of the rectangle 

 
Figure 6 - Light Green Rectangle 

To define the down state: 
1. Insert a new Keyframe in the Down frame of the Timeline. 
2. From the Tools panel, select the Paint Bucket Tool .  
3. In the Properties panel, change the color of the Paint Bucket Tool to red. This will 

change the color of the rectangle to red. 
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To add the button to the scene: 
1. Click on Scene 1 on the Timeline. This will bring Flash back to Scene 1. 
2. From the Library panel, left-click and drag the Button 1 symbol over to the middle of 

the first frame. 
3. Animation is done. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard. The result should be in accordance with Table 2. 

Table 2 – A simple button 
State Button Description

Up 
 

The button will be blue as long as the mouse cursor is 
not hovering over the button, or clicking on it. 

Over 
 

When hovering over the button the button will change to a 
green color. 

Down 
 

When left-clicking on the button the color will change to 
red.  

 

USING TEXT AS A BUTTON 
In the first example the button was a simple rectangle shape. This section takes it one step further 
showing how to make buttons based on text. The approach is much the same; the only difference 
is to use text instead of rectangle in the button symbol master. In addition to changing the color 
of the text, the size will be changed as well. 

To create a button symbol: 
1. Select the File menu ►New…. 
2. Click on the OK button. This will create a new flash file. 
3. Go to Insert ► New Symbol… in the menu. The Create New Symbol dialog box 

appears. 
4. Type desired name of the new button in the Name: text box. For example [Text button]. 
5. Select the Button option. 
6. Click OK button. The symbol master will appear. 

To define the up state: 
1. In the Text button master, select the Text Tool  from the Tools panel. 
2. Set the font to Verdana and size to 22. Set the color to green (see Figure 7). 

 

 

Figure 7 - Text Properties 

3. Using the left mouse button create a text region in the Up frame. 
4. Type [My button] into the text region (see Figure 8). 

Figure 8 – Inserting the Text 

To define the over state: 
1. Insert a new keyframe in the Over state. 
2. If not selected, select the Text Tool  from the Tools panel. 
3. Highlight the text (see Figure 9). 
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Figure 9 - Highlighted Text 

4. In the Properties panel change the color to a darker green color. This time, also increase 
the size to 30 (see Figure 10). 

 
Figure 10 – Text Properties for Over State 

To define the down state: 
1. Insert a new keyframe on the Down state. 
2. If not selected, select the Text Tool  from the Tools panel. 
3. Highlight the text. 
4. In the Properties panel change the color to a blue color (see Figure 11). 

 
Figure 11 - Text Properties for Down State 

To add the button to the scene: 
1. Click on Scene 1 on the Timeline. This will bring Flash back to Scene 1. 
2. From the Library panel, left-click and drag the Text button symbol over to the middle 

of the first frame. 
3. Animation is done. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard. The result should be in accordance with Table 3. 

Table 3 - Using text as a button 
State Button Description

Up 
 

The text will be light green as long as the mouse 
cursor is not hovering over the text, or clicking on 
it. 

Over 
 

When hovering over the text the, text will change to a 
darker green color, also the size will increase. 

Down 
 

When left-clicking on the text, the color will change 
to blue.  

USING IMAGES IN BUTTONS 
Buttons are not limited to shapes, colors and text. Adding images to the different states of the 
button will give a more realistic look as well as a richer user experience. However, there are 
more implications when using images. To make sure the images in the different states are 
correctly aligned with each other, rulers, grids and grid snapping will be used. 

Example:  
In the following example a button will be created using images of a butterfly. Different images 
of the butterfly will be used for the Up, Over, and Down state. 

To create the button symbol: 
1. Select the File menu ►New…. 
2. Click on the OK button. This will create a new flash file. 
3. Go to Insert menu ► New Symbol…. The Create New Symbol dialog box appears. 
4. Type [butterfly button] into the Name: text box. 

    Adobe Flash 8, Part 4 - 5 



5. Select the Button option. 
6. Click OK button. The symbol definition scene opens. 

 
To import the images: 

1. From the File menu, select Import… ► Import to Library…. The Import to Library 
dialog box opens. 

2. Select “butterfly1.jpg” and click on Open button. This will add the image to the library. 
3. Repeat steps 1 – 2 for “butterfly2.jpg” and “butterfly3.jpg”. 

 
To activate rulers, grid and grid-snapping: 

1. From the View menu, select Rulers. Rulers get activated. 
2. From the View menu, select Grid ► Show Grid. The grid gets activated. 
3. From the View menu, select Snapping ►Snap to Grid. Grid-snapping gets activated. 

 
To define the up state of the button: 

1. Double click on the butterfly button symbol in the Library panel. The definition scene 
for the butterfly button symbol gets activated. 

2. From the Library panel, drag butterfly1.jpg over to the stage. 
3. From the Tools panel, select the Selection Tool . 
4. Left-click and drag the upper-left corner of the image to snap the image to the grid. 

Notice how the corner of the image gets changes, indicating snapping (see Figure 12). 

 

 

Figure 12 - Snapping Image to Grid 

To define the over state of the button: 
1. On the timeline, insert a new keyframe in the Over frame. 
2. Press [Delete] key on the keyboard to delete the existing image. 
3. From the Tools panel, select the Selection Tool . 
4. From the Library panel, drag butterfly2.jpg over to the stage. 
5. Left-click and drag the upper-left corner of the image to snap the image to the grid (see 

Figure 13). 

Figure 13 - Defining the Over State 
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To define the down state of the button: 
1. On the timeline, insert a new keyframe in the Down frame. 
2. Press [Delete] key on the keyboard to delete the existing image. 
3. From the Tools panel, select the Selection Tool . 
4. From the Library panel, drag butterfly3.jpg over to the stage. 
5. Left-click and drag the upper-left corner of the image to snap the image to the grid (see 

Figure 14). 

 
Figure 14 - Defining the Down State 

To add the button to the scene: 
1. Click on Scene 1 on the Timeline. This will bring Flash back to Scene 1. 
2. From the Library panel, left-click and drag the butterfly button symbol over to the 

middle of the first frame. 
3. The animation is done. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard. The result should be in accordance with Table 4. 

Table 4 - Using images as buttons 
State Button Description

Up 
First image is shown as long as the mouse 
cursor is not hovering over the text, or 
clicking on it. 

Over When hovering over the image, the second 
image will be shown. 

Down When left-clicking on the image, the third 
image will be shown. 
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DEFINING A CUSTOM HIT STATE 
Sometimes the hit-area that is automatically defined by Flash is not the way that is desired. For 
example in the case where only part of the shape is supposed to be clickable. In other cases the 
hit area is too small and a larger customized hit state is needed. One particularly useful situation 
is when creating shapes that only have border and no fill, thus being transparent (see Figure 15). 
In these cases only the border would be clickable. However, by defining a hit state we can set a 
custom hit area that also lets the circle be clickable in the transparent areas. 

 
Figure 15 - A Bordered Circle with no Fill 

To define a custom hit state: 
1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “transparent circle.fla” file from the data files folder. 
3. Test the animation. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard. Notice how the circle is not clickable in the middle but only 
the border. 

4. Double-click on the “Transparent circle” symbol in the Library panel. This will bring 
up the symbol master. Notice how there is no hit state defined yet (see Figure 16). 

 
Figure 16 – No Defined Hit State 

5. Insert a new keyframe in the Hit state. The circle will be selected automatically. 
6. From the Tools panel, select the Paint Bucket Tool . 
7. In the Colors panel change the fill color from none to red (see Figure 17). 

 
Figure 17 - Changing the Fill Color 

8. Change the fill-color of the circle by clicking somewhere in the middle of the circle with 
the Paint Bucket Tool  (see Figure 18). 

 
Figure 18 - Using the Paint Bucket Tool 

Adding Behavior 
The buttons created so far have no purpose beyond changing color or shape. Usually interacting 
with a button leads to an action. For example clicking on the button may open a Web page or 
start an animation. To add this kind of functionality a little knowledge of behaviors is required. 
Behaviors can also be added to frames themselves and will be triggered whenever that frame is 
observed. 
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LINKING TO A WEB SITE 
Buttons are often used in menus. Each button in the menu can be a link to a Web page. In order 
to apply this kind of behavior to a button, the first thing that needs to be done is adding an 
instance of the button the stage. Once this instance is added, it must be given a unique name. 
This is so that Flash can identify which behavior belongs to which objects. 
 
To name an instance: 

1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “creating hyperlink.fla” file from the data files folder. 
3. Using the Selection Tool , select the Training Program button on the stage. 
4. Enter [Training Program] in the <instance name> textbox in the Properties panel (see 

Figure 19).  

 
Figure 19 - Naming the Instance 

5. Click [Enter] on the keyboard. 

To add hyperlink behavior: 
1. Click on the Training Program button instance to select it. 
2. Hold down [Shift] key while pressing [F3] key. This brings up the behaviors window 

(see Figure 20). 

 
Figure 20 - Behaviors Window 

3. Click the Add Behavior button . This will bring up a sub menu. Select Web ► Go 
to Web Page (see Figure 21). The Go to URL dialog box opens. 

 
Figure 21 - Adding a Behavior 

 

 

4. In the Go to URL dialog box, type [http://www.calstatela.edu/training] into the URL: 
textbox (see Figure 22). 

 
Figure 22 - The Go to URL Dialog Box 
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5. Click OK button. The behavior is now added to the Training Program button instance. 
6. Test the flash file by holding down the [Ctrl] key while pressing the [Enter] key on the 

keyboard. When clicking on the Training Program button the Training Program Web 
site should open. 

STOPPING AT FRAME 
So far in the Flash workshops each frame on the timeline has been running continuously in a 
consecutive order. At the end of the animation the animation will simply start over again. 
However, when dealing with an interactive animation, it’s important to stop at each frame and 
wait for input.  

To stop at frame: 
1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “bouncing ball.fla” file from the data files folder. 
3. Test the animation. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard.  Notice how the animation just keeps on repeating. 
4. Click on frame 24 in the Timeline panel. 
5. Click on the Actions button  below the stage to active the Actions panel. 
6. Click the Add new item to the script button . A sub menu appears. This will bring up 

a sub menu. Select Global Functions ► Timeline Control ►stop (see Figure 23).  

 
Figure 23 - Adding Action to Frame 

7. The animation is done. To test the animation hold down the [Ctrl] key while pressing the 
[Enter] key on the keyboard. Notice how the animation now stops at the end. 

GOING TO A FRAME THEN STOPPING 
This next technique is useful especially with buttons. For example all the buttons are added to 
frame 1. When one of the buttons is clicked Flash should go to frame 2. 

To go to a frame then stopping: 
1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “click me.fla” file from the data files folder. This is a file that has two frames. 

The first frame has a button Click me. There is no behavior added to this button yet. 
Frame 1 has the stop Actionscript command attached to it and will stop the animation. 
Observe frame 2. Frame 2 has some extra information added to it. 

3. Test the animation. To test the animation hold down the [Ctrl] key while pressing the 
[Enter] key on the keyboard. Notice how nothing happens when the button is clicked. 

4. Left-click on frame 1 on the Timeline panel. This will take the stage to frame 1. 
5. Left-click on the Click me button instance. This will select the Click me button. 
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6. Activate the behavior window ([Shift+F3]). 
7. Click the Add Behavior button . This will bring up a sub menu. Select Movieclip ► 

Goto and Stop at frame or label (see Figure 24). The Goto and Stop at frame or label 
dialog box opens. 

 
Figure 24 - Goto and Stop at frame or label 

 

 

8. In the Goto and Stop at frame or label dialog box type [2] into the textbox as shown in 
Figure 25. 

 
Figure 25 - The Goto and Stop at frame or label Dialog Box 

9. Click on OK button. 
10. The animation is done. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard. When clicking on the Click me button the animation 
should jump to frame two. 

Using Button Behaviors in a Web Page 
Using the techniques gone through so far in this workshop, it’s possible to build a Web page. 
This section will explain how to implement button behaviors in a Web page. Most of the content 
of the Web page is already in the “webpage.fla” file, but feel free to change or modify it. 

BUILDING THE MENU 
This section goes through the steps of building a menu using instances of button symbols with 
the Goto and Stop at frame or label behavior. 
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To build the menu: 

1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “webpage.fla” file from the data files folder. This is a file that has 3 different 

frames. The three different frames each represent the home, my interests, and the my 
links buttons (see Figure 26). Click on frame 1, 2, and 3 to see the difference between the 
frames. Test the Web page in its current state ([Ctrl+Enter]) to see that there is no 
behaviors added yet. Notice how there is no behavior added to frame yet to tell the 
animation to stop at the first frame. 

 

 

 

Figure 26 – The Menu 

3. Add stop behavior to frame 1 as described in Stopping at Frame section. Test the Web 
page again ([Ctrl+Enter]). Notice how the animation stops at the first frame. 

4. In the menu layer, left-click on frame 1. This will select all the different buttons in the 
menu. 

5. Click somewhere outside the stage to deselect the selection. 
6. Using the Selection Tool , select the Home button. 

 
Figure 27 - Selecting the Home Button 

7. Activate the behavior window ([Shift+F3]). 
8. Click the Add Behavior button . This will bring up a sub menu. Select Movieclip ► 

Goto and Stop at frame or label (see Figure 24). The Goto and Stop at frame or label 
dialog box opens. 

9. In the Goto and Stop at frame or label dialog box type [1] into the textbox. 
10. Click on OK button. 
11. Repeat steps 6 to 10 for the buttons my interests, and my links. Link my interests 

button with frame 2 and my links button with frame 3. 
 
The approach is a little bit different with the email me button. This button will not be linked to 
any frame but to an email address.  
 
To link to an email address: 

1. Using the Selection Tool , select the Email me button. 
2. Activate the behavior window ([Shift+F3]). 
3. Click the Add Behavior button . This will bring up a sub menu. Select Web ► Go to 

Web Page (see Figure 21). The Go to URL dialog box opens. 
4. In the Go to URL dialog box, type [mailto:youremail@calstatela.edu] into the URL: 

textbox (see Figure 28). Replace youremail@calstatela.edu with your actual email 
address. 
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5. Click on OK button. 
6. When done, insert keyframes in frame 2 and 3 of the menu layer. 
7. The menu is done. To test the animation hold down the [Ctrl] key while pressing the 

[Enter] key on the keyboard. 
 
Practice the concept: In the content layer in frame 3 (see Figure 29), add links to the respective 
Web sites (see Table 5) such as described in the Linking to a website section. 

Figure 29 - Content Layer Frame 3 

Table 5 - Button and URL 
Button URL 
Myspace http://www.myspace.com/ 
Training Program http://www.calstatela.edu/training 
Dodgers http://www.dodgers.com/ 

EXPORTING INTO .HTML FILE 
After the Web page flash file has been created we can export it into a html file. 
 
To export into .html file: 

1. From the menu, select File ► Publish settings…. This will bring up the Publish settings 
dialog box. 

2. In the Publish settings dialog box, click on the folder icon  next to the webpage.swf 
textbox. This will open the Select Publish Destination dialog box. 

Figure 30 - Publish Settings 
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3. In the Select Publish Destination dialog box, select the desktop. 

 

 

 

Figure 31 - The Select Publish Destination Dialog Box 

4. Click the Save button. The “webpage.swf” file will be saved to the desktop. 
5. Repeat steps 2 to 4 for the folder icon  next to the webpage.html textbox. The 

“webpage.html” file will be saved to the desktop. 

NOTE: It’s important to set the settings for both the .swf and .html file. Since both of these files 
are required when saving into html format. 

6. From the menu, select File ► Publish, optionally [Shift+F12]. This will publish the 
Web page with the settings that were just set. 
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