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Introduction 
Adobe Flash 8 is the industry's most advanced authoring environment for creating interactive 
and animated Web sites. It gives Web designers an efficient way to send artwork and animation 
over the internet. Flash uses vector graphics, which can be scaled to any size without losing 
clarity/quality. Flash also uses easy scripting for adding interactivity and animation. 

This workshop will cover more advanced animation techniques in Flash from adding sounds and 
movie clips to combining animation techniques. Setting acceleration and deceleration, which can 
be controlled by setting the ease of the tween, will also be covered.   

Advanced Techniques 
In addition to having a straightforward animation, adding sound can make a big difference. 
Whether it is background music or sound events like a car engine, it will definitely make an 
impact on the viewer. Another technique that will be covered is movie clip. Movie clips are 
special types of symbols that have their own timelines separate from the original scene. 

IMPORTING SOUNDS 
Adding sounds to the animation will make it more alive. On the other hand it is important to be 
careful when adding sounds, since sounds will increase the file size of the exported Flash files. 
Since Flash is primarily not an audio program, sound files will have to be imported. 

To import a sound file: 
1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “moving car.fla” file from the data files folder. 
3. From File menu, select Import… ► Import to Library…. 
4. Select “carhonk.wav” and click on Open button. This will insert a carhonk.wav symbol 

into the library. 
5. In the sound layer insert a new keyframe in frame 40. 
6. Left-click and drag carhonk.wav into the newly inserted frame (see Figure 1). 

 
Figure 1 - Adding Sound From Library to Scene 

7. The animation is now complete. Hold down the [Ctrl + Enter] keys on the keyboard to 
see the result. 
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NOTE: Flash can import digital audio of different formats, such as mp3, wav, aif, and au. 
However, there are certain exceptions. In Windows, Flash can only import aif, and au when 
Apple Quicktime is installed. On a Macintosh wav can not be imported. 

IMPORTING IMAGES 
The drawing tools are the basis of all development in Flash. However, sometimes real-life 
images can add to the quality of the animation. For example, with sound files, images must be 
imported in order to be used. 
 
To import an image: 

1. Select the File menu ►New…. 
2. Click OK button. This will create a new flash file. 
3. Under the Insert menu, select New Symbol…. The Create New Symbol dialog box 

opens. 
4. Type [car] and select the Graphic option button. 
5. From File menu, select Import… ► Import to Stage…. The Import to Stage dialog box 

opens. 
6. Select “red car.gif” and click the Open button. This will add the image to the stage. 

(Notice how the red car.gif symbol has also been added to the library automatically.) 
7. Click on the Scene 1 button on the Timeline to go back to Scene 1. 
8. From the Library panel, left-click on the car symbol and drag it over to the middle of the 

stage. 
9. Hold down the [Ctrl + Enter] keys on the keyboard to test. The result should look 

similar to Figure 2. 

 
Figure 2 - An Image of a Red Car 

MOVIE CLIPS AND GRAPHIC SYMBOLS 
Movie clips let the user create symbols with their own timeline. This is particularly useful when 
dealing with objects that have a repeatable motion pattern. For example; windshield wipers 
moving back and forth, rotating wheels, and eyelids opening and closing. Instead of having to 
define this pattern over and over again, this is automatically done by Flash. Inserting a movie 
clip is done like any other symbol; by just dragging it over to the desired frame. 

To create a wheel graphic symbol: 
1. Under Insert menu, select New Symbol…. The Create New Symbol dialog-box appears. 
2. Type [wheel] and select the Graphic option button. 
3. Click OK button. The definition scene for wheel symbol opens. 
4. From the Tools panel, select the Oval Tool .  
5. In the Properties panel, set the stroke color to black, and the fill color to grey. Also 

increase the line thickness to 10 or more. 
6. While holding down the [Shift] key, draw a circle in the middle of the stage. 
7. From the Tools panel, select the Line Tool . 
8. Draw a vertical and a horizontal spoke on the wheel (see Figure 3). 
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Figure 3 – A Wheel 

 
NOTE: Before creating the movie clip symbol, Flash needs the necessary graphic symbols to apply to 
the movie clip symbols. 

To apply rotation to wheel by using movie clip symbol: 
1. Under Insert menu, select New Symbol…. The Create New Symbol dialog box appears. 
2. Type [rotating wheel] and select the Movie clip option button 
3. Click OK button. The definition scene for the rotating wheel symbol opens. 
4. From the Library panel, left-click on the wheel symbol and drag it over to the middle of 

the frame (see Figure 4). 

 
Figure 4 - Inserting the Wheel Graphic Symbol 

5. Insert a new keyframe in frame 6. 
6. From the Tools panel, select Free Transform Tool . 
7. Apply a 90 degree clockwise rotation on symbol by selecting the symbol and rotating one 

of the corners (see Figure 5). 

 
Figure 5 - Applying Rotation Transformation 

8. Repeat steps 5 - 7 for frames 12, 18, and 24. This will create a complete 360 rotation on 
the wheel. 

To apply motion tween to the wheel: 
1. Left-click in frame 1 of the rotating wheel symbol.  
2. Hold down the [shift] key on the keyboard while left-clicking on frame 24. This will 

select frames 1 through 24. 
3. In the Properties panel, select Motion from the Tween: drop-down list. 
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To add wheels to the car symbol: 

1. Double click on the car symbol in the Library panel. The definition scene for the car 
symbol becomes activated. 

2. From the Library panel, left-click on the rotating wheel symbol and drag it over to the 
back of the car. 

3. Use the Free Transform Tool  to resize the wheel as needed to fit the car. 
4. Repeat steps 2 and 3 for the front part of the car. The result should be a car with wheels 

(see Figure 6). 

 
Figure 6 - Car with Wheels 

To view the car movie clip: 
1. Click on the Scene 1 button on the Timeline to go back to Scene 1. 
2. From the Library panel, left-click on the rotating wheel symbol and drag it over to the 

middle of the stage. 
3. Animation is done. Hold down [Ctrl] while pressing [Enter] key on keyboard to test. 

The result should be a rotating wheel. 
 
To create a windshield wiper graphic symbol: 

1. Select the File menu ►New…. 
2. Click OK button. This will create a new flash file. 
3. Under Insert menu, select New Symbol…. The Create New Symbol dialog box appears. 
4. Type [wiper] and select the Graphic option button. 
5. Click OK button. The definition scene for wiper symbol opens. 
6. From the Tools panel, select the Line Tool . 
7. Draw a vertical line in the middle of the stage (see Figure 7). 

 
Figure 7 - A Windshield Wiper 

 

To create a windshield wiper movie clip: 
1. Under Insert menu, select New Symbol…. The Create New Symbol dialog box appears. 
2. Type [swinging wiper] and select the Movie clip option button. 
3. Click OK button. The definition scene for the swinging wiper symbol opens. 
4. From the Library panel, left-click on the wiper symbol and drag it over to the middle of 

the frame. 
5. From the Tools panel, select Free Transform Tool . 
6. Left-click and drag pivot-point to the bottom of the wiper so that when the wiper rotates 

it will rotate around this point (see Figure 8). 
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Figure 8 - Moving the Pivot Point of the Rotating Windshield 

 

 

 

7. Insert a new keyframe in frame 6. 
8. From the Tools panel, select Free Transform Tool . 
9. Apply a 90 degree clockwise rotation on symbol by selecting symbol and rotating the top 

end. 

 
Figure 9 - Applying Rotation to the Right 

10. Insert a new keyframe in frame 12. 
11. From the Tools panel, select Free Transform Tool . 
12. Apply a 90 degree counter-clockwise rotation on symbol by selecting symbol and 

rotating the right end. Wiper should now be in original position as in Figure 8. 
13. Insert a new keyframe in frame 18. 
14. From the Tools panel, select Free Transform Tool . 
15. Apply a 90 degree counter-clockwise rotation on symbol by selecting symbol and 

rotating the top end (see Figure 10). 

 
Figure 10 - Applying Rotation to the Left 

16. Insert a new keyframe in frame 24. 
17. From the Tools panel, select Free Transform Tool . 
18. Apply a 90 degree clockwise rotation on symbol by selecting symbol and rotating the left 

end. Wiper should now be in original position as in Figure 8. 

To apply motion tweening to the windshield wiper: 
1. Left-click in frame 1 of the swinging wiper symbol.  
2. Hold down the [Shift] key on the keyboard while left-clicking on frame 24. This will 

select frames 1 through 24. 
3. In the Properties panel, select Motion from the Tween: drop-down list. 

To view the windshield wiper movie clip: 
1. Click on Scene 1 button on the Timeline to go back to Scene 1. 
2. From the Library panel, left-click on swinging wiper symbol and drag it over to the 

middle of the stage. 
3. The animation is now complete. Hold down the [Ctrl + Enter] keys on the keyboard to 

test. The result should be a swinging wiper. 
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ADDING GOTOANDPLAY ACTION TO FRAME 
Movie clip symbols will automatically restart at the last frame. However, there is a short break  
of 1 frame where it is not playing. This can give a choppy or broken effect that is undesirable.  
To remove such an effect a simple action needs to be added to the last frame of the movie clip. 
By telling Flash to automatically go to frame 1, there will not be any dead frames when restarting 
the movie clip.   

To add gotoAndPlay action to a frame: 
1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “wheel.fla” file from the data files folder. 
3. Test the animation by holding down the [Ctrl + Enter] keys on the keyboard.  

(Notice the choppy effect when the movie clip restarts.) 
4. Double click on the rotating wheel symbol in the Library panel. The definition scene 

for the rotating wheel symbol gets activated. 
5. Click in frame 24 on the timeline. 
6. Click on the Actions button  below the stage to active the Actions panel. 
7. Click the Add new item to the script button . This will bring up a sub menu. Select 

Global Functions ► Timeline Control ►gotoAndPlay (see Figure 11).  

 
Figure 11 - Adding Action to Frame 

8. The text [gotoAndPlay();] will automatically be inserted. 
9. Make sure the blinking text cursor is between the parentheses. Type [1] on the keyboard. 

The text have now been changed to [gotoAndPlay(1);] (see Figure 12). 

 
Figure 12 - Adding the GotoAndPlay Action 

10. The action has now been added. Test the animation by holding down the [Ctrl + Enter] 
keys on the keyboard. Notice how there is no more dead frames in the Flash movie. 

Combining Animation Techniques 
This part will demonstrate examples that include combinations of previous techniques used in 
this handout; motion tweening, graphic symbols, and movie clip symbols. This part also 
introduces the ease; which is used to set the acceleration/deceleration of a motion tween. 

COMBINING MOTION TWEENING WITH MOVIE CLIPS 

   Adobe Flash 8, Part 3 - 7 

This example will apply the usage of graphic symbols, motion tweening, and movie clip 
symbols. Motion tweening will be applied to a car to make it move from the left to the right of 
the frame. The car will have wheels that rotate. For this effect using the movie clip symbol is 
best. The final result should look somewhat like Figure 13. 



 

 

 

Figure 13 - A Moving Car 
 
To add rotating wheels to car: 

1. Select the File menu ► Open…. The Open dialog box appears. 
2. Select the “car.fla” file from the data files folder. 
3. Double-click on car symbol in Library panel. The car symbol definition scene opens. 
4. From the Library panel drag the rotating wheel symbol over to the back of the car. 
5. Repeat also for front of the car (see Figure 14). 
6. Click on the Scene 1 button on the Timeline to go back to Scene 1. 
7. The animation can now be tested. To test, hold down the [Ctrl + Enter] keys 

 
Figure 14 – Car with Moving Wheels 

NOTE: The car is still not moving from the left to the right as wanted. Applying motion tweening 
will solve this problem. But first, the timing needs to be planned. How many seconds should the 
car take to move from the left to the right of the frame? Also, the number of frames per second 
needs to be considered when choosing how many frames will be used for the animation. So if the 
car uses 10 seconds to go from the left to the right, and the document has 12 frames per second, 
the total number of frames will be: 

10 seconds*12 frames/second = 120 frames 

To apply motion tweening to the car: 
1. Insert a new keyframe in frame 120. 
2. From the Tools panel, select the Selection Tool . 
3. Move the car to the right part of the stage (see Figure 15). 

 
Figure 15 – Moving the Car to the Right Part of the Stage 

4. Left-click on frame 1 in the Timeline. 
5. Hold down [Shift] key on keyboard while left-clicking on frame 120. This will select 

frames 1 through 120. 
6. In the Properties panel, select Motion from the Tween: drop-down list. 
7. The animation is now complete. Hold down the [Ctrl + Enter] keys on the keyboard to 

test. The result should be a moving car with rotating wheels. 
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ACCELERATION AND DECELERATION 
This example will cover a bouncing ball animation. However, to make it look like its really 
bouncing, the ball should accelerate before hitting the ground and decelerate after. This effect 
can be applied by setting the ease of the tween. 
 

NOTE: Ease is a number between 100 and -100. Default ease is 0, which means no acceleration or 
deceleration. Setting the ease below 0 will result in deceleration, while above 0 will result in 
acceleration. 

Creating a bouncing ball animation: 
1. Select the File menu ►New…. 
2. Click OK button. This will create a new flash file. 
3. Go to Insert ► New Symbol… in the menu. The Create New Symbol dialog box opens. 
4. Type [Circle]. 
5. Select the Graphic option button. 
6. Click OK button. The symbol definition scene opens. 
7. Draw a circle somewhere in the first frame. 
8. Click on Scene 1 to get back to Scene 1. 
9. Left-click and drag newly created Circle symbol from Library panel over to top-middle 

part of frame 1. 
10. Insert new keyframes in frames 12 and 24. 
11. In frame 12, move the Circle symbol to the lower-middle part of the frame. 
12. Left-click in frame 1 on the Timeline. 
13. Select Motion from the Tween: drop-down list. 
14. Set the Ease: to 100 (see Figure 16). 

 
Figure 16 - Setting the Ease 

15. Left-click in frame 12 on the Timeline. 
16. In the Properties panel, select Motion from the Tween: drop-down list. 
17. Set the Ease: to -100. 
18. The animation is now complete. Hold down the [Ctrl + Enter] keys on the keyboard to 

see animation (see Figure 17). 

 
Figure 17 - Timeline of a Bouncing Ball 

19. Go back to the car exercise file. Try making it so that the car decelerates till about the 
middle of the stage, then starts accelerating again. This will give the illusion of breaking 
and speeding. 

Supplemental Information  
The following section is intended to be used as a supplemental section for users who wish to add 
sound and graphic images to their Flash content.  
   Adobe Flash 8, Part 3 - 9 



SEARCHING THE WEB FOR SOUND FILES 
The following Web sites contain search engines for sound files. 

FindSounds 
FindSounds provides an easy-to-use search interface with numerous options to refine the search. 
Upon search the user can specify information such as file formats, number of channels, minimum 
resolution, minimum sample rate, and maximum file size (see Figure 18). 

 

 

Figure 18 – http://www.findsounds.com/ 

Altavista 
Altavista provides an easy-to-use and intuitive search engine for sound files (see Figure 19). 
Sound type can be specified together with the duration of the files. However, file size can not be 
specified. 

Figure 19 - http://www.altavista.com/audio/ 

SEARCHING THE WEB FOR IMAGE FILES 
The following Web sites contain search engines for image files. 

stock.xchng 
The leading service when it comes to high quality non-copyrighted stock exchange pictures (see 
Figure 20). In order to take advantage of all the services, a free signup is required.  
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Figure 20 - http://www.sxc.hu/ 

Google 
The leading search engine when it comes to image content. However, there is no indicator 
whether the files are copyrighted or not. 

Figure 21 - http://www.google.com/imghp/ 
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