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Introduction 
Adobe Flash 8 is the most advanced authoring environment for creating interactive and 
animated Web sites. It gives Web designers an efficient way to send artwork and animation over 
the internet. Flash uses vector graphics, which can be scaled to any size without losing 
clarity/quality. Flash also uses easy scripting for adding interactivity and animation. 

This workshop will cover basic animation techniques used in Flash. The most common technique 
today is to define keyframes, then let the computer generate the frames in between. This involves 
several techniques. In Flash it is called motion tweening and shape tweening. This handout is an 
introduction to animations using Flash. 

Animation Basics  
A movie consists of separate frames. When the frames are put together they form the movie. 
Animation is the technique used to create a movie or film by defining each frame individually. 
Each frame can be generated by a computer, or defined by the user. Animation is an optical 
illusion of movement created by having a consecutive display of static frames. These frames may 
be generated by a computer, or come from photography or a painted image. When the frames are 
put together and viewed it gives the illusion of continuous movement (see Figure 1). Computer 
animation has advanced considerably and is today at a stage where it can generate near life-like 
movies. 

 

 

 

Figure 1 - Illusion of Continuous Movement 

THE TIMELINE 
The timeline is used to work with animations in Flash (see Figure 2). Each frame of the Flash 
movie is represented on the timeline (see Figure 3). By default, Flash will display the timeline 
for Scene 1. A Flash file can contain multiple scenes, and each scene can have its own timeline. 

Figure 2 - The Timeline 

Figure 3 – Frames in the Timeline 

THE LIBRARY 
One of the fundamental parts of Flash is the library. When using the library, it is possible to have 
a “master” version of the graphic. With one change to the “master” version of the graphic all 
places where this graphic is referred to will also change. When something is placed in the library 
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it becomes a symbol. Anything that is created in flash and placed on stage can be converted into 
a symbol. 

When a symbol is used outside the library it is called an instance. The instance refers to the 
symbol. There is no limit to how many instances that can be created from a symbol. When the 
symbol is edited, all the instances referring to the symbol will change accordingly. 

To create a symbol: 
1. Select the File menu ►New…. The New Document dialog box opens. 
2. Select “Flash Document” in the Type: list box. 
3. Click the OK button. A blank Flash file will be created. 
4. Select the Insert menu ► New Symbol…. The Create New Symbol dialog box opens. 
5. Type [Circle] in the Name: text box. 
6. Click the Graphic option button in the Type: section. 
7. Click OK button. The symbol definition scene opens. 
8. Click the Oval Tool (O)  on the Toolbox and draw a circle anywhere in the first frame 

(see Figure 4). 

 
Figure 4 – Defining a Symbol 

 
NOTE: Notice the slightly changed timeline. Flash has changed to the symbol definition scene. On 
top of the timeline it will now say the name of the symbol that is being edited (see Figure 5).  

 
Figure 5 – The Current Scene 

To use the symbol: 
1. Click the Scene 1 button on the timeline to return to Scene 1. 
2. If the Library panel is not open, select the Window menu ► Library. 
3. From the Library panel click and drag “Circle” symbol on to the stage (see Figure 6). An 

instance of the symbol has now been created. 

 
Figure 6 - The Library Panel 
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INSERTING A NEW KEYFRAME 
Keyframes are frames that are user defined. By defining keyframes Flash can generate the 
frames between the keyframes using a process called tweening.   

To insert a new keyframe: 
1. Select the File menu ►New…. The New Document dialog box opens. 
2. Select “Flash Document” in the Type: list box. 
3. Click the OK button. A blank Flash file will be created. 
4. Right-click on frame 12 in the timeline (see Figure 7). A pop-up menu will appear. 
5. Select Insert Keyframe. A new keyframe will be inserted. This technique will be used 

frequently throughout this handout. 

 
Figure 7 - Inserting a New Keyframe 

OLD-STYLE ANIMATIONS 
Making a frame-by-frame animation is much like making a flipbook. In a flipbook, each page 
contains a slightly different picture. Fanning through the book will give an illusion of motion or 
an animation. Although this is not the most effective way to do animations in Flash, 
understanding this concept will provide a better understanding when using motion and shape 
tweening. 

To apply old-style animation to a circle: 
1. Select the File menu ►New…. The New Document dialog box opens. 
2. Select “Flash Document” in the Type: list box. 
3. Click the OK button. A blank Flash file will be created. 
4. Using the Oval Tool (O) , create a circle in the top-middle section of the stage (see 

Figure 8).  

 
Figure 8 - Inserting a Circle 

5. On the timeline, insert a new keyframe to the right of the current frame.  
6. Left-click and drag the circle slightly lower than the first circle using the Selection Tool 

(V)  (see Figure 9). 
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Figure 9 - Moving the Circle 

7. Repeat step 4 to 6 till the circle is at the bottom of the screen. (See Figure 10) 

Figure 10 - Circle at the Bottom of the Screen 

8. The animation is done. To play the animation, hold down the [Ctrl] key while pressing 
the [Enter] key on the keyboard. 

FRAMES AND FRAME RATE 
The more frames per second, the better will be the illusion of continuous movement. The default 
in Flash is 12 frames per second. This will be sufficient in most cases. However, depending on 
which kind of animation is created, and the level of realism, it may be desirable to switch to a 
different frame rate.  

To change the frames per second in Flash: 
1. Select the Modify menu ► Document…. The Document Properties dialog box opens 

(see Figure 11). 
2. Type [24] in the Frame rate: text box, then click the OK button. This will change the 

frame rate from 12 to 24 frames per second. 

 
Figure 11 - Document Properties 

3. Test the animation by holding down the [Ctrl] key while pressing [Enter] key on the 
keyboard. Notice how the circle moves faster. 
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Animations in Flash 
This section will deal with the different techniques used to create animations in Flash. There are 
2 basic techniques used: motion tweening (see Figure 12) and shape tweening (see Figure 13). 
Motion tweening applies motion to any object in Flash whereas shape tweening applies motion, 
but in addition it also allows modification to the shape of the object. Shape tweening is less space 
efficient because it generates a new copy of the object for each frame. Motion tweening uses a 
reference to the original object and creates an instance of it for each frame, applying only the 
given offset in location. 

 

 

Figure 12 - Motion Tweening 

Figure 13 - Shape Tweening 

MOTION TWEENING 
Old style animation requires a lot of work because the artist has to draw each frame manually. 
When using motion tweening in Flash, all that needs to be done is defining two keyframes. Flash 
then fills in the gaps between the two frames (see Figure 14). With motion tweening the user is 
able to animate the following properties: location, scale, rotation, tint and alpha. 

 
Figure 14 – Flash Fills in the Extra Frames Using Motion Tweening. 

The following example will demonstrate how to create an animation of a circle moving from the 
left side of the screen to the right side. 

To perform a simple motion tween: 
1. Select the File menu ►New…. The New Document dialog box opens. 
2. Select “Flash Document” in the Type: list box. 
3. Click the OK button. A blank Flash file will be created. 
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4. Select the Insert menu ► New Symbol…. The Create New Symbol dialog box appears. 
5. Type [Circle] in the Name: textbox. 
6. Click the Graphic option button in the Type: section. 
7. Click the OK button. The symbol definition scene opens. 
8. Using the Oval Tool (O) , draw a circle anywhere in the first frame (see Figure 15). 

 
Figure 15 - Defining a New Symbol 

9. Click the Scene 1 button on the timeline (see Figure 16). This will bring Flash back to 
Scene 1. 

 
Figure 16 – Buttons on the Timeline 

10. Drag newly created “Circle” symbol from Library panel to the left side of the first frame 
in Scene 1 (see Figure 17). 

 
Figure 17 - Creating an Instance of a Symbol 

11. Right-click inside frame 12 and select Insert Keyframe. 
12. With the Selection Tool , move the circle in frame 12 to the right side on the stage (see 

Figure 18). 

 
Figure 18 - Moving the Circle to the Right Side of the Stage 
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13. In the timeline, left-click on frame 1, then hold down the [Shift] key on keyboard and 
left-click on frame 12. Frames 1 to 12 will be selected (see Figure 19).  

 
Figure 19 - Selecting Multiple Frames 

14. In the Properties panel, select “Motion” from the Tween: drop-down list (see Figure 20). 

 
Figure 20 - Adding Motion Tween to Frames 

15. The animation is done. To play the animation, hold down the [Ctrl] key while pressing 
the [Enter] key on the keyboard. 

SHAPE TWEENING 
Shape tweening is a technique in Flash that can be used to create a morph effect. Morphing is an 
animation style that describes one shape turning into another shape. As with motion tweening the 
user only needs to define the first and the last frame (see Figure 21). Flash fills in the rest of the 
frames. Shape tweening increases the file size, since the flash library and symbols are not 
available for this tween type.  

 
Figure 21 – Flash Fills in the Extra Frames Using Shape Tweening. 

This following example will demonstrate how to create an animation of a circle changing its 
shape. 

To perform a simple shape tween: 
1. Select the File menu ►New…. The New Document dialog box opens. 
2. Select “Flash Document” in the Type: list box. 
3. Click the OK button. A blank Flash file will be created. 
4. Using the Oval Tool (O) , draw a circle as shown in Figure 22. 
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Figure 22 - A Simple Circle 

5. Right-click inside frame 12 and select Insert Keyframe. 
6. Deselect the circle in frame 12 by clicking anywhere outside the circle. 
7. Select the Selection Tool (V)  from the Toolbox. 
8. Place cursor near the outer edge of the circle as shown in Figure 23. 

 
Figure 23 - Using the Selection Tool Next to a Shape 

9. Left-click and hold the mouse button and drag to change the shape of the circle into 
something like in Figure 24. 

 
Figure 24 - Changing the Shape of the Circle 

10. Left-click in frame 1 on the timeline. 
11. In the Properties panel, select “Shape” from the Tween: drop-down menu (see Figure 

25). 

 
Figure 25 - Adding Shape Tween to Frames 

12. To play the animation, hold down the [Ctrl] key while pressing [Enter] key on the 
keyboard. 
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ANIMATING TEXT 
Text animations are no different than regular animations using motion tweening. The first step is 
to create the necessary symbols containing the text. After the symbols are created, they can 
easily be added to the keyframes. 

Adding animation to text: 
1. Select the File menu ►New…. The New Document dialog box opens. 
2. Select “Flash Document” in the Type: list box. 
3. Click the OK button. A blank Flash file will be created. 
4. Select the Insert menu ► New Symbol…. The Create New Symbol dialog box opens. 
5. Type [Text] in the Name: text box. 
6. Click the Graphic option button in the Type: section. 
7. Click OK button. The symbol definition scene opens. 
8. Using the Text Tool (T)  add some text in the first frame (see Figure 26). Format the 

text as desired. 

 
Figure 26: Adding Text to the Graphic Symbol 

9. Click the Scene 1 button on the timeline to go back to Scene 1. 
10. Add the newly created symbol to top-left corner of the stage in frame 1 by left-clicking 

and dragging it from the Library panel. 
11. Insert a new keyframe in frame 24. 
12. With the Selection Tool (V) , move the text to middle of the stage in frame 24. 
13. Left-click in frame 1 on the timeline.  
14. Select “Motion” from the Tween: drop-down menu. 
15. To play the animation, hold down the [Ctrl] key while pressing the [Enter] key on the 

keyboard. 

ADDING TIMELINE EFFECTS 
Flash has several built-in effects that can be added to an animation. These are common special 
effects such as “Blur,” “Drop Shadow,” “Expand,” and “Explode.” When using these built-in 
effects Flash will generate the necessary symbols and frames. These symbols should not be 
reused or modified as doing so risks interfering with the effect. This section will go through the 
“Blur” and “Explode” effects in particular, but a similar approach can be used to add other built-
in effects. 

Adding the Blur Effect 
This example is a continuation of the text animation created in last exercise; in addition to 
moving the text from one place to another, a “Blur” effect will be added to the end of the 
animation. 

To add the Blur effect: 
1. Left-click in frame 24 on the timeline. This will bring frame 24 to the stage. 
2. Select the Insert menu ► Timeline Effects ►Effects ►Blur. The Blur dialog box 

opens (see Figure 27). 

  Adobe Flash 8, Part 2 - 10 



 
Figure 27 - The Blur Dialog Box 

3. Adjust the settings until the desired effect is seen (see Table 1). Click the Update 
Preview button to view a preview of the adjustments. 

4. Click the OK button to apply the effect. 
5. To play the animation, hold down the [Ctrl] key while pressing the [Enter] key on the 

keyboard. 

Table 1 - Blur settings 
Blur Setting Result
Effect duration Affects the duration of the effect. 

Resolution 

Affects the number of individual copies of the object 
used to create the blur effect. The blur effect 
copies the object and scales it, while fading out at 
the same time. The higher the number, the more 
objects scaled and faded out within the duration 
specified. 

Scale Affects the scale of each copy of the object that is 
made to simulate the blur effect. 

Horizontal/Vertical 
Blur 

By selecting or deselecting these checkboxes, the 
direction of which the blur effect goes can be 
specified to either horizontal or vertical, or both. 

Direction of 
movement Affects the direction of the effect. 

Adding the Explode Effect 
The explode effect is a special effect that will make it look as if an object is exploding. To be 
more specific, the effect will split the object into smaller parts, and in a number of consecutive 
frames these parts will rotate and move from each other. 

Adding an explode effect to a bomb: 
1. Select the File menu ► Open…. The Open dialog box appears. 
2. Locate and select the “bomb.fla” file from the data files folder. 
3. Select the Insert menu ► Timeline Effects ►Effects ►Explode. The Explode dialog 

box opens (see Figure 28). 
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Figure 28 - Explode Dialog Box 

4. Adjust the settings until the desired effect is seen (see Table 2). Click the Update 
Preview button to preview the adjustments. 

5. Click the OK button to apply the effect. 
6. To play the animation, hold down the [Ctrl] key while pressing the [Enter] key on the 

keyboard. 

Table 2 - Explode settings 
Explode Setting Result
Effect duration Affects the duration of the effect. 
Direction of 
Explosion 

Affects the direction in which the fragments of the 
explosion will travel in. 

Arc Size 
Affects how much the fragments trajectory is curved. 
The various details of the curve can be specified 
using this setting. 

Rotate Fragments by Affects how many degrees the individual particles of 
the explosion will rotate. 

Final Alpha Affects the final transparency of the fragments. A 
value of “0” will ensure that the fragments fade out. 
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