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Advanced Microsoft Excel 2007 
Microsoft Excel 2007 is a software application that can be used as a spreadsheet, database, or 
graphing program. The electronic spreadsheet portion of Excel allows performing sophisticated 
calculations and creating formulas that automatically calculate answers. Data management 
capability allows manipulating lists of information such as names, addresses, inventory items, 
prices, etc. The information created in an Excel spreadsheet or database can be used to create 
Excel charts. In addition, Excel shares features such as the Version Compatibility Checker and 
the Document Inspector with other Microsoft Office 2007 applications to ensure consistency in 
the preparation and presentation of information.  

This handout presents some advanced features the program offers such as macros, paste special, 
organizational chart, advanced charting, and database. These are the features most commonly 
used by students and professionals in all fields.  

Worksheet/Workbook Enhancements 
Worksheet/workbook enhancements focus on the features Excel offers for internal use. When 
changing workbook properties, none of the data in the workbook is changed - only the 
description of the file. When cell comments are entered, they do not change the content of a cell; 
but only provide the description and explanation of the value in a particular cell. 

VIEWING WORKBOOK PROPERTIES 
Workbook properties are the information attached to a workbook to summarize its purpose or to 
help users locate it. Usually this information can be found in the Properties dialog box or the 
Document Information Panel, which contains fixed and modifiable information. Fixed 
information includes statistics such as the size of the workbook, the date the workbook was 
created, modified, date last accessed and the name of the last person who saved the workbook. 

Workbook properties can be viewed and modified by opening the Document Information Panel 
(see Figure 1) beneath the Ribbon and, if necessary, the Properties dialog box (see Figure 2). 
Partial properties can also be displayed using the Properties view in the Open dialog box of a 
closed workbook (see Figure 3). 

 
Figure 1 - Document Information Panel 

To view the Document Information Panel: 
1. Click the Office Button. 
2. Select the Prepare option. 
3. Select the    option. 

To open the Properties dialog box: 
1. With the Document Information Panel open, click the    drop-down 

arrow. 
2. Click the    option. 
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Figure 2 - Properties Dialog Box 

 
 
 
 
 

 
Figure 3 - Properties View in the Open Dialog Box 

 

To view partial properties from the Open 
dialog box: 

1. Click the Office Button. 
2. Select the    option. The Open 

dialog box will appear. 
3. Click the Views drop-down arrow (see 

Figure 4). 
4. Select    from the drop-down 

list. 
5. If necessary, navigate to the drive and 

folder where the file is located. 
6. Single-click the file to activate the 

partial properties panel (see Figure 3). 

 

 
Figure 4 - Views Drop-down List 

 

NOTE: If the computer is set to open files using a single click, step 6 above will open the file without 
displaying the partial list of properties. It is also possible to view a brief properties description (size, 
type, date modified) of the workbook by selecting Details from the Views drop-down list of the Open 
dialog box. 

EDITING WORKBOOK PROPERTIES 
The complete workbook properties can be found in the Properties dialog box (see Figure 2) in 
the Summary or Custom tabs. In the Summary tab there are preset fields where a user can insert 
new information or modify existing information. The user can also enter the title and subject 
text, enter or change the name of the author, assign categories or keywords or include comments. 
In addition to the existing fields, there are options in the Custom tab to create new fields and 
field information. 
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WORKING WITH COMMENTS 
Comments are notes added to a worksheet. Comments can be used to provide information about 
data in a cell or about the worksheet itself. Examples of how comments can be used might 
include describing how the user arrived at a particular formula in a cell, or list the telephone 
number of a client to whom the data in the worksheet refers. When a comment is attached to a 
cell, a red indicator appears in the upper, right corner of the cell (see Figure 5). Comments are 
useful to communicate with other users when working in shared workbooks on a network. Since 
comments include the name of the current user, they can be an effective way to explain data or 
the reason for a change. For example, if some of the users change a value in a shared workbook, 
a comment helps in explaining why the value was changed. 

 

 
Figure 5 - Cells with Comments 

 
Figure 6 - Comments Group 

To create comments: 
1. Select the cell to add a comment to. 
2. Select the Review tab on the Ribbon. 
3. Click the New Comment button in the Comments group (see Figure 6). A text box will 

open with an arrow pointing to the cell where the comment will be placed. 
4. Type the comment. 
5. When finished, click outside the cell to hide the comment 

NOTE: Comments can also be added by right-clicking in the cell and selecting the   
command. 

Comments can be viewed using the same technique as viewing a ScreenTip. When the mouse 
pointer is positioned over any cell that has a comment attached to it, the comment appears in a 
comment box next to the cell. To hide the comment, move the mouse pointer away from the cell. 

NOTE: To permanently display comments, right-click the cell and select the Show/Hide Comment 
option from the pop-up menu. 

Comments automatically include the name of the current user. The user name can be changed by 
clicking the Office Button  ►    ►     ► enter the correction in the   
text box. 

To change how comments are displayed, click the Office Button  ►    ►  

► make the changes in the    section of the dialog box. 

Comments can be edited by selecting the appropriate cell that needs editing. The New Comment 
button in the Comments group will change to an Edit Comment button. Clicking the Edit 
Comment button will open the comment text box in editing mode. Make any necessary changes 
and click outside the cell to save the edited comment. 
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Users can navigate through all comments in a worksheet by clicking the Next and Previous 
buttons in the Comments group until all comments have been viewed.  

Comments can be deleted by selecting the cell with the comment and clicking the Delete button 
in the Comments group. 

PRINTING COMMENTS 
The comments can be printed on a separate page at the end of a printed worksheet or as they 
appear on the worksheet. Comments that print on a separate page at the end of the printed 
worksheet display the cell address, the author of the comment, and the text that appears in the 
comment.  

To print the comments in a worksheet: 
1. Select the Page Layout tab on the Ribbon. 
2. Open the Page Setup dialog box by clicking the Page Setup dialog launcher  . 
3. Select the Sheet tab. 
4. In the Print section, click the Comments: drop-down list box and select either the At end 

of sheet or the As displayed on sheet option. 

NOTE: If the As displayed on sheet option is selected, the comment(s) must be set for permanent 
display. Otherwise, comments will not be printed. 

5. Click the Print… button ► OK button. 

USING SMARTART 
SmartArt is a new feature in Excel 2007. SmartArt is a visual representation of information and 
ideas that combines text and graphics so that information can be shown in a more visually 
enhancing manner. Figure 7 is an example of SmartArt. When the SmartArt graphic is placed on 
a worksheet, text can be automatically entered. The advantage to using SmartArt is that the user 
does not have to draw any of the graphic shapes. They are automatically created when the 
graphic is selected. The SmartArt graphic can be formatted if a different appearance is desired. 

 

 
Figure 7 - Example of SmartArt 

 
Figure 8 - Choose a SmartArt Graphic Dialog Box 

 

To incorporate a SmartArt graphic onto a worksheet: 
1. Select the Insert tab on the Ribbon. 
2. Click the SmartArt button in the Illustrations group. The Choose a SmartArt Graphic 

dialog box opens (see Figure 8).  
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3. Select the category in the left column of the dialog box; select the graphic in the List 
section of the dialog box. A description is provided in the preview pane on the right side 
of the dialog box (see Figure 8). 

4. After the graphic is selected, click the OK button. Text can then be entered by clicking in 
any part of the graphic where “[Text]” appears 

NOTE: Text can also be entered by clicking the Expand/Collapse button      on the left edge of the 
graphic and opening the Type your text here dialog box (see Figure 10). Click the Close button    
when finished and the text will automatically appear in the graphic. 

 
Figure 9 - Sample Blank SmartArt Graphic

 

 
Figure 10 - Type Your Text Here Dialog Box 

 

To format the graphic: 
1. Select the object so that the sizing 

handles are visible as in Figure 9. 
2. Right-click anywhere inside the 

object and select the   
option. The Format Shape dialog box 
opens (see Figure 11). 

3. Choose the appropriate options until 
the desired formatting effects are 
displayed by the graphic. 

4. When finished formatting the 
graphic, click the Close button. 

 

 

 
Figure 11 - Format Shape Dialog Box
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Using Paste Special 
There may be times when it is necessary to paste only certain aspects of copied data (such as 
formulas, values, or formats). For example, if the user wants to copy and paste all the formulas in 
a worksheet, but not the formatting associated with the cells. The Paste Special feature allows a 
user to specify which aspect of the copied data to paste; there are options to paste all cell 
attributes or only a specific one. 

 
Figure 12 - Paste Drop-down Menu 

 
Figure 13 - Paste Special Dialog Box 

WORKING WITH PASTE SPECIAL 
When copying the contents of a cell or a range of cells, any formatting that has been applied to 
the cell(s) is copied, as well as the cell contents. When the user subsequently pastes the copied 
data, an exact copy of both the contents and its formatting is pasted. 

To use the Paste Special option: 
1. Copy the relevant cell(s). 
2. Select the Home tab on the Ribbon. 
3. Click the Paste drop-down arrow in the Clipboard group. The Paste drop-down menu 

opens (see Figure 12). 
4. Select the    option. The Paste Special dialog box opens (see Figure 13). 
5. Select the appropriate option ► OK button. 

NOTE: The Paste Special dialog box can also be opened by right-clicking in the cell where the pasting 
operation will be performed and selecting the    option. 

COPYING VALUES BETWEEN WORKSHEETS 
There may be times when it is desired to copy the results of a formula, but not the formula itself. 
For example, a user may want to copy the totals from quarterly worksheets (in which each total 
is the result of a formula) to a summary worksheet (in which only formula results or totals are 
needed). Copying values between worksheets is accomplished by copying the cells, opening the 
Paste Special dialog box and selecting the    option in the Paste section ► OK button. 
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COPYING FORMULAS BETWEEN WORKSHEETS 
There may be times when it is desired to copy only the formula found in a cell or range of cells. 
Copying formulas between worksheets is accomplished by copying the cell(s), opening the Paste 
Special dialog box and selecting the    option in the Paste section ► OK button. 

Using Organization Charts 
An organization chart displays the hierarchical relationships within a framework or organization. 
An organization chart consists of shapes and connecting lines. Each shape contains the name and 
represents the position of a unit. The lines or connectors between shapes represent the 
relationships between each unit in the chart. Generally, the shapes closer to the top of the chart 
represent a higher position in the hierarchy of the organization. 

WORKING WITH ORGANIZATION CHARTS 
The user can apply an organization chart slide layout to a new or existing slide. When inserting 
an organization chart, it appears in a drawing canvas. The drawing canvas can be resized and 
moved as desired. 

PowerPoint treats an organization chart as a SmartArt object. Thus, adding animation effects, as 
well as formatting or selecting a different coloring scheme options are available to the user. 
Additionally, the layout of the chart can be changed as well. The different types of positions that 
can be included on an organization chart are described in Table 1. 

To create an organization chart: 
1. Select the Insert tab on the Ribbon. 
2. Click the SmartArt button in the Illustrations group. The Choose a SmartArt Graphic 

dialog box opens (see Figure 8). 
3. Click the Hierarchy button in the left pane. The available organizational charts will be 

displayed in the center pane. A description of each chart can be found in the right pane. 
4. Select a chart ► OK button. A chart object will be inserted in the slide (see Figure 14). 

 
Figure 14 - Sample Organization Chart 

NOTE: Text is entered and the chart formatted the same way as any other SmartArt object. See the 
Using SmartArt section in this document for instructions. Multiple objects can be selected by 
pressing the [Shift] + [Ctrl] key combination and clicking on the desired shapes. 

To change the layout of the organization chart: 
1. Right-click anywhere inside the object except in the text placeholders. 
2. Select the    option from the menu. The Choose a SmartArt Graphic dialog 

box will open (see Figure 8). 
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3. Click the Hierarchy button in the left pane. The available organizational charts will be 
displayed in the center pane. A description of each chart can be found in the right pane. 

4. Select a chart ► OK button. The chart object will change to the desired layout. 
 
To add a position to the organization chart: 

1. Right click the text object relative to 
where the position will be added. 

2. Select the Add Shapes option. 
3. Select the location where the shape will 

be added (see Figure 15). A new 
position will be added to the chart.  

Figure 15 - Add Shape Options 

Table 1 - Organization Chart Positions 
Type Position 
Subordinate Appears below and is connected to the selected shape. 
Coworker Appears adjacent to and is connected to the selected shape. 
Assistant Branches off from a connecting line, below the selected shape. 

NOTE: A position can be deleted from the chart by selecting the position and pressing the [Delete] key. 

To promote or demote a position in the chart: 
1. If necessary, open the    text box. 
2. Right-click inside the text editor for the position. 
3. Select the Promote or Demote option depending on the action desired. The position will 

be moved up (promoted) or down (demoted) relative to where it had been. 

Drawing and Modifying Objects on Worksheets 
The user can draw a variety of shapes on a worksheet. Additionally, once an object has been 
drawn, users can change the fill color, add text, or otherwise modify an object to give the 
presentation more visual appeal. For example, if a circle is drawn on a slide, it appears with the 
default fill color supplied by Excel. The user can modify the fill color to another color. 

DRAWING AN OBJECT 
The categories of objects that may be drawn include lines, rectangles, basic shapes, block arrows, 
equation shapes, flowcharts, stars and banners, callouts, and action buttons. Each category has 
several variations of shapes to choose from. 

To draw an object on a slide: 
1. Select the slide that will contain the object. 
2. Select the Insert tab on the Ribbon. 
3. Click the Shapes drop-down arrow in the Illustrations group (see Figure 16). The 

Shapes drop-down menu will open (see Figure 17). 

 
Figure 16 - Illustrations Group 

4. Click on the shape that will be drawn. 
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5. Place the cursor over the worksheet (the shape will change to a +). 
Click and drag until the desired size of the shape is reached; release the mouse. The 
object will appear on the worksheet (see Figure 18 for an example of a drawn rectangle). 

NOTE: Each object will have three different types of controls called handles (see Figure 18). The 
Object Rotation Handle rotates the object so that it is oriented at a different angle. The Bi-
Directional Sizing Handle will simultaneously change the size of the object in two directions. 
The Uni-Directional Sizing Handle will change the size of the object in one direction. To use a 
handle, click and drag it with the mouse. 

 

 
Figure 17 - Shapes Drop-down 

Menu 

 

 

 

Figure 18 - Object Handles 

CHANGING THE FILL COLOR 
The user can change the color inside the object. Fill color can be either changed or removed 
completely. 

To remove the fill color: 
1. Select the object to be modified. 
2. Select the Home tab on the Ribbon. 
3. Click the    drop-down arrow. The Shape Fill drop-down menu opens (see 

Figure 19).  
4. Select the    option. The object becomes transparent. 

To change the fill color: 
1. Select the object to be modified. 
2. Select the Format tab on the Drawing contextual tab on the Ribbon. 
3. Click the    drop-down arrow. The Shape Fill drop-down menu opens (see 

Figure 19).  
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4. Select the fill color from the   , the   , or the   
section. 

NOTE: If more colors are desired, select the    option and choose a color from the 
Colors dialog box (see Figure 20). 

 
Figure 19 - Fill Color Drop-down Menu 

 
Figure 20 - Colors Dialog Box 

 
CREATING AND MANIPULATING A TEXT BOX 
Text boxes offer another way to present information. The user can create text boxes as desired to 
label objects or graphics, add captions, or create additional notes. The font, font size, alignment, 
and font style features can be used to format text box content in a variety of ways. 

To create a text box: 
1. Select the Insert tab on the Ribbon. 
2. Click the Text Box button in the Text group (see Figure 21). 

 
Figure 21 - Text Group 

 
Figure 22 - Repositioning Cursor 

3. Position the cursor in the document where the text box is to be created ► left-click and 
drag to draw the text box. As soon as the mouse is released, the cursor is placed inside the 
text box. 

4. Type the desired text then click outside the text box. 

To re-position the text box: 
1. Click the text box to select it. 
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2. Move the cursor over one of the text box edges until it changes shape to a four-arrow 
cross (see Figure 22). 

3. Click and drag the text box to its new location. 

NOTE: A text box can be resized by first selecting it and then using the sizing handles as described in 
the Drawing an Object section of this document (see Figure 18 and Figure 22). 

To edit the contents of a text box: 
1. Right-click the text box to select it. 
2. Select the    option. The cursor will be placed in the text box. 
3. When the editing is complete, click outside the text box. 

GROUPING OBJECTS 
Grouping is particularly useful when multiple objects are intended to work together. When 
objects are grouped, they represent as a single object. Applying the same command to a group of 
objects saves time from changing each item separately. Additionally, grouped objects can be 
moved as a single object and maintain their spacing and alignment. 

 
To group objects: 

1. Hold down either [Ctrl] key or the 
[Shift] key and click each object to 
group. 

2. When all objects have been selected, 
right-click on one of the objects. 

3. Select the    option to open the 
submenu (see Figure 23). 

4. Select the    command in the 
submenu (see Figure 23). 

 
Figure 23 - Object Right-Click Menu 

UNGROUPING OBJECTS 
To make individual changes to an object that is grouped with other objects, it is necessary to first 
ungroup objects. 

To ungroup objects: 
1. Right-click any object in the group. 
2. Select the    option to open the submenu (see Figure 23). 
3. Select the    command in the submenu (see Figure 23). 

ADDING A 3-D EFFECT 
An object can appear three-dimensional by adding a 3-D effect. For example, when creating a 
logo, a 3-D effect makes the object stand out from the page. There are a variety of different 3-D 
styles to select from. 

NOTE: An object can have either a shadow or a 3-D effect, but not both. A line color cannot be assigned 
to fill a 3-D object, but the fill color can be changed 
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To add a 3-D effect to an object: 
1. Select the object to add a 3-D effect to by clicking on it. 
2. Select the Format tab on the Drawing contextual tab on the Ribbon. 
3. Click the    drop-down arrow in the Shape Styles group. 
4. Select the    option in the Shape Effects drop-down menu. 
5. Select one of the preset 3-D options (see Figure 24).

 
Figure 24 - Preset 3-D Rotations 

 
Figure 25 - Format Shape 3-D Format Dialog Box 

NOTE: After selecting one of the preset options, the object will appear to have no depth. Depth can 
be added by selecting    in the Shape Effects drop-down menu. When the 
Format Shape dialog box opens, click the    button and set the depth using the Depth: spin 
box (see Figure 25). 

ADDING A SHADOW EFFECT 
A shadow effect presents the object as if a light is being shined on it. The effect varies depending 
on the direction the light comes from. Excel 2007 offers the user a variety of shadow effects to 
choose from. 

To add a shadow effect to an object: 
1. Select the object to add the shadow effect by clicking on it. 
2. Select the Format tab on the Drawing contextual tab on the Ribbon. 
3. Click the    drop-down arrow in the Shape Styles group. 
4. Select the    option in the Shape Effects drop-down menu. 
5. Select one of the preset shadow effect options (see Figure 26). 
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Figure 26 - Preset Shadow Effects 

 
Figure 27 - Format Shape Shadow Effects Dialog 

Box 

NOTE: After selecting one of the preset options, the object can be formatted for a greater effect. 
Formatting can be done by selecting    in the Shape Effects drop-down menu. When 
the Format Shape dialog box opens, click the    button (if necessary) and make adjustments 
until the desired effects for the object are displayed (Figure 27). 

Advanced Charting Techniques 
After creating a chart, additional information or different elements may be added to the chart. 
Excel allows the user to manipulate any part of the chart as well as add elements. Information in 
a newly created chart will frequently have to be modified to be presented effectively and clearly. 

CHANGING THE AXIS SCALING 
When a chart is created, Excel automatically creates a scale for the value (Y) axis based on the 
data in the chart. This scaling can be changed if desired. The options in the Auto section of the 
Scale tab in the Format Axis dialog box (see Figure 28) are selected by default. When these 
options are selected, Excel overrides any manual settings. As soon as the user manually changes 
any of the scaling values, the corresponding check boxes in the Auto section are deselected 
allowing the manual values to be applied to the chart. To restore the scaling to its original values, 
reselect the appropriate check boxes in the Auto section. 
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To change axis scaling: 
1. Right-click the chart axis to change. 
2. Select the    option. The 

Format Axis dialog box opens (see 
Figure 28). 

3. Click the Fixed option button for the 
Minimum: and/or Maximum: axis 
values. 

4. Enter the value in the text boxes of the 
scale ► Close button. 

NOTE: The Minimum: and Maximum: settings 
control range of values on the scale, while the 
Major unit: and Minor unit: control the 
determination of how the axis is divided between 
the minimum and maximum values and the 
frequency of major and minor gridlines. The user 
can also manipulate where the category (X) axis 
crosses the value axis. The default value is “0”, but 
it can be any number between the maximum and 
minimum values. 

  
 Figure 28 - Format Axis Dialog Box 

CHANGING DATA SERIES CHART TYPES 
Excel allows mixing different chart types within a single chart to create a combination chart. For 
example, it might become necessary to show some of the total sales for a product in a column 
format and at the same time show some in a line format. Mixing chart types can help show the 
relationships between the data series more accurately and may improve the overall appearance 
and clarity of the chart (see Figure 29 for an example of a mixed chart). 

 
Figure 29 - Sample Mixed Chart Type 
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To change the chart type of a specific data series: 
1. Right-click the relevant data series object on the chart. 
2. Select the    command. The Change Chart Type dialog box opens 

(see Figure 30). 
3. Select the chart category in the left pane. 
4. Select the chart type to use from the right pane ► OK button. 

 
Figure 30 - Change Chart Type Dialog Box 

ADDING A TRENDLINE 
Because of the varying height of the bars in a column chart, it is sometimes difficult to determine 
the general direction or trend of the data. Excel enables users to quickly add a trendline to a data 
series (see Figure 31). A trendline has the effect of smoothing out rough spots in the data of a 
chart and provides an overall better picture of the data series. Trendlines are commonly used for 
data charted over time. 

To add a trendline to a data series: 
1. Right-click the data series object on the chart. 
2. Select the    option. A trendline is added to the chart and the Format 

Trendline dialog box opens (see Figure 32). 

NOTE: By default, a Linear type trendline is added to the chart. Different types can be selected from 
the Trend/Regression Type section of the Format Trendline dialog box. 

Line Color, Line Style, and Shadow effects can be altered on the trendline if desired by clicking 
the appropriate button in the left pane of the dialog box. Other options that users frequently find 
useful is to check the    and    options at the bottom 
of the Trendline Options section. Displaying the equation on the chart means that the equation 
used to determine the trendline will be visible to the user. Displaying the R-squared value 
provides the user with a good indication of how well the data fits the trendline. The R-squared 
can range from 0 to +1.00. Generally, the larger the R-squared value, the more accurate will be 
the predictability of the trendline equation. A trendline can be deleted by selecting it and pressing 
the [Delete] key. 
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Figure 31 - Sample Chart with Trendline Added 

 
Figure 32 - Format Trendline Dialog Box 

NOTE: The    option may not be available on all chart types, particularly those that use a 3-
D visual effect. 

Macros 
A macro is a program created to automatically perform frequently used operations. It contains all 
the commands, mouse movements, and user actions necessary to complete a task. Macros can 
save a considerable amount of time because they can be used to automate repetitive, time-
consuming tasks. Macros can be used for simple tasks performed frequently or for complex tasks 
that require consistency. 

DEFINING MACROS 
Excel macros are written in the Visual Basic for Applications programming language. The 
series of commands used in a macro is known as a procedure. Each procedure is given a name 
that is used to execute the macro. 

Each procedure is saved in an object called a module. The module is attached to the worksheet 
where the macro is stored. The module is hidden and cannot be seen in the normal window view. 
To select the module to view and edit the macro commands, the Visual Basic Editor must be 
used. 

NOTE: A macro can be stored in a specific workbook, a new workbook, or a special hidden workbook 
called the “Personal Macro Workbook”. Macros stored in a specific workbook can only be used when 
that workbook is open. The “Personal Macro Workbook” automatically opens when Excel starts. As a 
result, macros stored in the “Personal Macro Workbook” are available to all workbooks. 
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RECORDING A MACRO 
A macro can be created using the macro recorder. Excel records the macro as the user performs 
the steps to include in it. The steps are not recorded as simple keystrokes but are translated into 
the Visual Basic for Applications programming language which translates the steps into macro 
statements. 

When recording a macro, Excel creates a module in the current worksheet. As the user performs 
the macro keystrokes, they are saved as Visual Basic language statements in that module. A 
module can contain more than one macro. During the macro recording process the user names 
the macro and enters descriptive information about it. This information is entered in the Record 
Macro dialog box and appears as a comment in the module. If text is going to be selected as part 
of the macro routine, it must be selected using the keyboard. The macro will not recognize 
selecting text using the mouse. 

Some words are reserved and cannot be used in a macro name; reserved words are usually macro 
commands, such as “Date,” “If” or “Next.” If a reserved word is used in a macro name, a 
warning message will open when the user tries to exit Excel. The user will not be allowed to exit 
the program until the reserved word is changed. 

To record a macro: 
1. Select the View tab on the Ribbon. 
2. Click the Macros drop-down arrow in the Macros group. 
3. Select the    option from the drop-down menu. The Record Macro dialog 

box opens (see Figure 33). 
4. Assign a name to the macro in the Macro name: text box. 
5. Select a place to store the macro in the Store macro in: drop-down menu. 

 
Figure 33 - Record Macro Dialog Box 

 
Figure 34 - Macro Dialog Box 

NOTE: An optional description of the macro can be entered in the Description: text box. 
Additionally, a shortcut key can be created by entering a letter in the Shortcut key: text box. The 
[Ctrl] + [letter] key combination can be used to start the macro once it has been recorded and stored. 
The shortcut key is case sensitive and users should not choose keys that are already used by Excel. 
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6. Click the OK button and perform the necessary key/mouse commands until the sequence 
is completed. 

7. Click the Macros drop-down arrow in the Macros group. 
8. Select the    option from the drop-down menu. The macro will cease 

recording. 

RUNNING A MACRO 
Macros are saved in modules, and both are saved with the workbook in which they were written 
unless they are saved in the “Personal Macro Workbook”. Before the user can run a macro, the 
workbook in which it is saved must be open. When a macro is selected run, Excel performs the 
commands in the same sequence that was performed when it was recorded. Macros in any open 
workbook can be run from any other open workbook. 

To run a macro: 
1. Select the View tab on the Ribbon. 
2. Click the Macros button in the Macros group. The Macro dialog box opens (see Figure 

34). 
3. Select the macro to run, and then click the Run button. 

Enabling Macros 
To function properly, file security must be set to allow macros to run. When a macro is recorded, 
it can be immediately run. The effect of any security settings will not be seen until the workbook 
has been closed with all changes saved. The default security setting in Excel is to disable all 
macros when a file containing them is opened. The user then has the option to enable the 
disabled content. 

To enable macros when opening a file: 
1. Open the file. A message bar will appear at the top of the worksheet (see Figure 35). 
2. Click the    button on the message bar. The Microsoft Office Security Options 

dialog box opens (see Figure 36). 
3. Click the    option button ► OK button. The content will be enabled, the 

dialog box will close, and the message bar will disappear. 

 
Figure 35 - Message Bar 

 

 
Figure 36 - Microsoft Office Security Options Dialog 

Box 
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DELETING A MACRO 
Macros that are no longer useful can be deleted. Since macros can invoke other macros, make 
sure that the macro being deleted is not needed by another macro. If a macro is stored in a 
workbook, the workbook must be open to delete the macro. If the macro is stored in the 
“Personal Macro Workbook” (which automatically loads as a hidden window every time Excel 
is opened) the “Personal Macro Workbook” window must be unhidden before the macro can be 
deleted, even though the macro may be visible in the Macro dialog box. 

To unhide the Personal macro workbook: 
1. Select the View tab on the Ribbon. 
2. Click the    button in the 

Windows group. The Unhide dialog 
box will open (see Figure 37). 

NOTE: The Unhide dialog box displays all 
hidden workbooks. 

3. Select the “PERSONAL” workbook ► 
OK button. A workbook named 
“PERSONAL” will open.  

 
Figure 37 - Unhide Dialog Box 

To delete a macro: 
1. Select the View tab on the Ribbon. 
2. Click the Macros button in the Macros group. The Macro dialog box opens (see Figure 

34). 
3. Select the macro to delete, and then click the Delete button. 

Working with the Database Features in Excel 
Although manipulation of numeric data is Excel’s primary purpose, the row-and-column format 
lends itself in creating and storing databases. Generally, a good rule of thumb is that if the 
worksheet grows to more than 2000 rows, then the data should be stored in a data warehouse or 
relational database such as Microsoft Access. 

USING A DATABASE 
A database is a collection of information arranged in a way that makes it easy to access. For 
example, a telephone book is a static database arranged in alphabetical order. Because it is static, 
the information cannot be rearranged. In real-world applications, the capability is needed to 
manipulate a database. This capability is known as database management. 

Excel has built-in database management capabilities. The user can treat a worksheet, or portions 
of a worksheet, as a database. An Excel database can help in entering, editing, locating, sorting 
and analyzing information. In Excel, the user can define any continuous collection of data as a 
database. The columns contain the field categories and the rows contain the record data. 
Additional rows can also be inserted as records are added to the database. A valid database does 
not contain any blank columns or rows. 

NOTE: The user can also work with tables created in other Microsoft Office 2007 programs by copying 
and pasting the lists into Excel. 
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CREATING AND SAVING A DATABASE 
Before creating a database the user must consider the specific information to collect (that is, the 
fields or categories of information). For example, it is necessary to track a client name, address, 
city, state, zip code, telephone number, invoice number, date of invoice, amount of invoice and 
the sales representative’s commission. One field can be created (or one column used) for each 
type of information. 

A field occupies a single column of a database and contains a single piece of information in each 
record. For example, a “Salary” field might contain salary information for each employee 
record. The user can enter text, numbers, formulas, dates, or functions into a field. A computed 
field contains formulas or functions. Excel uses the top row of the list (the column label) as the 
field name. 

Proper planning can save hours of additional work at a later date. For example, to sort a database 
by last name, it is necessary to create two fields (one for the first name and one for the last 
name). It is difficult to enter the first and last names in a single field and then sort by last name. 

Once the field names for a database have been created, it is time to enter records. Each row of a 
database contains one record. A record contains all the information related to one entry. For 
example, an employee record could contain the name, address, telephone number, and salary 
information of a single employee. Although each record contains all the fields in the database, 
every field is not necessarily required to contain data. 

To create a database in Excel: 
1. Create a new Excel file and input the data as is normally done. 
2. Select the cell to enter the first column label. 
3. Type in the desired column label. 
4. Press the tab key on keyboard to move to the next cell in the row. 
5. Enter additional database field labels as needed. 
6. When the fields have been labeled, enter records for each field. 

NOTE: Previous versions of Excel allowed the user to save the worksheet with a “.dbf” file extension 
that allowed the worksheet to be opened by a database program. Excel 2007 no longer has that feature 
available. Instead, the user must save the worksheet and then import it directly into Access 2007. See 
the Intermediate Access Handout for the Microsoft Office 2007 series for step-by-step instructions on 
importing an Excel worksheet. 

MODIFYING A DATABASE 
A user can modify a database by adding and/or deleting records and fields. New records can be 
added to the end of the database or a new row can be inserted in the database to add a record in a 
particular location. The user can also delete records by deleting the row that contains the record. 
When a row is deleted, Excel adjusts any database ranges as needed. If the user simply clears the 
contents of a record, the blank row will cause problems when sorting and locating records within 
the database. 

After a database has been created, sometimes there is a need to track additional information. The 
user can insert columns into the database to create additional fields as needed. Conversely, the 
fields that no longer need to be tracked can be deleted. Deleting unnecessary fields produces a 
more efficient database and faster sorts and queries. Modifying a database by editing the 
information happens the same way as editing any worksheet. The user can change the 



information in any field by editing it on the Formula bar or by typing over the old information in 
the cell. The information can also be copied from one cell to another. 

A valid database list cannot contain any blank columns or rows. 

NOTE: A database can be formatted using of any of the Excel formatting features. 

When a row is deleted, all the information in that row is deleted across the entire worksheet. 
Before deleting a row, make sure that there is no information in the row that should be retained. 

VIEWING RECORDS USING THE  DATA FORM 
Viewing records in the data form allows easy navigation between records. The data form 
displays one record at a time. If a list has hundreds of records, the data form allows quick 
scrolling to the desired record. When the scroll box in the scroll bar is dragged, the counter in the 
upper right corner of the data form indicates which record will appear when the mouse button 
releases. The data form can only be accessed by customizing the Quick Access Toolbar. 

To customize the Quick Access Toolbar and 
view records using data form: 

1. Click the Customize Quick Access 
Toolbar drop-down arrow  . 

2. Select the    option.  
The Excel Options dialog box opens. 

3. Set the    drop-
down list to  . 

4. Scroll down the list of available 
commands and select  . 

5. Click the    button to add the 
command to the toolbar ► OK button. 

6. Place the cursor in a field in the first 
record. 

7. Click the Form button on the Quick 
Access Toolbar. The record will open 
in the data form (see Figure 38). 

 
Figure 38 - Viewing Records Using Data Form 

NOTE: Pressing the [Enter] key or the [Shift+Enter] key combination will move to the next or 
previous records, respectively. The [Page Up] and [Page Down] keys move you through multiple 
records in the database using one keystroke. 

EDITING RECORDS USING THE DATA FORM  
The data form can be used to edit records. In the data form, each field appears in its own text 
box. The data in the text boxes are edited the same way as in a worksheet. 

To edit a record in data form: 
1. Open the records in the data form. 
2. Display the record to edit. 
3. Select the text in the field to edit. 
4. Edit the text as desired. 
5. Press the [Enter] key. 
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NOTE: The changes can be canceled and the original data can be restored by clicking the Restore 
button on the data form (see Figure 38) before pressing the [Enter] key and moving to another 
record. 

ADDING RECORDS USING THE DATA FORM 
Records can be added to the database by using the data form. New records are appended to the 
end of the database. Any existing named ranges in the list do not expand to include the new 
records. 

NOTE: Pressing the [Tab] key or the [Shift+Tab] key combination moves to the next and previous 
fields, respectively. The insertion point moves to the New button when the [Tab] key is pressed from the 
last field in a record. 

To add a record using the data form: 
1. Open the records in the data form. 
2. Click the New button. A new record appears in the dialog box with all blank fields. 
3. Type the information in the field(s) of the dialog box. 
4. Click the Close button to close data form. Scroll as necessary to verify that the new 

record appears correctly at the end of the database. 

DELETING RECORDS  USING THE DATA FORM  
When a user no longer needs a record or it becomes irrelevant, the record can be deleted from the 
data form. The record is deleted from the worksheet as well. 

To delete a record from the data form: 
1. Open the records in the data form. 
2. Display the record to delete. 
3. Click the Delete button. A message box asking for confirmation of the deletion appears. 
4. Click the OK button. 

NOTE: The Delete button in the data form dialog box should be used with caution. Once a record is 
deleted from the data form, it cannot be restored. 

SORTING DATABASE RECORDS 
Users can sort data in a table according to the entries in a particular column. A table is a range of 
cells organized with similar sets of data in each column. For example, the user may have a table 
containing employee data, with columns for the first name, last name, department, salary, and 
age. Users can sort the list alphabetically by employee name or numerically by salary. It is also 
possible to group the employees alphabetically by department. 

Excel uses the following guidelines when sorting data: 
1. Rows with duplicate items in the sort column remain in their original order. 
2. Rows with blank cells in the sort column are placed last in the sorted list. 
3. Hidden rows are not moved. 

NOTE: If the user wants to be able to restore a list to its original order, a column must be included 
containing sequential numbers to denote the original position of each row before the data is sorted. 
The table can then be sorted by this additional column to restore the list to its original order. 

Lists can be sorted by more than one column by selecting the Data tab on the Ribbon and 
clicking the Sort button in the Sort & Filter group. The Sort dialog box (see Figure 39) opens 



and allows the user to specify any number of columns to sort by. Additional columns can be 
specified by clicking the    button on the Sort dialog box. An order of precedence is 
followed in the sort schema. Users should designate the first column to sort by as the most 
general and the last column as the most specific. 

 
Figure 39 - Sort Dialog Box 

SORTING RECORDS IN ASCENDING/DESCENDING ORDER 
A list can be sorted in either ascending or descending order. Ascending order sorts a list from the 
lowest to highest value. Descending order sorts a list from the highest to lowest value. Lists are 
sorted by the column that contains the active cell. 

The order of an ascending sort is listed below: 
1. Numbers are sorted from the smallest negative number to the largest positive number. 
2. Dates and times are sorted based on their chronological value. 
3. Text and text that includes numbers is sorted as follows: 0 1 2 3 4 5 6 7 8 9 (space) ! " # $ 

% & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T 
U V W X Y Z. 

4. False logical values are sorted before true logical values. 
5. All error values are equal and are not sorted. 
6. Blanks are always sorted last. 

In a column of mixed data, the ascending sort order is numbers, dates, text, logical values, error 
values, and blanks with items within each category sorted in ascending order. Descending sorts 
list data in the reverse order of ascending sorts, except for blanks. Blank cells are always sorted 
last. Therefore, in a column of mixed data, the descending sort order is error values, logical 
values, text, dates, numbers, and blanks with items within each category sorted in descending 
order. 

NOTE: Apostrophes (’) and hyphens (-) are ignored in a sort, unless two items are identical except for the 
apostrophe or hyphen. In that case the apostrophe or hyphen is sorted last in an ascending sort and first in 
a descending sort. 

To sort a list in ascending or descending order: 
1. Click in the column of data that will be sorted. 

Advanced Microsoft Excel 2007 - 25 



2. Select the Data tab on the Ribbon. 
3. Click the sort Ascending button    or the sort Descending button  . 

An alternative sort method is to right-click in the column of data, select the    option and then 
select the sort order. Additionally, users can click the    button on the Data tab of the 
Ribbon to open the Sort dialog box (see Figure 39). 

Using the Version Compatibility Checker 
A new feature in several of the Microsoft Office 2007 applications is the Compatibility Checker. 
The Compatibility Checker will inspect workbooks created in Excel 2007 to see if the 
worksheets contain objects such as SmartArt that are incompatible with earlier versions of Excel. 

To run the Compatibility Checker: 
1. Click the Office Button. 
2. Select the    option. 
3. Select the Run Compatibility 

Checker option. The Microsoft Office 
Excel Compatibility Checker dialog 
box opens (see Figure 40). Any 
incompatible items will be identified in 
the dialog box. 

4. Click the OK button to close the dialog 
box. 

NOTE: If no incompatible items are identified 
in the workbook, the dialog box will still open 
and indicate that no incompatible items were 
found. 

Figure 40 - Microsoft Office Excel Compatibility 
Checker Dialog Box 

By default, Excel will check the backward compatibility of any presentation when it is saved in 
the    format. If no incompatible items are found, the Microsoft Office Excel 
Compatibility Checker dialog box will not open. If an incompatible item is identified and the 
user proceeds to save the workbook, the incompatible item will be degraded so that the 
workbook will open in an earlier version of Excel. For example, SmartArt objects will be 
converted to non-editable images that will open in the earlier version. 

Using the Document Inspector 
Another new feature in Microsoft Office 2007 applications is the Document Inspector feature. 
Workbooks may sometimes contain hidden or personal information that a user may be unaware 
of, or does not want to share with others if copies of the workbook will be distributed. Personal 
information can also become embedded in the form of metadata when workbook properties are 
set. The Document Inspector will identify any potential information that a user may want 
removed before distributing a workbook and give the user the option to remove it.  

To use the Document Inspector: 
1. Click the Office Button. 
2. Select the    option. 
3. Select the    option. The Document Inspector dialog box opens (see 

Figure 41). 
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4. Users are presented with six categories of information that the Document Inspector will 
search for. Each of the categories can be either selected or deselected by the user with the 
associated check boxes. 

5. When the categories have been selected, click the Inspect button. 

 
Figure 41 - Document Inspector Dialog Box 

6. When the Document Inspector completes its search, the Document Inspector Results 
dialog box will open (see Figure 42).  

7. If any potential personal information is found within the document, the user can choose 
to ignore it or eliminate it by clicking the Remove All button. 

8. The user can re-inspect the document by clicking the Reinspect button, or, if no further 
actions are needed, click the Close button. 

 
Figure 42 - Document Inspector Results Dialog Box 
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