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Introduction 
Adobe Dreamweaver® is the widely used industry standard program for Web site creation. Using 
a design view to create the layout, code views to create scripting and backend, or split screen 
view to work on both simultaneously, users can easily create the page they desire. The added 
ability to integrate other Adobe Creative Suite software such as Photoshop, Illustrator, 
Fireworks, and Flash into the final page design is another benefit of the program. 
 
In Part 4, learn how to create and manipulate layer, an element which gives users flexibility in 
placing objects on the screen. Layers are also required in working with timelines and behaviors, 
the two crucial tools that are essential in creating animation. Several basic special effects will 
also be introduced in this Part. 

Layers 
Layers are used to lay out the page because they provide a great deal of flexibility in placing 
content. Users can put content inside a layer and locate the layer anywhere on the screen. 
Moreover, users can manage layers as desired. 
 

To draw a layer: 

1. Change the Insert bar to Layout category. Select the Draw Layer button . 
 

 

 

Figure 1 - Layout Category of the Insert Bar 

2. Click and drag a rectangle. 
3. A layer will show on the screen (see Figure 2 ). 
 

 
Draw a Layer 

 
Resize a Layer 

 
Move a Layer 

Figure 2 - Layer 

To resize a layer: 
1. Select a layer and click the border of the layer to show the selection handles. 
2. Place the mouse on any one of the selection handles. The mouse becomes a double-

headed arrow (see Figure 2). 
3. Click and drag to resize the layer. 

 
To move a layer: 

1. Select a layer and click the border of the layer to show the selection handles. 
2. Place the mouse on the border. The mouse becomes a four-headed arrow (see Figure 2). 
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3. Click and drag to move the layer. 
 
To delete a layer: 

1. Select a layer. 
2. Press the [Delete] key on the keyboard to delete the layer. 

 
NOTE: When inserting a big picture into a small layer, the layer will expend automatically to fit 
the picture size.  

PROPERTIES PANEL OF LAYERS 
The properties panel shows all the information of one particular layer. Depending on which layer 
is selected, the value on the properties will change accordingly. Table 1below describes the 
meaning of every field. 

 

 
Figure 3 - Properties Panel of Layers 

 
Table 1 - Fields of Properties Panel 
Panel Field Description 
Layer ID Shows the name of the layer so users can identify the layer. 
L and T Left and Top tell the layer’s relative position from the 

upper-left hand corner of the page. 
W and H The layer’s Width and Height. 
Z-Index Determines the order of the layers. Higher-numbered layers 

appear in front of lower-numbered layers. 
Vis This lets the user know if the layer is visible or not. The 

default is invisible. 
Bg image This sets up the Background image of the layer. 
Bg color This sets up the Background color of the layer. 

 

Adding Content into a Layer 
Inserting content inside the layers can help to arrange the interface. Users can add text or pictures 
inside the layers as a convenient way to arrange their Web pages. 
 
To Add Content into a Layer: 

1. Click inside the desired layer. 
2. On the Insert bar ► Change to the Common category. 

3. Select the Image button . The Select Image Source dialog box will appear (see Figure 
4). 

4. Look for “arrow.gif”. 
5. Click OK. 
6. Create another new layer. 
7. Repeat step 1 to 6 to add “target.gif”, “ball.gif”, and “table.gif” inside the new layers.  
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Figure 4 - The Select Image Source Window 

MANAGING LAYERS 
When using multiple layers, it is important to learn how to manage layers to avoid getting 
confused. By using the layers panel, users can change the name, stacking order, and visibility of 
layers. 

 
To open the layers panel: 

1. Select Window menu ► Click Layers.  
2. The Layers panel shows under CSS window on the right hand side of the screen (see 

Figure 5). 

 

Eye Icon Column 
(Visibility). 

Z-Index  
(Stacking Order) 

Figure 5 - Layers Panel 

To rename a layer: 
1. Double-click on the name of the layer. 
2. Rename it and click [Enter]. 

 
To change the order of a layer: 

1. Click on the order of the layer. Enter new value and click [Enter]. 
OR 

Click on the name of the layer and drag up or down to a desired position, then release the 
mouse to change the order. 
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NOTE: Checking the Prevent overlaps checkbox  can avoid having layers 
overlap each other. 

 
To change the layer visibility: 

1. Click in the Eye Icon column for a layer to change its visibility.  
2. The first click will switch from a closed eye to an open eye, followed by no eye icon after 

the following click. 
 

NOTE: The open eye means the layer is visible, the closed eye means invisible, and when there is 
no eye icon, the default is visible. 

Timelines 
Dreamweaver 8 offers a timeline function to create basic animations. With the timelines panel, 
users can work with separate timelines to control different actions on a page. The simple way to 
activate a timeline is by dragging a layer inside the panel. 
  
To open the timelines panel: 

1. Select Window menu ► Click Timelines. 
2. The Timelines Panel shows at the bottom of the screen (see Figure 6 and Table 2). 

 
To add objects to a timeline: 

1. Select Arrow layer. 
2. Click and drag Arrow layer into Animation channel. The purple Animation bar will 

appear. 
 

NOTE: Only images and layers can be added into the timeline. 
 
 

Playback Head Frame Numbers 
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Figure 6 - Timelines Panel 

Table 2 - Timelines Panel Introduction 
Panel Section Description
Timeline pop-up 
menu 

It specifies which timeline is currently displayed. 

 
The meanings (in order from left to right) are: Back 
to the first frame/Backward one frame/ Current frame 
number/ Forward one frame. 

Fps  
(Frames per second) 

The default setting is 15 frames per second, which is
a good average rate for animation. 

Autoplay Check this box to make the timeline play 
automatically when the page opens in a browser. 

Timeline Pop-Up 

Behaviors Channel 

Animation 
Animation Channel 

Keyframes



Panel Section Description
Loop Check this box to make the timeline loop 

continuously. 
Playback head It indicates which frame is currently displayed. 

 

To edit the timeline: 
1. Click frame 1, and set the arrow on the right of the screen (Starting location).  
2. Click frame 15, the click and drag to set the arrow on the left of the screen (Ending 

location). A line will appear on the screen showing the route (see Figure 7). 
3. Check the Autoplay checkbox on the panel. A message window pops up. 

Click OK (see Figure 8). 
4. Save the file. 
5. Go to the File menu ► Preview in browser to view the result. 
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Figure 7 - Animation Route 

 
Figure 8 - Dreamewaver 8 Message Window 

To add multiple timelines and keyframes: 
1. To add a new timeline (Timeline2), go to the Modify menu ►Timeline ► Add 

Timeline.  
2. Click and drag the “Ball” layer into the animation channel of Timeline2. 
3. To add a new keyframe, click on frame 5 and go to the Modify menu ► Timeline 

►Add keyframe.  
4. Rearrange the ball’s location for frame 5. 
5. Follow the step above to add a keyframe on frame 10 and rearrange the location. 
6. Set the ending location on keyframe 15. 
7. Use the Playback head (see Figure 6) to check the movement. Save the file. 

 

Behaviors 
Behaviors are used to add interactivity to the site (see Table 3). Use the Behaviors panel to 
select an action (behavior) and how to trigger it (event). The panel is also used to add, modify, or 
remove behaviors. Behaviors can be used together with timelines or work along with other 
objects.  

The line shows the route 



Table 3 - Event Names and Definition 
Event Triggered When
onBlur A field loses focus or becomes inactive. 
onClick Clicking the object. 
onDblClick Double-clicking the object. 
onFocus A field gains focus or becomes active. 
onKeyDown Pressing a key on the keyboard. 
onKeyPress Pressing any key. 
onKeyUp Releasing a key. 
onLoad When a page, frameset, or image finishes loading. 
onMouseDown Pressing the mouse button. 
onMouseMove Moving the mouse. 
onMouseOut Moving the mouse off an object. 
onMouseUp Releasing a mouse button. 
onMouseOver Placing the cursor over an object. 
onUnload The user goes to a new URL or the browser is closed. 
 
To open the Behavior panel: 

Go to the Window menu ►Behaviors. The Behaviors panel will show on the right side of 
the screen (see Figure 9). 
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Show all events Add behavior Remove event Move selected event up

Figure 9 - Behaviors Panel 

Behavior with Timeline 
1. After setting up a timeline for an animation, select the ball layer and go to the Behaviors 

panel, ► Click the Add behavior button   to open the actions list (see Figure 10). 
2. From the menu, select Timeline ► Play timeline. The Play timeline dialog box opens 

(see Figure 11). 
3. Click the down-point arrow and select Timeline2. 
4. Click OK. 

Behavior 

Show set events Move selected event down 

Event 



 

 

 

Figure 10 - Insert Behavior 

Figure 11 - Play Timeline Window 

5. On the Behaviors panel, a new behavior is added. 
6. Click the down-point arrow on event and select onClick (see Figure 12). 

Figure 12 - Change Event 
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7. Save the file and preview the result. 
 

Other Behaviors 
To add a Popup Message: 

1. Select the <body> tag (see Figure 15). 
2. Click the Add behavior button on the Behavior panel. 
3. Select Popup Message. The Popup Message window shows (see Figure 13). 
4. Inside the Message text box, type the message “Welcome! Let’s learn how to create some 

interactions.”  
5. Click OK. 
6. Save the file and preview in the browser to see the result. 
 

 

 

Figure 13 - Popup Message Window 

Set Text of Status Bar: 
1. Select the <body> tag (see Figure 15). 
2. Click the Add behavior button on the Behavior panel. 
3. Select Set Text ►Set Text for Status Bar. The Set Text of Status Bar window appears 

(see Figure 14). 

Figure 14 - Set Text of Status Bar Window 

4. In the Message text box, type “Dreamweaver part 4- Layer, Timeline and Behavior”. 
5. Click OK. 
6. Save the file and preview in the browser to see the result. 

DRAG LAYER 
Drag layer allows users to drag any layer and put it into a desired location on the screen. It is 
usually used for things such as drag and drop games and puzzles. 
 

To create the drag and drop game: 
1. Create three new layers. Put the images “tree.gif”, “place.gif”, and “flower.gif” into the 

layers.  
2. Rename the layer names to be “tree”, “flower”, and “ground”. 
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3. Click on the <body> tag at the bottom of the window (see Figure 15). 



4. Go to Behavior ► Add Behavior ► Drag Layer.  
5. Select desired layer name “tree” (see Figure 16). 
6. Click OK. 
7. Repeat step 3-6 for “flower” layer. 
8. Save the file and preview in browser. Inside the browser, users should be able to click 

and drag the tree and the flower to anywhere. 

 

 

Figure 15 - The Body Tag 

Figure 16 - Drag Layer Window 
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To create a puzzle game: 
1. Put the image “pokergray.gif” into a layer. Change the layer name to “pokergray”. 
2. Put the image “heart.gif” into a layer. Change the layer name to “heart”. 
3. Adjust the location so that the heart layer can overlap on pokergray layer. 
4. Click on the <body> tag at the bottom of the window (see Figure 17). 
5. Go to Behavior ► Drag Layer. 
6. Select the desired layer named “heart”. Press the Get current position button to set the 

destination.  
7. Type “70” into the Pixels of drop target text box so when the object approaches the 

destination, it will snap automatically (see Figure 18). 
8. Click OK. 
9. Move the heart layer to another blank area. 
10. Repeat step 2-9 to finish the club, spade, and diamond. 
11. Save the file and preview in browser. 

 
Figure 17 - Overlap Layers 



 

 

Figure 18 - Drag Layer Window (Puzzle) 

Swap Image: 
1. Insert a table (2 rows 4 columns). Merge the first row. 
2. Insert “pic01.jpg” into the first row. 
3. Insert “t2.gif”, “t3.gif”, “t4.gif”, and “t5.gif” into the second row. 
4. Remember to name each image in the Properties panel. 
5. Select “t2.gif” ►Add behavior ► Swap Image to open the window (see Figure 19). 

 

Select the 
picture that 
will have the 
effect. 

Use the browse 
button to select 
the picture that 
the effect will 
be applied to. 

Figure 19 - Set Swap Image 

6. Images: select image “pic01”. 
7. Set source to: click the Browse button look for “pic02.jpg”. Click OK. 
8. Click OK. 
9. Repeat steps 4-8 to click t3, t4, t5 and select pic01 to pic03, pic04, and pic05. 
10. Save the file and preview in the browser to see the result. 
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