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Introduction 
Adobe Dreamweaver® is the widely used industry standard program for Web site creation. Using 
a design view to create the layout, code views to create scripting and backend, or split screen 
view to work on both simultaneously, users can easily create the page they desire. The added 
ability to integrate other Adobe Creative Suite software such as Photoshop, Illustrator, 
Fireworks, and Flash into the final page design is another benefit of the program. 
 
This Part introduces users to hyperimage, rollover image, hot spot image, including Flash text 
and Flash button. Not only that images are used to decorate page layout, they also have 
interactive functions which are crucial in Web site development.  

Using Adobe Fireworks 8 to Optimize Images 
The ultimate goal in Web graphics is to have quality images that can be downloaded as fast as 
possible. To do that optimization can be used. It is very helpful in reducing loading time in a 
Web site with a lot of images. The Editing tool that will be used is Adobe Fireworks 8. 

To launch Fireworks 8: 
1. Select the Start Menu ► All Programs ► Macromedia ► Macromedia Fireworks 8. 

To resize an image: 
1. Click  under the Open Recent Item section. The Open dialog box appears. 
2. In the Open dialog box, select the drive where the file is stored in the Look in: list box. 

Double-click the file name “pic01.jpg.” 
3. Once the file is opened, click in the gray area around the image to view the image 

properties in the Properties panel (see Figure 1). 

4. Click the  button. The Image Size dialog box appears. 
5. Under Pixel dimensions, change the Width   to 100 Pixels and the Height 

 will automatically change proportionately to 75 (see Figure 2). 
 

 

NOTE: When the Constrain proportions check box is checked, any change of the width or height 
will automatically match the proportion. 

6. Click the OK button. 
7. Repeat Steps 2-6 for images “pic02.jpg, pic03.jpg, and pic04.jpg.” 

Figure 1 - Image Properties 
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Figure 2 - Resizing an Image 

OPTIMIZING THE IMAGE 
To efficiently utilize images on a Web site, a low resolution images with smaller file size is 
preferrable. The .Gif file format, for example, usually has smaller file size and is a preferred file 
format for Web pages. By optimizing the image, users can customize what is best for their needs. 

To optimize an image: 
1. Select the Window menu and choose the Optimize option. The Optimize panel appears 

on the right side (see Figure 3). 
2. Click on the first drop down box to select an image type. 

3. Select the GIF WebSnap 256  option. 

NOTE: The Websnap option is chosen to convert all colors to its best matching Websafe color. 
Therefore more complex colors such as scarlet or crimson may simply be converted to red. 
Websafe colors are the 256 most common colors that can be processed on the simplest of 
computers for both Macintosh and Windows with a display setting of 256 colors. Most modern 
computers far exceed this limit with even lower end displays exceeding 200,000 colors, but to 
increase the viewing audience, the simplest possible choice is usually best. (see Table 1 for 
detailed information). 

4. All the other options can be left alone. 
5. Repeat steps 2-3 for images “pic02.jpg, pic03.jpg, and pic04.jpg.” 
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Figure 3 - Optimizing Image 

Table 1 - Optimization Options 
Optimization Setting Description
GIF Web 216 Converts all colors to Websafe colors. 

The color palette contains up to 216 
colors 

GIF WebSnap 256 Converts non-Websafe colors to the 
closest Websafe color. The color 
palette contains up to a maximum of 
256 colors. 

GIF WebSnap 128 Converts non-Websafe colors to their 
closest Websafe color. The color 
palette contains up to 128 colors. 

GIF Adaptive 256 A color palette that contains only the 
actual colors used in the image. The 
color palette contains up to a maximum 
of 256 colors. 

JPEG - Better Quality Set the quality to 80 and smoothing to 
0, resulting in a high- quality but 
larger graphic. 

JPEG - Smaller File Set the quality to 60 and smoothing to 
2, resulting in an image size smaller 
than a Better Quality JPEG, but with 
reduced quality. 

To save the optimized image: 
1. Go to File menu ► Save As…. 
2. Click the Save in: drop-down arrow and select the location to save the files. 
3. In the File Name: text box, type “t1” to change the file name. 
4. Select “GIF (*.gif)” from the Save as type: drop-down arrow (see Figure 4). 
5. Repeat Steps 1-4 for the images “pic02.jpg, pic03.jpg, and pic04.jpg.” 
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Figure 4 - Saving the Optimized Image 

Inserting an Image 
Images enhance a Web page and provide interactivity. Images can be inserted alone, within 
tables, or in layers. Since inserting large image files will cause the Web page to load slower. To 
solve the problem, image thumbnails will be inserted onto the actual Web page wile hyperlinks 
to the larger files will be created. 

INSERTING IMAGES INTO A TABLE 
Once the images are optimized and ready to be used as thumbnails, they will be inserted into a 
table.  

To insert multiple images into a table: 
1. Lunch Dreamweaver. 
2. Click  under the Open Recent Item section. The Open dialog box appears. 
3. In the Open dialog box, select the drive where the file is stored in the Look in: list box. 

Double-click the file name “part3_index.htm.” 
4. Click in the second row of the table under the “Picture” title. 

5. Select the Image  button on the Insert tool bar ► click the drop down arrow ► 
Image ► select “t1.gif” and click OK (see Figure 5). 

6. The Image Tag Accessibility Attributes dialog box appears. Click OK (see Figure 6). 
 

NOTE: If the picture is not shown properly, entering alternate text for the picture inside the 
Alternate text: text box can offer users more information about the picture. This step is optional. 

 
7. Click in the next table cells to insert “t2.gif, t3.gif, and t4.gif” images by repeating steps 

2-6. 
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Figure 5 - Select Image Source Dialog Box 

The file path 
can also be 
indicated here 

Enter the  
alternate  
text here 
(optional) 

Figure 6- Image Tag Accessibility Attributes Dialog Box 

USING THE IMAGE PROPERTIES TO ORGANIZE THE IMAGES 
The image properties have many options to edit the images such as resizing the image and 
naming the image.  Aligning the picture in the table is also possible in the image properties.  
 
To align the images in each of the table’s cells: 

1. Select the second row ► image “t1.gif.”  
2. Select the Align center  button under the image properties (see Figure 7). 
3. Repeat step 2 for the rest of the images in the table. 
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Figure 7 - Image Properties 

Table 2- Image Properties 
Field Description

 

Naming every image helps identify what each image is 
when using other features within Dreamweaver. 

 

The Width and Height textboxes show pixel size of 
the image. Images can be resized by changing the 
values in the textboxes. 

 

The Hotspot tools, which include Rectangular, Oval, 
and Polygon , are used in creating hotspots on an 
image. The Arrow is used for selecting images. 

 

This is the Source and Link box. The Source shows 
where the image source file is and the Link shows 
where the image links too. 

 
Target is used for hyperimages or hyperlinks. 
Options are as the following: 

• “_blank” means the target will open in a new 
window.  

• “_parent” will open the target in the parent 
frameset or window of the frame that contains 
the link.  

• “_self” means the target will open in the same 
frame or window.  

• “_top” will open the target in the full 
browser window, thereby removing all frames. 

• “_parent”,” _self”, and “_top” are only useful 
when applying framesets inside the Web page. 

 
The Alternate textbox allows users to display a 
screentip when a cursor is placed over an image or 
hyperimage. 

 
These two icons are used for editing images in Adobe
Fire Works which is an image editor program. 

 
The Crop icon is for cropping a part of image. 

 
The Brightness and contrast icon has option to 
change the brightness or contrast of that image. 

 
The Sharpen icon allows the user to sharpen the 
image (this option can cause distortion in the 
image). 

 
The Border textbox allows user to put a boarder 
around the images. 

USING THE IMAGE PROPERTIES TO NAME THE IMAGES 
All images should be named to prevent confusion in later activities. Some advanced options such 
as the swap option require users to name the image. 

To name the images: 
1. Select the second row ► image “t1.gif”. 
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2. Locate the text box on the left hand side of the image properties next to the mini image 
displayed of the original image (see Figure 8). 

3. Type in a desired name for the image.  Make sure the image name is recognizable and 
contains no spaces. 

4. Repeat steps 1-3 for all the images in the Web page, “t2.gif”, “t3.gif”, and “t4.gif.”  
 

 
Figure 8 - Naming the Image 

Creating Interactive Images 
Interactive images help enhance the Web page. The three types of interactive images are 
hyperimages, rollover images, and hotspot images. These three types of images have different 
functions and can be applied to images for different purposes.  

CREATING A HYPERIMAGE 
Hyperimages are used to create an image as a hyperlink which will redirect users to another 
location once the image is clicked.  Any image can be converted to a Hyperimage. 

To create a hyperimage: (Click the thumbnail to see enlarged picture). 
1. Click on the “t1.gif” picture.  
2. Go to the properties panel. 

3. In the  box under the Properties toolbar, click on the 
Browse for File button  to look for “pic01.jpg” (see Figure 9). 

4. Press the OK button. 
5. Set the Target drop down list   to be “_blank”. 
6. Repeat steps 1- 5 for “t2.gif, t3.gif, t4.gif.” 
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Figure 9 - Use Browse Button to Select File 

Practicing the concept: (Click the picture to link to another page) 
1. Press [Enter] after the “Back to Top” link so the cursor is at the very bottom of the page. 

2. Go to the Image  button on the Insert tool bar ► click on the drop down arrow ► 
Image ► Browse for “CSULAlogo.jpg” and press OK. 

3. To link the picture, click on the  button ► locate and select “part3_map.html” in the 
part 3 image folder► press OK.  

4. Change the Target to “_blank” to open the linked page in a new window. 
 

NOTE: When inserting the URL address, the completed address including “http://” is required at 
the beginning.  

ROLLOVER IMAGE 
The rollover image technique replaces the static image with another image once the mouse is 
hovering over it. For example, Image B is used as a rollover image for a static Image A. When a 
user hovers the mouse over Image A, what the user will see is Image B. 

To create rollover image: 
1. Click inside the first row, second column of the picture table. 

2. Go to the Image  button on the Insert tool bar ► click on the drop down arrow ► 
Rollover Image to open the Insert Rollover Image dialog box (see Figure 10). 

3. Type “Rollover” in the Image Name: text box. 
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Figure 10 - Insert Rollover Image Dialog Box 

4. For the Original Image textbox, click on the  button.  Find and select the file 
“lightbulb1.gif”. 

5. For the Rollover Image textbox, click on the  button.  Find and select the file 
“lightbulb2.gif”. 

6. Leave the “Preload Rollover image” checkbox checked. 
7. Press the OK button. 
8. Press [F12] to view the Web page in Internet Explorer. 
9. Move the cursor over the image inserted. The image changes from “lightbulb1.gif” to 

“lightbulb2.gif” (see Figure 11 and Figure 12). 
 

NOTE: When using the rollover image function, Dreamweaver uses the original image size as 
default. For the best result, the two images should be the same size.  

 
 

 
Figure 11 - Rollover Before 

 
Figure 12 - Rollover After 

 
 
 
 

 

CREATING A HOTSPOT IMAGE 
Creating a hotspot on an image allows a specific area of the image to link to a certain place. One 
image can contain multiple hotspots at one time. 
 
To create a hotspot: 

1. Click under the Map section. 

2. Go to the Image  button on the Insert toolbar ► click the drop-down arrow ► 
Image ► “oalmap.gif.” 

3. Click the “oalmap.gif” and use the Hotspots tool located under the Properties panel (see 
Figure 13). 

4. Click the Rectangular hotspot tool. Draw a rectangle over the ITS Office on the map 
(see Figure 14). 

5. After drawing the rectangle over the ITS Office, the Properties panel changed (see 
Figure 15). 
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6. Enter the URL address: [http://www.calstatela.edu/its] into the Link text box to set the 
hyperlink. Enter “Go to ITS Web site” into the Alt text box as the screen tip. Set the 
Target to “_blank” to have the target open in a new window. 

7. Save the Web page and view it in Internet Explorer by pressing [F12] on the keyboard. 
 

  
 
 
 

 
 

 

Figure 13 - Hotspot Tool Figure 14 – Drawing a Hotspot  

Polygon 
Hotspot Tool 

Oval Hotspot 
Tool 

Rectangular 
Hotspot Tool 

 

 
Figure 15 - Set Up the Hotspot Properties 

Practicing the concept: 
1. Click on File ► Open ► Find “part3_map.html” and press OK. 
2. Make sure the image is selected and choose the Oval  Hotspot tool. 

3. Draw a circle on the  below the Library North building on the image (see Figure 16). 
In the Link Box Enter [http://www.calstatela.edu/library]. 

4. Change the target to “_blank” and enter “Go to CSULA library Web site” in the Alt box. 

 

 
Figure 16 - Hotspot Tool 

FLASH TEXT AND FLASH BUTTON 
Dreamweaver contains some easy-to-use flash objects that users can apply for a fancier interface. 
Flash text and Flash buttons offer special effects that activate when users hover their mouse over 
the text or button.  
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To create a Flash text: 
1. Open the “flashtext1.htm” file. 
2. Click after the text “For example:” in the Flash text section. 
3. Go to Insert ► Media ► Flash text 
4. The Insert Flash Text dialog box shows (see Figure 17). 
5. Enter the desired text in Text: text box and check the Show font check box to preview 

the result. 
6. Change the other defaults for font, size, font color, rollover color, and background color. 
7. Enter the hyperlink address and set the Target as “_blank”. 
8. Click OK. 
9. The Flash Accessibility Attributes dialog box shows. Click OK (see Figure 18). 
10. Save the file and view it in Internet Explorer. 

 

 

Figure 17 - Insert Flash Text Dialog Box 

Figure 18 - Flash Accessibility Attributes Dialog Box 
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To create a Flash button: 
1. Click after the text “For example:” in the flash button section. 
2. Go to Insert ►Media ►Flash button. 
3. The Insert Flash Button dialog box shows (see Figure 19). 
4. Select one button template from the Style spinbox. 

 
NOTE: Move the mouse to Sample: box on the particular template to preview the result. 

 
5. Enter desired text into the Button text: text box. 
6. Change the Font, Size, and background color as desired. 
7. Enter the link location including “http://” and set the Target as “_blank”. 
8. Click OK. 
9. Click OK again. 
10. Save the file and view it in Internet Explorer. 

 
Figure 19 - Insert Flash Button Dialog Box 
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